Snap branches all show with same name

Bug #1768794 reported by Michal Predotka on 2018-05-03
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-software (Ubuntu)
High
Robert Ancell
Bionic
High
Robert Ancell
Cosmic
High
Robert Ancell

Bug Description

[Impact]
Snaps with multiple branches (e.g. communitheme) all show in GNOME Software with the branches having the same name.

Steps to reproduce:
1. Search for ”communitheme”
2. Select ”communitheme” result
3. Click on the channel selection button
4. You will see a popup with loooooong list of channels

Expected result:
All branches/channels are shown.

Observed result:
All branches have the same name.

[Regression Potential]
Fix was an invalid iterator, unlikely to cause further issues.

Michal Predotka (mpredotka) wrote :
Sebastien Bacher (seb128) wrote :

bug #1768779 has details

Changed in gnome-software (Ubuntu):
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

Robert, is the list we display coming directly from snapd? or a bug in g-s/snapd-glib?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
Robert Ancell (robert-ancell) wrote :

Note this doesn't occur in Xenial as the code changes required for backport fixed the issue there. Though the communitheme doesn't show (LP: #1763736)

no longer affects: gnome-software (Ubuntu Xenial)
Changed in gnome-software (Ubuntu Bionic):
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-software (Ubuntu Cosmic):
status: Confirmed → Fix Committed
summary: - A lot of the same entries for Communitheme snap channels
+ Snap branches all show with same name
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu6

---------------
gnome-software (3.28.1-0ubuntu6) cosmic; urgency=medium

  * debian/patches/0011-Support-snap-channels.patch:
    - Make snap channel selection list scrollable (LP: #1768779)
    - Fix channel branches all showing the same name (LP: #1768794)
    - Alphabetically sort channel branch names (LP: #1769556)

 -- Robert Ancell <email address hidden> Mon, 07 May 2018 16:31:46 +1200

Changed in gnome-software (Ubuntu Cosmic):
status: Fix Committed → Fix Released

Hello Michal, or anyone else affected,

Accepted gnome-software into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-software/3.28.1-0ubuntu4.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
John Lenton (chipaca) wrote :

FWIW there's a bug store-side, as it shouldn't be exposing branches at all.

John Lenton (chipaca) wrote :

OTOH what the client should be doing is looking at 'tracks' to get the order of the channels, and then using that to look up each track in the map; this would've avoided the issue (but not the info leak which is still a bug)

William Grant (wgrant) wrote :

The bug has been fixed and the server no longer advertises branches.

Robert Ancell (robert-ancell) wrote :

We are using 'tracks' in the order as provided, it was the branches under the tracks that wasn't handled correctly (hadn't seen any in the wild at the time).

Michal Predotka (mpredotka) wrote :

Seems to be fixed in 18.04. Although due to this fix I can't test the fix for the bug #1768779

SRU verification for Bionic:
I have reproduced the problem with gnome-software 3.28.1-0ubuntu4 in bionic and have verified that the version of gnome-software 3.28.1-0ubuntu4.18.04.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-software - 3.28.1-0ubuntu4.18.04.1

---------------
gnome-software (3.28.1-0ubuntu4.18.04.1) bionic; urgency=medium

  * debian/patches/0011-Support-snap-channels.patch:
    - Fix incorrect default install version being shown (LP: #1767445)
    - Make snap channel selection list scrollable (LP: #1768779)
    - Fix channel branches all showing the same name (LP: #1768794)
    - Alphabetically sort channel branch names (LP: #1769556)
  * debian/control:
    - Use bionic Vcs link

 -- Robert Ancell <email address hidden> Mon, 07 May 2018 16:32:37 +1200

Changed in gnome-software (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-software has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers