Network icons in status menu disappearing

Bug #1774957 reported by Forage
122
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-shell (Ubuntu)
Invalid
Undecided
Unassigned
Bionic
Fix Committed
Medium
Iain Lane
Cosmic
Fix Released
Medium
Iain Lane
Disco
Invalid
Undecided
Unassigned

Bug Description

https://gitlab.gnome.org/GNOME/gnome-shell/issues/140

---

Ever since the update to Ubuntu 18.04 I'm having issues with the status menu at the top right of the screen.

Normally you'd have a wired network connection icon displayed at the top without opening the menu. In my case it is not displayed half of the time. In the menu list no icon nor label is displayed for the wired connection menu item.
When talking about half of the time it means that I can randomly make it display again when removing the USB network adapter and reconnecting it e.g.
This does not work reliably though.

When connecting to a VPN, normally you'd get an additional icon at the top. This is not the case any more, nor does the switch behind an activated VPN turns change to an active state. The result is that you can activate a VPN using the switch, but you can verify that it is activated, nor can you de-active the VPN through the menu. This does change in settings though.

Wireless settings are no longer displayed in the menu at all. So no way to activate it or connect to a specific network.

I tried reconfiguring (dpkg-reconfigure) gnome-shell as well as network-manager-gnome, to no avail.

Attached you'll find a screenshot illustrating the issue. You'll see two icons missing to the left of the volume icon, as well as the wireless menu missing completely and no icon and text label for the wired connection menu item.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.1-0ubuntu2
ProcVersionSignature: Ubuntu 4.15.0-22.24-generic 4.15.17
Uname: Linux 4.15.0-22-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Jun 4 10:47:05 2018
DisplayManager: gdm3
EcryptfsInUse: Yes
InstallationDate: Installed on 2016-10-07 (604 days ago)
InstallationMedia: Ubuntu-GNOME 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160720)
SourcePackage: gnome-shell
UpgradeStatus: Upgraded to bionic on 2018-05-31 (3 days ago)

Revision history for this message
Forage (forage) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Revision history for this message
Václav Pavlík (pavl-va) wrote :

I have the same problem.

On a newly upgraded Ubuntu 18.04 with Gnome 3.28, the system menu on the right in the top panel is missing entries, if booted with an ethernet connection. If booted without ethernet (with or without wifi) all the entries are there.

Replicable: yes
How to: Boot (or restart Gnome by Alt-F2, r, Enter) with the ethernet cable connected - icons are missing (see screenshot 1).
Workaround: Boot (or restart Gnome by Alt-F2, r, Enter) with the ethernet cable disconnected - all the icons are there (see screenshot 2). Then connect the ethernet cable (see screenshot 3).

This workaround is, however, not a permanent solution...

Revision history for this message
Václav Pavlík (pavl-va) wrote :
Revision history for this message
Václav Pavlík (pavl-va) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :
description: updated
Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
Changed in gnome-shell (Ubuntu):
assignee: nobody → Iain Lane (laney)
status: Confirmed → In Progress
Revision history for this message
Lurkars (lurkars) wrote :

I could hot-fix this problem by changing network configuration via nm-connection-editor. In my case the "Connection priority for auto-activation" was set to -999 for one Ethernet configuration. After changing it to 0 and reconnect, the icons re-appeared. So it is maybe an issue of malformed/weird configuration.

Revision history for this message
Ahmad Amr (aamr) wrote : Re: [Bug 1774957] Re: Network icons in status menu disappearing

I changed it to 0 as well, fingers crossed.

Kind Regards,

Ahmad Amr

On Wed, Aug 22, 2018, 11:37 AM Lukas Haubaum <email address hidden>
wrote:

> I could hot-fix this problem by changing network configuration via nm-
> connection-editor. In my case the "Connection priority for auto-
> activation" was set to -999 for one Ethernet configuration. After
> changing it to 0 and reconnect, the icons re-appeared. So it is maybe an
> issue of malformed/weird configuration.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1785818).
> https://bugs.launchpad.net/bugs/1774957
>
> Title:
> Network icons in status menu disappearing
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1774957/+subscriptions
>

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

A couple of fixes are being worked on right now in the upstream bug:

https://gitlab.gnome.org/GNOME/gnome-shell/issues/140

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

The fix landed upstream in master, but it was _after_ tag 3.30.0. So the fix is either in gnome-shell version 3.32.0 or 3.30.1 ...?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix released in gnome-shell 3.30.1 (Ubuntu 18.10 onward).

Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
javen (jwli) wrote :

the fix released in gnome-shell 3.30.1 only available for Ubuntu 18.10. is right?
if it possible to released patch for Ubuntu 18.04?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Yes, 18.04 has been nominated to receive the fix.

Revision history for this message
boris (atomtm) wrote :

Same here! There are times my Wifi icon and the VPN icon when connecting to a VPN service are missing.
When extending the panel you can't use the switches to enable VPN configuration and the VPN is indicating to off although connencted.

Changed in gnome-shell (Ubuntu):
milestone: none → ubuntu-18.04.2
milestone: ubuntu-18.04.2 → none
Revision history for this message
Sasa Batistic (sasa-batistic) wrote :

it's the same in GNOME 3.30 (Ubuntu 18.10).

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Sasa,

That doesn't sound right. I thought the fix for this bug was already in Ubuntu 18.10. Can you please check again what version of the 'gnome-shell' package you have installed and also attach a screenshot of what you see?

Revision history for this message
Forage (forage) wrote :

For what it's worth, since the update to 18.10 I have not seen the issue again on the two systems I have.

Revision history for this message
Diego Foglino (biker84) wrote :

I have Ubuntu mate 18.04.2. I don't have gnome-shell installed.
There is this bug.

Revision history for this message
Ian McMichael (ian-sigma-uk) wrote :

According to https://gitlab.gnome.org/GNOME/gnome-shell/issues/140 this is fixed in Gnome Shell 3.30.1 & 3.28.4. Any chance of getting 3.28.4 (or the fix) in 18.04 LTS desktop?

Revision history for this message
Alexey (alexey-muranov) wrote :

There is no 3.28.4 release yet: https://gitlab.gnome.org/GNOME/gnome-shell/tags

Revision history for this message
javen (jwli) wrote :

When will the fix be included in Ubuntu 18.04?this issue has been bothering me for a long time.
and another issue that the gnome-shell always crash every time wake up the screen.
the user experience couldn't be worse....

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Found the fix is in gnome-shell_3.28.3+git20190124.orig.tar.xz, which means it is in bionic-proposed right now:

https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3+git20190124-0ubuntu18.04.1

Changed in gnome-shell (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Iain Lane (laney)
status: Triaged → Fix Committed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

And you can download the .deb files containing the fix for Ubuntu 18.04 amd64 here:

https://launchpad.net/ubuntu/+source/gnome-shell/3.28.3+git20190124-0ubuntu18.04.1/+build/16422548

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

javen,

If you experience crashes then please log new bugs for those.

Changed in gnome-shell (Ubuntu Cosmic):
status: New → Fix Released
importance: Undecided → Medium
assignee: nobody → Iain Lane (laney)
Changed in gnome-shell (Ubuntu Disco):
status: Fix Released → Invalid
assignee: Iain Lane (laney) → nobody
importance: Medium → Undecided
Revision history for this message
Andrei (and741) wrote :

Daniel, how do I know which of the three deb-files

gnome-shell-common_3.28.3+git20190124-0ubuntu18.04.1_all.deb (179.2 KiB)
gnome-shell-dbgsym_3.28.3+git20190124-0ubuntu18.04.1_amd64.ddeb (1.1 MiB)
gnome-shell_3.28.3+git20190124-0ubuntu18.04.1_amd64.deb (650.2 KiB)

from that page I should install?

I tried to install the first one and it completely messed up my log in procedure with the error "failed to start session" showing up at log in. I spent half a day fixing that.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

You can safely install all three, but you only need two: *.deb

You don't need *.ddeb

Revision history for this message
Marco Ferretti (marco-ferretti) wrote :

I am still experiencing the issue on ubuntu 18.04.4 :

dpkg -s gnome-shell
Package: gnome-shell
Status: install ok installed
Priority: optional
Section: universe/gnome
Installed-Size: 7350
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 3.28.3-0ubuntu0.18.04.4
Provides: notification-daemon, polkit-1-auth-agent
Depends: libatk-bridge2.0-0 (>= 2.5.3), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.14), libcairo2 (>= 1.14.0), libcanberra-gtk3-0 (>= 0.25), libcanberra0 (>= 0.2), libcroco3 (>= 0.6.2), libecal-1.2-19 (>= 3.17), libedataserver-1.2-23 (>= 3.17.2), libgcr-base-3-1 (>= 3.8.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libgirepository-1.0-1 (>= 1.35.9), libgjs0-libmozjs-52-0, libgjs0g (>= 1.52.1), libglib2.0-0 (>= 2.53.0), libgstreamer1.0-0 (>= 1.4.0), libgtk-3-0 (>= 3.21.6), libical3 (>= 3.0.0), libjson-glib-1.0-0 (>= 0.13.2), libmutter-2-0 (>= 3.28.3), libnm0 (>= 1.0.0), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libpolkit-agent-1-0 (>= 0.99), libpolkit-gobject-1-0 (>= 0.94), libpulse-mainloop-glib0 (>= 0.99.1), libpulse0 (>= 0.99.1), libsecret-1-0 (>= 0.7), libstartup-notification0 (>= 0.11), libsystemd0, libx11-6, libxfixes3, evolution-data-server (>= 3.17.2), gir1.2-accountsservice-1.0, gir1.2-atspi-2.0 (>= 2.9.91), gir1.2-freedesktop, gir1.2-gdesktopenums-3.0 (>= 3.12), gir1.2-geoclue-2.0, gir1.2-gcr-3 (>= 3.7.5), gir1.2-gdm-1.0 (>= 3.18.2), gir1.2-glib-2.0 (>= 1.45.3), gir1.2-gnomebluetooth-1.0 (>= 3.12.0), gir1.2-gnomedesktop-3.0 (>= 3.12.0), gir1.2-gtk-3.0 (>= 3.16), gir1.2-gweather-3.0, gir1.2-ibus-1.0 (>= 1.5.2), gir1.2-mutter-2 (>= 3.27.91), gir1.2-nm-1.0, gir1.2-nma-1.0, gir1.2-pango-1.0, gir1.2-polkit-1.0, gir1.2-rsvg-2.0, gir1.2-soup-2.4 (>= 2.40.1), gir1.2-upowerglib-1.0 (>= 0.99), gjs (>= 1.47.90), gnome-settings-daemon (>= 3.16.0), gnome-shell-common (= 3.28.3-0ubuntu0.18.04.4), ubuntu-wallpapers, gsettings-desktop-schemas (>= 3.21.3), mutter (>= 3.27.91), python3, libglib2.0-bin (>= 2.53.0)
Recommends: xserver-xorg-legacy, bolt (>= 0.2), gkbd-capplet, gnome-control-center, gnome-user-guide, iio-sensor-proxy, unzip, ubuntu-session | gnome-session
Suggests: gir1.2-telepathyglib-0.12, gir1.2-telepathylogger-0.2 (>= 0.8.0), chrome-gnome-shell, gdm3 (>= 3.10.0.1-3~), gnome-themes-standard-data, switcheroo-control
Breaks: gdm3 (<< 3.19.92), gnome-session (<< 3.19)
Conflicts: gnome-screensaver (<< 3.6)
Description: graphical shell for the GNOME desktop
 The GNOME Shell provides core interface functions like switching
 windows, launching applications or see your notifications. It takes
 advantage of the capabilities of modern graphics hardware and
 introduces innovative user interface concepts to provide a
 delightful and easy to use experience. GNOME Shell is the defining
 technology of the GNOME 3 user experience.
Homepage: https://wiki.gnome.org/Projects/GnomeShell
Original-Maintainer: Debian GNOME Maintainers <email address hidden>

Revision history for this message
Marco Ferretti (marco-ferretti) wrote :

p.s.: restarting gnome-shell (with SIGQUIT) works as a temporary patch.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Marco,

You are missing the fix for this bug. See comment #23.

Revision history for this message
Marco Ferretti (marco-ferretti) wrote :

Hi Daniel,

will install the patch later today and let you know.

Thanks for pointing me to a possible solution (I completely missed it).

Revision history for this message
Ian McMichael (ian-sigma-uk) wrote :

Looking good on 18.04.1 LTS Desktop. I have installed the patch from comment #23 and the network icon now appears consistently on both the status bar and the status menu.

Revision history for this message
Marco Ferretti (marco-ferretti) wrote :

Following up on #30 and #29 I can confirm that ubuntu 18.04.2 is working fine with the patch from comment #23

Thanks a lot for the support !

Revision history for this message
javen (jwli) wrote :

Hi

gnome-shell crash when lock the screen, I don't known if it cause by new gnome-shell(3.28.3+git20190124-0ubuntu18.04.1), Please confirm.

the syslog attached, lock screen at 'Mar 19 09:37:55'

==========
dpkg -l |grep gnome-shell

ii chrome-gnome-shell 10-1 all GNOME Shell extensions integration for web browsers
ii gnome-shell 3.28.3+git20190124-0ubuntu18.04.1 amd64 graphical shell for the GNOME desktop
ii gnome-shell-common 3.28.3+git20190124-0ubuntu18.04.1 all common files for the GNOME graphical shell
ii gnome-shell-extension-appindicator 18.04.1 all App indicators for GNOME Shell
ii gnome-shell-extension-ubuntu-dock 0.9.1ubuntu18.04.3 all Ubuntu Dock for GNOME Shell

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

javen,

Please follow these instructions:

https://wiki.ubuntu.com/Bugs/Responses#Missing_a_crash_report_or_having_a_.crash_attachment

and ideally continue any discussion about crashes in a new bug.

Revision history for this message
e-fernbach (e-fernbach) wrote :

Ubuntu 18.04.2 Gnome
had the problem described above, followed #23 and now my Xserver doesn't work anymore. I am stuck at a terminal.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers