[regression] gnome-shell crashed with SIGTRAP in g_realloc_n() from g_log_structured()

Bug #1758035 reported by Maciej Borzecki on 2018-03-22
142
This bug affects 20 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
gnome-shell (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

https://errors.ubuntu.com/problem/bf61cf0ebedaacbd48f7c12574f551fea3f706c7
https://errors.ubuntu.com/problem/bc2bd5031309e8cf2314785805634f998452e937
https://errors.ubuntu.com/problem/f30049f514bf17053fe0461bf2b0890e46ad32dd

---

Freshly installed bionic.

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: gnome-shell 3.28.0-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: GNOME-Greeter:GNOME
Date: Thu Mar 22 12:22:58 2018
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2018-03-22 (0 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180321)
ProcCmdline: /usr/bin/gnome-shell
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 g_realloc_n () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_log_structured () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
Title: gnome-shell crashed with signal 5 in g_realloc_n()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

StacktraceTop:
 g_realloc_n () from /tmp/apport_sandbox_d15w8xzz/lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_log_structured () from /tmp/apport_sandbox_d15w8xzz/lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /tmp/apport_sandbox_d15w8xzz/lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /tmp/apport_sandbox_d15w8xzz/lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
summary: - gnome-shell crashed with signal 5 in g_realloc_n()
+ gnome-shell crashed with SIGTRAP in g_realloc_n() from
+ g_log_structured()
information type: Private → Public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

No reports of this new crash on errors.ubuntu.com yet, but I think we can expect to see it there soon.

Brian Murray (brian-murray) wrote :

There is a bit of a backlog which the errors.ubuntu.com retracers are working through so it could be a while.

Daniel van Vugt (vanvugt) wrote :

This looks like maybe a regression in this (which was published the day before the first crash report):

https://launchpad.net/ubuntu/+source/glib2.0/2.56.0-2ubuntu1

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in gnome-shell (Ubuntu):
importance: Undecided → High
summary: - gnome-shell crashed with SIGTRAP in g_realloc_n() from
+ [regression] gnome-shell crashed with SIGTRAP in g_realloc_n() from
g_log_structured()
tags: added: regression-update rls-bb-incoming
description: updated
tags: removed: rls-bb-incoming
Changed in gnome-shell (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
Iain Lane (laney) on 2018-04-03
Changed in glib2.0 (Ubuntu Bionic):
assignee: nobody → Daniel van Vugt (vanvugt)

I think this is just a false-positive, as we're probably crashing before or aborting but then we fail at the point we try to get the gjs stack.

So, probably we should get journalctl from such crashes to see if any JS calltrace is there.

Daniel van Vugt (vanvugt) wrote :

That sounds plausible.

Also there are zero reports of this crash after gnome-shell 3.28.0. So zero crashes in Ubuntu 18.10, and zero crashes since the final release of Ubuntu 18.04.

The only systems still crashing seem to be pre-release bionic systems that haven't been updated for most of the year.

I think this looks fixed already. Maybe fixed as early as the final release of 18.04.

Changed in glib2.0 (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in glib2.0 (Ubuntu Bionic):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in gnome-shell (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in gnome-shell (Ubuntu Bionic):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in glib2.0 (Ubuntu):
status: Confirmed → Incomplete
Changed in glib2.0 (Ubuntu Bionic):
status: Confirmed → Incomplete
Changed in gnome-shell (Ubuntu):
status: Confirmed → Incomplete
Changed in gnome-shell (Ubuntu Bionic):
status: Confirmed → Incomplete
Changed in glib2.0 (Ubuntu):
status: Incomplete → Fix Released
Changed in glib2.0 (Ubuntu Bionic):
status: Incomplete → Fix Released
Changed in gnome-shell (Ubuntu):
status: Incomplete → Fix Released
Changed in gnome-shell (Ubuntu Bionic):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers