gnome-initial-setup runs for upgraders in GNOME session & deletes alternate keymaps

Bug #1765644 reported by Julian Andres Klode on 2018-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

After installing gnome-initial-setup, and logging out and back in to a GNOME session, gnome-initial-setup runs. Going through it, and accepting the defaults, it correctly picks up my configuration AFAICT, but for keymaps, it only keeps the first one.

Simple way out is to not run g-i-s in GNOME sessions, other is to make keymap setup non-destructive wrt alternative keymaps.

Iain Lane (laney) on 2018-04-20
Changed in gnome-initial-setup (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Robert Ancell (robert-ancell)
Jeremy Bicha (jbicha) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

summary: - After install, runs in gnome session after logging in again, deletes
+ gnome-initial-setup runs for upgraders in GNOME session & deletes
alternate keymaps
Jeremy Bicha (jbicha) wrote :

It's intentional that gnome-initial-setup run at first login after being installed. Yes, that means it will run for upgraders. I don't think we want to change that.

Ubuntu GNOME 17.04 installed gnome-initial-setup by default but I guess you just installed gnome-session and not vanilla-gnome-desktop.

Sebastien Bacher (seb128) wrote :

I don't think Robert is working on that one

Changed in gnome-initial-setup (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in gnome-initial-setup (Ubuntu Bionic):
assignee: Robert Ancell (robert-ancell) → nobody
Iain Lane (laney) wrote :

Not sure we're going to SRU this one :(

tags: added: rls-bb-notfixing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers