Drop fwupdate from the archive

Bug #1841744 reported by Will Cooke on 2019-08-28
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Yuan-Chen Cheng
fwupdate (Ubuntu)
Wishlist
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
lubuntu-meta (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
ubuntu-unity-meta (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

Further to this bug report:
https://bugs.launchpad.net/ubuntu/+source/fwupdate/+bug/1787254

We can now move forward and remove fwupdate from the archive. The new tool fwupd replaces fwupdate, and fwupdate is now seen as legacy.

This won't have any effect on the ability to update firmware etc, the tooling all uses fwupdmgr.

I would like to get Mario's +1 on this bug report before we proceed and to make sure that my assertions are correct.

Mario Limonciello (superm1) wrote :

Sounds fine by me

Sebastien Bacher (seb128) wrote :

Removing packages from eoan:
 fwupdate 12-3ubuntu2 in eoan
  fwupdate 12-3ubuntu2 in eoan amd64
  fwupdate 12-3ubuntu2 in eoan arm64
  fwupdate 12-3ubuntu2 in eoan armhf
  fwupdate 12-3ubuntu2 in eoan i386
  fwupdate-amd64-signed-template 12-3ubuntu2 in eoan amd64
  fwupdate-arm64-signed-template 12-3ubuntu2 in eoan arm64
  fwupdate-armhf-signed-template 12-3ubuntu2 in eoan armhf
  fwupdate-i386-signed-template 12-3ubuntu2 in eoan i386
  libfwup-dev 12-3ubuntu2 in eoan amd64
  libfwup-dev 12-3ubuntu2 in eoan arm64
  libfwup-dev 12-3ubuntu2 in eoan armhf
  libfwup-dev 12-3ubuntu2 in eoan i386
  libfwup1 12-3ubuntu2 in eoan amd64
  libfwup1 12-3ubuntu2 in eoan arm64
  libfwup1 12-3ubuntu2 in eoan armhf
  libfwup1 12-3ubuntu2 in eoan i386
Comment: superseeded by fwupd
Remove [y|N]? y
1 package successfully removed.

Changed in fwupdate (Ubuntu):
importance: Undecided → Wishlist
status: New → Fix Released
Yuan-Chen Cheng (ycheng-twn) wrote :

LGTM, thank you.

Steve Langasek (vorlon) wrote :

fwupdate has been re-added to eoan because it has reverse-dependencies.

This is a package that's still in Debian unstable. "No longer needed" is not normally a valid rationale for removing a package from Ubuntu devel that is still included in Debian. In cases where it is important to remove the package despite still being in Debian, then it also needs to be added to the sync blacklist.

Changed in fwupdate (Ubuntu):
status: Fix Released → Incomplete
Mario Limonciello (superm1) wrote :

I believe adding it to the sync blacklist makes sense.

Mario Limonciello (superm1) wrote :

>fwupdate has been re-added to eoan because it has reverse-dependencies.

Adding tasks for the two metapackages still sourcing fwupdate.

Mario Limonciello (superm1) wrote :

I was looking for the seeds for ubuntu-unity, and I don't see it's been updated since bionic. Also I don't see it present in https://ubuntu.com/download/flavours.

Should this ubuntu-unity-meta be dropped from the archive as well?

Changed in lubuntu-meta (Ubuntu):
status: New → Fix Committed
Mario Limonciello (superm1) wrote :
Changed in lubuntu-meta (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

> Should this ubuntu-unity-meta be dropped from the archive as well?

If you think that's appropriate, please file a separate bug report on that; subscribe ubuntu-archive; assign it to the Ubuntu developer who uploaded ubuntu-unity-meta; and provide the bug number here.

Mario Limonciello (superm1) wrote :

#9:
I've filed bug 1842014 for that purpose

Changed in ubuntu-unity-meta (Ubuntu):
status: New → Triaged
Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
Yuan-Chen Cheng (ycheng-twn) wrote :

Still saw fwupdate have rdepends on ubuntu-unity-desktop. Not sure what's the next action item, since LP: #1842014 is invalid? We need to land it?

Changed in oem-priority:
status: New → Confirmed
importance: Undecided → High
Rex Tsai (chihchun) on 2019-09-04
tags: added: oem-priority
Mario Limonciello (superm1) wrote :

For ubuntu-unity-meta I asked the maintainer in #1842014 to update it but they didn't yet. Considering the urgency here, I took matters into my hands:

1) Ported https://code.launchpad.net/~unity7maintainers/ubuntu-seeds/ubuntu-unity.cosmic -> https://code.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/+git/ubuntu-unity

2) Updated ubuntu-unity-meta to reference eoan. Due to how germinate works, it falls back to https://code.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/+git/ubuntu-unity when https://code.launchpad.net/~unity7maintainers/ubuntu-seeds/ubuntu-unity.oean doesn't exist.

3) Refreshed dependencies using ./update

4) Uploaded to eoan

So I believe that Ubuntu plans can continue now.

That said there is discussion in Debian now to turn fwupdate into a transitional package with something like this (advice welcome).
https://salsa.debian.org/efi-team/fwupdate/commit/b4daba89c567d4cf52f5deaab1ea2ee13039d03f

Khurshid Alam (khurshid-alam) wrote :

@Mario Limonciello

I did not respond because I was busy with breakage in other unity related packages. You should give us time to do that specially when you filed the bug one week ago.

Now we don't have access to ~ubuntu-core-dev, we can't change those.

Also you are doing it wrong.

1. First you should clone lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.cosmic and then update structure and then push it as lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.eoan.

2. Then you change the update.config in https://code.launchpad.net/~unity7maintainers/ubuntu-unity-meta/

3. Only then you run a ./update.

4. git push launchpad master

As of now it is not clear how do I push a new update ? It's broken.

Mario Limonciello (superm1) wrote :
Changed in ubuntu-unity-meta (Ubuntu):
status: Triaged → Fix Released
Mario Limonciello (superm1) wrote :

fwupdate 12-6 was uploaded into Debian to do a transition there->fwupd. After bullseye release will propose it to remove from Debian archive.

It's up to Ubuntu archive admins to either accept the same transition package (I tested it on Ubuntu w/ a local apt repo and it worked just fine for me) or to remove fwupdate from archive entirely without transition package.

Mario Limonciello (superm1) wrote :

@kurshid-alam:
>I did not respond because I was busy with breakage in other unity related packages. You should give us time to do that specially when you filed the bug one week ago.

This bug has been actually a response to bug #1820768 which has been open a very long time. A simple "I'm working on it" would have helped. More comments below:

> 1. First you should clone lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.cosmic and then update structure and then push it as lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.eoan.

Yes I updated STRUCTURE to point to platform.eoan, but I don't have permissions to push to that location. That's why I opted to push to ~ubuntu-core-dev, the fallback logic will pull from there instead if necessary. You can push to this location (lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.eoan) now for your next revision.

> 2. Then you change the update.config in https://code.launchpad.net/~unity7maintainers/ubuntu-unity-meta/

Again, don't have permissions to update this. I have just emailed you the local patch for it so you can update your git.

> As of now it is not clear how do I push a new update ? It's broken.

I'm happy to help work with you on this offline to re-enable your workflow (and sponsor your next package when it's ready), please email me.

On Wed, Sep 04, 2019 at 05:33:32PM -0000, Mario Limonciello wrote:
> > 1. First you should clone lp:~unity7maintainers/ubuntu-seeds/ubuntu-
> unity.cosmic and then update structure and then push it as
> lp:~unity7maintainers/ubuntu-seeds/ubuntu-unity.eoan.

> Yes I updated STRUCTURE to point to platform.eoan, but I don't have
> permissions to push to that location. That's why I opted to push to
> ~ubuntu-core-dev, the fallback logic will pull from there instead if
> necessary. You can push to this location (lp:~unity7maintainers/ubuntu-
> seeds/ubuntu-unity.eoan) now for your next revision.

It is in my view inappropriate for any seeds, or authoritative VCS branches
for Ubuntu packages, to be owned by a team that does not have
ubuntu-core-dev as a member - since ubuntu-core-dev are defined as the team
that has upload rights, and oversight responsibility, for the entire
archive.

So if someone could please update ~unity7maintainers to add
~ubuntu-core-dev, that would be a good idea.

@Mario Limonciello

Hi, I understood what you did. I have now updated the bzr branch and then run update and pushed changes to lp:ubuntu-unity-meta. Since, now, the changelog version is 0.3 there should not be any problem uploading over 0.2. Note I dropped all architectures except amd64 and i386 since Unity doesn't really work on other arch. If it is a issue we can change that.

I have also send invitation to ubuntu-core-dev to join ~unity7maintainers team.

Thanks.

Mario Limonciello (superm1) wrote :

You're missing the changes that went in for 0.2 in your branch, at least the changelog should be mentioned before the 0.3 release. I did send you these over email in lieu of availability to commit to the branch yet.
Also you need to drop the non-x86 architectures in debian/control, and remove the unneeded files from the source root as well.

Steve Langasek (vorlon) wrote :

fwupdate 12-6 is not yet available for syncing, so I will go ahead and remove fwupdate for now. Any core-dev is free to sync the package once it becomes available, it will just land in the NEW queue (but it'd be a quick review).

Steve Langasek (vorlon) wrote :

Removing packages from eoan:
 fwupdate 12-3ubuntu2 in eoan
  fwupdate 12-3ubuntu2 in eoan amd64
  fwupdate 12-3ubuntu2 in eoan arm64
  fwupdate 12-3ubuntu2 in eoan armhf
  fwupdate 12-3ubuntu2 in eoan i386
  fwupdate-amd64-signed-template 12-3ubuntu2 in eoan amd64
  fwupdate-arm64-signed-template 12-3ubuntu2 in eoan arm64
  fwupdate-armhf-signed-template 12-3ubuntu2 in eoan armhf
  fwupdate-i386-signed-template 12-3ubuntu2 in eoan i386
  libfwup-dev 12-3ubuntu2 in eoan amd64
  libfwup-dev 12-3ubuntu2 in eoan arm64
  libfwup-dev 12-3ubuntu2 in eoan armhf
  libfwup-dev 12-3ubuntu2 in eoan i386
  libfwup1 12-3ubuntu2 in eoan amd64
  libfwup1 12-3ubuntu2 in eoan arm64
  libfwup1 12-3ubuntu2 in eoan armhf
  libfwup1 12-3ubuntu2 in eoan i386
Comment: Obsoleted by fwupd; LP: #1841744
1 package successfully removed.

Changed in fwupdate (Ubuntu):
status: Incomplete → Fix Released
Changed in oem-priority:
status: Confirmed → Fix Committed
Yuan-Chen Cheng (ycheng-twn) wrote :

per check eaon archive, confirm fwupdate has been removed, and ubuntu-unity-desktop no longer Recommends it. Mark fix release in oem-priority.

Changed in oem-priority:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Yuan-Chen Cheng (ycheng-twn) wrote :

change back to fix committed for now, since we could need to also track it here for disco and bionic SRU.

Mario Limonciello (superm1) wrote :

I've added series for disco and bionic to track the same actions that happen for eoan.

Also for eoan, fwupdate 12-6 as a transition package that removes all fwupdate binaries during apt upgrade is in debian unstable now and in Ubuntu NEW queue for eoan.

summary: - Drop fwupdate from the archive from E
+ Drop fwupdate from the archive
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers