Freecad's start workbench points to missing webgui -> almost empty gui

Bug #1753376 reported by Michael on 2018-03-05
48
This bug affects 12 people
Affects Status Importance Assigned to Milestone
freecad (Debian)
Fix Released
Unknown
freecad (Ubuntu)
Low
Unassigned
Bionic
Low
Unassigned

Bug Description

[Impact]

 * Using freecad 0.16.6712+dfsg1-1ubuntu2 from Ubuntu 18.04, the Start Workbench is broken due to a missing Qt4 dependency of WebGui.

 * Backporting the proposed fix will prvent FreeCAD from building the affected Workbench as well as changing the default to the Part Workbench.

 * The proposed upload will fix the issue by setting the default workbench to "PartWorkbench" in src/Main/MainGui.cpp. Additionally, the pacakage rules file is modified to prevent the Start Workbench from being built.

[Test Case]

 * On Ubuntu 18.04, install freecad and run normally.

 * An empty Start Workbench is loaded. The message "No module named WebGui" is logged in the report view.

[Regression Potential]

 * All functionality provided by the Start Workbench will be unavailable.

Changed in freecad (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in freecad (Ubuntu):
status: New → Confirmed
Mohammed Shaikh (mumararshaikh) wrote :

The same issue is noted on Ubuntu 18.04 Wayland.

On XServer it didn't run and shows error "Unable to create drawable".

Screenshot : https://imgur.com/a/vbl7p1O

Jason Daborn (mtx-lives) wrote :

Same here, at first you are met with a very sparse window, but FreeCad is thankfully usable if you use the view drop down and select a workbench

Changed in freecad (Debian):
status: New → Fix Released
Zachary Gummow (maleous) wrote :

I have prepared a change to the Debian package that will eliminate this issue.

description: updated
Changed in freecad (Ubuntu):
importance: Undecided → Low
Mathew Hodson (mathew-hodson) wrote :

Fixed in 0.17+dfsg1-1

Changed in freecad (Ubuntu Bionic):
importance: Undecided → Low
Changed in freecad (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.