Google Contacts API Deprecated

Bug #1952107 reported by Yeshayohu Zirkind
114
This bug affects 20 people
Affects Status Importance Assigned to Milestone
evolution-data-server
Fix Released
Unknown
evolution (Ubuntu)
Fix Released
High
Unassigned
Bionic
Triaged
Undecided
Unassigned
Focal
Triaged
Undecided
Unassigned
Impish
Fix Released
Undecided
Unassigned
evolution-data-server (Ubuntu)
Fix Released
High
Unassigned
Bionic
Triaged
Undecided
Unassigned
Focal
Triaged
Undecided
Unassigned
Impish
Fix Released
Undecided
Unassigned

Bug Description

* Impact
The google contacts integration with the GNOME component will stop working since it relies on an API which is going to be shutdown

* Testcase
- use evolution
- add a google account
- go the contacts section

The contacts stored on the google account should be listed, no error should be displayed

* Regression potential
The patch changes the google contact backend so any potential issue is likely to be with contacts integration.

--------------------------------

I opened Evolution today and a red banner appeared on top with the following message:

> Failed to connect address book “<email address hidden> : Contacts”

> Invalid request URI or header, or unsupported nonstandard parameter: Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration.

I found the upstream bug report for this[0], which references the commit[1] that fixes it.
However, that commit is in release 3.42.0, whereas Ubuntu 21.10 currently has 3.40.4-1. Is it possible to backport this commit so that Evolution will continue to work properly?

[0]: https://gitlab.gnome.org/GNOME/evolution/-/issues/1658
[1]: https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/d63a1ce3921a6a6c573a6a

Changed in evolution (Ubuntu):
importance: Undecided → High
Changed in evolution-data-server (Ubuntu):
importance: Undecided → High
Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue is fixed with 3.42 in the current Ubuntu serie, I'm working on backporting the change to impish, later series will also need to be fixed

description: updated
Changed in evolution (Ubuntu):
status: New → Fix Committed
status: Fix Committed → Fix Released
Changed in evolution-data-server (Ubuntu):
status: New → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Yeshayohu, or anyone else affected,

Accepted evolution-data-server into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evolution-data-server/3.40.4-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in evolution-data-server (Ubuntu Impish):
status: New → Fix Committed
tags: added: verification-needed verification-needed-impish
Changed in evolution (Ubuntu Impish):
status: New → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Yeshayohu, or anyone else affected,

Accepted evolution into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evolution/3.40.4-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Yeshayohu, or anyone else affected,

Accepted evolution into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evolution/3.40.4-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Yeshayohu, or anyone else affected,

Accepted evolution into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evolution/3.36.5-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in evolution (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal
Changed in evolution-data-server (Ubuntu Focal):
status: New → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Yeshayohu, or anyone else affected,

Accepted evolution-data-server into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/evolution-data-server/3.36.5-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (evolution-data-server/3.36.5-0ubuntu2)

All autopkgtests for the newly accepted evolution-data-server (3.36.5-0ubuntu2) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

evolution-data-server/3.36.5-0ubuntu2 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#evolution-data-server

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Sebastien Bacher (seb128) wrote :

the armhf tests worked after a retry

Revision history for this message
Tim Richardson (tim-richardson) wrote :

I used proposed-updates today to get the latest evolution, and contact sync works again.
So 3.40.4-1ubuntu2 works. (amd64 arch)

Revision history for this message
Tim Richardson (tim-richardson) wrote :

(... Ubuntu 21.10)

tags: added: verification-done-impish
removed: verification-needed-impish
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution - 3.40.4-1ubuntu2

---------------
evolution (3.40.4-1ubuntu2) impish; urgency=medium

  * debian/patches/git_contact_api.patch:
    - use the right version of the eds webdav API (lp: #1952107)

 -- Sebastien Bacher <email address hidden> Tue, 30 Nov 2021 21:38:27 +0100

Changed in evolution (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 3.40.4-1ubuntu1

---------------
evolution-data-server (3.40.4-1ubuntu1) impish; urgency=medium

  * debian/patches/git-contact-api.patch:
    - use the new google contact api since the old one is deprecated
      and is going to stop working (lp: #1952107)

 -- Sebastien Bacher <email address hidden> Fri, 26 Nov 2021 18:23:27 +0100

Changed in evolution-data-server (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for evolution has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Kurt von Finck (mneptok) wrote :

Pardon me if this should be a separate issue, but ...

GNOME Contacts has this same issue. And I'm not sure if the fix provided for Evolution will propagate to GNOME Contacts.

Revision history for this message
Paulo da Silva (paulinsche) wrote :

I upgrade to 3.36.5-0ubuntu in focal:

Contacts in evolution are EMPTY.

Revision history for this message
ibreeden (i-breeden) wrote :

The same here. Upgraded to 3.36.5-0ubuntu2 in focal. When starting Evolution I get "Connecting to address book failed: Unauthorized". Pressing button [Reconnect] clears the message but Address book is empty.

Revision history for this message
Steve Levitt (slevit) wrote :

Same here. 3.36.5-0ubuntu2 in focal. "Connecting to address book failed: Unauthorized"

Revision history for this message
Alfred Porter (aporter-b) wrote (last edit ):

I also upgraded to 3.36.5-0ubuntu2 in focal. After reloading the address book and re-authenticating, it returns an HTTP 400 (Bad Request). The log file is from the addressbook factory with debugging of google and carddav backend enabled.

Revision history for this message
Ca Ma (camacnr) wrote (last edit ):

After update and upgrade and reconnected to google account it is not working on Ubuntu 18.04 LTS.
I receive this message: Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration and I am not able to see any contact on gnome and gnome evolution.

tags: added: verification-failed-focal
removed: verification-needed-focal
Revision history for this message
Ca Ma (camacnr) wrote (last edit ):

Here just a little workaround for Ubuntu 18.04.6 LTS and Gnome 3.28.2. I suppose it could work with other distributions:

1-backup your evolution data
2-install or upgrade evolution from 3.28 to 3.42 via flatpack (https://flathub.org/apps/details/org.gnome.Evolution)
3-import evolution data from the previous backup
4-reboot

and I have all contacts, calendars and tasks working again!

Revision history for this message
Braath Waate (braathwaate) wrote :

Upgrade to evolution 3.36.5-0ubuntu2 on Ubuntu 20.04.03 (focal) did not fix the bug for me either. I am wondering if anyone has gotten it to work on focal.

To fix the bug on Ubuntu 18.04 (bionic), I had to compile the source (master branch), largely following the instructions at https://wiki.gnome.org/Apps/Evolution/Building, but I also had to build libcmark and turn off introspection, vala, and weather to get it to build. I couldn't use the flatpak build because the machine is a laptop and very limited on disk space.

Revision history for this message
bd (dreyerbernd) wrote :

Malfunction still persits (see below).

Verbindung zu Adressbuch »<email address hidden> : Kontakte« fehlgeschlagen

Ungültige Anfrageadresse oder -kopfzeile, oder nicht unterstützter Nicht-Standardparameter: Contacts API is being deprecated. Migrate to People API to retain programmatic access to Google Contacts. See https://developers.google.com/people/contacts-api-migration.

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Proposed package removed from archive

The version of evolution in the proposed pocket of Focal that was purported to fix this bug report has been removed because one or more bugs that were to be fixed by the upload have failed verification and been in this state for more than 10 days.

Changed in evolution (Ubuntu Focal):
status: Fix Committed → Confirmed
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

The version of evolution-data-server in the proposed pocket of Focal that was purported to fix this bug report has been removed because one or more bugs that were to be fixed by the upload have failed verification and been in this state for more than 10 days.

Changed in evolution-data-server (Ubuntu Focal):
status: Fix Committed → Confirmed
tags: removed: verification-needed
Revision history for this message
David Johnston (david-littlebald) wrote :

Any chance this will get fixed in focal?

Revision history for this message
Corentin Noël (tintou) wrote (last edit ):

For it to work on Focal, one has to also backport this commit in EDS https://gitlab.gnome.org/GNOME/evolution-data-server/-/commit/adbd6fc07033b639a990467009bce416b87ef855

Jeremy Bicha (jbicha)
Changed in evolution (Ubuntu Focal):
status: Confirmed → Triaged
Changed in evolution (Ubuntu Impish):
assignee: nobody → Jeremy Bicha (jbicha)
Changed in evolution-data-server (Ubuntu Focal):
status: Confirmed → Triaged
assignee: nobody → Jeremy Bicha (jbicha)
Changed in evolution (Ubuntu Focal):
assignee: nobody → Jeremy Bicha (jbicha)
Changed in evolution (Ubuntu Impish):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in evolution-data-server:
status: Unknown → Fix Released
Revision history for this message
Taylor Raack (track16) wrote :

Brian, Sebastien, do either of you have the ability to mark this as a bug in Bionic as well for tracking purposes? (I don't seem to have permission to do that). It would be excellent for your patches to be backported to Bionic, regardless of _who_ submits such a patch.

Thank you very much in advance!

Revision history for this message
Jeremy Bicha (jbicha) wrote :

I added a Bionic task.

This is blocked because we haven't been able to find a working patch to fix this issue. You can see one attempt in the comment history of this bug. I added some notes from my attempt at
https://salsa.debian.org/gnome-team/evolution/-/merge_requests/3

Changed in evolution-data-server (Ubuntu Bionic):
status: New → Triaged
Changed in evolution (Ubuntu Bionic):
status: New → Triaged
Changed in evolution (Ubuntu Focal):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in evolution-data-server (Ubuntu Focal):
assignee: Jeremy Bicha (jbicha) → nobody
Revision history for this message
V B (valentin-brasov) wrote :

I am on Ubuntu 22.04 with the system up-to-date and Evolution is not retrieving any contacts from google. :(

Revision history for this message
Alfred Porter (aporter-b) wrote :

I upgraded to 22.04 as well and initially had the same problem. I had to create an app password for Evolution and after that my contacts were synced: https://support.google.com/mail/answer/185833?hl=en-GB.

Revision history for this message
V B (valentin-brasov) wrote (last edit ):

Hi Alfred, I did create a app password in the Google account (I had to enable the 2-step veryfication before doing it), but Gnome, in its Online Contacts, does not accept my app password for the google account, instead only the real google account password. Any instructions please about how you configured Evolution (or Gnome) to use the app password?

Revision history for this message
Alfred Porter (aporter-b) wrote :

If I recall, you need to open the Seahorse application and search for "Address Book" entries. These need to be changed to the app-specific password you created in Google. But when Evolution interactively asks you for your Google account, you will still use the normal password that goes along with that account.

Revision history for this message
V B (valentin-brasov) wrote :

Hi again Affred and thank you very much for trying to help me. So, firstly, just to be sure that there is no confusion, the way I configured my google account in Ubuntu 22.04 is not in Evolution, but in Ubuntu Settings -> Online Accounts, then Evolution automatically uses that account. In Online Accounts I ticked all possible things to sync for my google account (including Contacts). Like I said, entering the app password in Online Accounts is not accepted by Ubuntu. Then I did, as you said, open the Seahorse app. When I look into that with the filter set to "Show any" (so that it doeas not filter any entries out), I see no entry for Address Book. The only entry I see is named "GOA google credentials for identity account_xxxxxxxxxx_y" and it has a poassword field (can be edited after clicking right on the entry and choosing Properties) like:
{'authorization_code': <'aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa'>, 'access_token': <'bbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbbb'>,
'access_token_expires_at': <int64 iiiiiiiiiiiiiiii>, 'refresh_token': <'ccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccccc'>}

So there is no password or app password part in the above field. I even tried to replace that field with {'password': <'eeeeeeeeeeeeeeee'>}, where ee...ee will be the app password, or directly with ee...eee, but no luck.

Any other suggestions please? Thank you very much.

Revision history for this message
V B (valentin-brasov) wrote :

When will this fix be released also for Ubuntu 22.04 (Jammy Jellyfish)?

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.