Xen stable update to 4.9.2

Bug #1763354 reported by Stefan Bader on 2018-04-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xen (Ubuntu)
Medium
Stefan Bader
Artful
Medium
Stefan Bader

Bug Description

SRU Justification:

Impact: Upstream Xen has released a stable update to 4.9.2. Bionic and Artful are based on 4.9.0 currently. By upgrading to the latest stable release we would gain many fixes and improvements from the upstream stable stream.

Fix: Replaced the orig tarballs with the contents of the upstream stable release. Dropping patches we have picked up already.

Testcase: Basic regression testing after upgrading.

MRE discussion: http://irclogs.ubuntu.com/2013/07/22/%23ubuntu-meeting.html#t20:33

References:
* 4.9.1 release: https://www.xenproject.org/downloads/xen-archives/xen-project-49-series/xen-491.html
* 4.9.2 release: https://www.xenproject.org/downloads/xen-archives/xen-project-49-series/xen-492.html

Stefan Bader (smb) on 2018-04-12
Changed in xen (Ubuntu Artful):
assignee: nobody → Stefan Bader (smb)
importance: Undecided → Medium
status: New → Triaged
Stefan Bader (smb) wrote :
Download full text (4.3 KiB)

Regression test results on Bionic/18.04:

Starting on Xen 4.9.2 (Thu Apr 12 12:44:14 UTC 2018) on AMD
===========================================================================
dom0 tests
===========================================================================
* 10-dom0/12-setup PASS
===========================================================================
PV Guest tests (using xen xl toolstack)
===========================================================================
* 20-pvm/10-guest-boot PASS
* 20-pvm/15-update PASS
* 20-pvm/20-reboot PASS
* 20-pvm/21-recover-reboot PASS
* 20-pvm/25-security-qrt PASS
* 20-pvm/30-reboot PASS
* 20-pvm/31-recover-reboot PASS
* 20-pvm/35-pgslam PASS
* 20-pvm/40-save-restore PASS
* 20-pvm/45-pgslam PASS
* 20-pvm/90-guest-shutdown PASS
===========================================================================
HVM Guest tests (using libvirt / xl driver)
===========================================================================
* 30-hvm/10-guest-boot PASS
* 30-hvm/15-update PASS
* 30-hvm/20-reboot PASS
* 30-hvm/21-recover-reboot PASS
* 30-hvm/25-security-qrt PASS
* 30-hvm/30-reboot PASS
* 30-hvm/31-recover-reboot PASS
* 30-hvm/35-pgslam PASS
* 30-hvm/40-save-restore PASS
* 30-hvm/45-pgslam PASS
* 30-hvm/90-shutdown PASS
Finished all testcases. Overall status:
PASS

Starting on Xen 4.9.2 (Thu Apr 12 12:44:14 UTC 2018) on Intel
===========================================================================
dom0 tests
===========================================================================
* 10-dom0/12-setup PASS
===========================================================================
PV Guest tests (using xen xl toolstack)
===========================================================================
* 20-pvm/10-guest-boot PASS
* 20-pvm/15-update PASS
* 20-pvm/20-reboot PASS
* 20-pvm/21-recover-reboot PASS
* 20-pvm/25-security-qrt PASS
* 20-pvm/30-reboot PASS
* 20-pvm/31-recover-reboot PASS
* 20-pv...

Read more...

Changed in xen (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xen - 4.9.2-0ubuntu1

---------------
xen (4.9.2-0ubuntu1) bionic; urgency=medium

  * Update to upstream 4.9.2 release (LP: #1763354).
    Changes include numerous bugfixes, including security fixes/updates.
    4.9.0 -> 4.9.1:
    - XSA-226 / CVE-2017-12135 (replacement)
    - XSA-227 / CVE-2017-12137 (replacement)
    - XSA-228 / CVE-2017-12136 (replacement)
    - XSA-230 / CVE-2017-12855 (replacement)
    - XSA-231 / CVE-2017-14316 (replacement)
    - XSA-232 / CVE-2017-14318 (replacement)
    - XSA-233 / CVE-2017-14317 (replacement)
    - XSA-234 / CVE-2017-14319 (replacement)
    - XSA-235 / CVE-2017-15596 (replacement)
    - XSA-236 / CVE-2017-15597 (new)
    - XSA-237 / CVE-2017-15590 (replacement)
    - XSA-238 / CVE-2017-15591 (replacement)
    - XSA-239 / CVE-2017-15589 (replacement)
    - XSA-240 / CVE-2017-15595 (update)
    - XSA-241 / CVE-2017-15588 (replacement)
    - XSA-242 / CVE-2017-15593 (replacement)
    - XSA-243 / CVE-2017-15592 (replacement)
    - XSA-244 / CVE-2017-15594 (replacement)
    - XSA-245 / CVE-2017-17046 (replacement)
    4.9.1 -> 4.9.2:
    - XSA-246 / CVE-2017-17044 (new)
    - XSA-247 / CVE-2017-17045 (new)
    - XSA-248 / CVE-2017-17566 (new)
    - XSA-249 / CVE-2017-17563 (new)
    - XSA-250 / CVE-2017-17564 (new)
    - XSA-251 / CVE-2017-17565 (new)
    - XSA-252 / CVE-2018-7540 (new)
    - XSA-254 / CVE-2017-5754 (new / XPTI Meltdown mitigation)
    - XSA-255 / CVE-2018-7541 (new)
    - XSA-256 / CVE-2018-7542 (new)
  * Dropped:
    d/p/ubuntu/tools-fix-ftbs-arm.patch (upstream)

 -- Stefan Bader <email address hidden> Thu, 12 Apr 2018 11:54:57 +0200

Changed in xen (Ubuntu):
status: In Progress → Fix Released
Stefan Bader (smb) on 2018-04-16
Changed in xen (Ubuntu Artful):
status: Triaged → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers