Videos won't resume after being paused

Bug #1752197 reported by Robin Hicks on 2018-02-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
WebKit
Fix Released
Medium
epiphany-browser (Ubuntu)
High
Unassigned
webkit2gtk (Ubuntu)
High
Unassigned
Artful
High
Unassigned

Bug Description

On my Ubuntu 17.10 system, Epiphany Browser 3.26.1 has trouble playing YouTube videos. I can play a video from the start point without trouble, but if I pause the video the screen will freeze and stay that way after restarting the video, if I leave the page and go back later it will show a black screen. In both cases the soundtrack continues without problem.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: epiphany-browser 3.26.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-36.40-generic 4.13.13
Uname: Linux 4.13.0-36-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Feb 27 17:27:50 2018
InstallationDate: Installed on 2017-12-06 (83 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: epiphany-browser
UpgradeStatus: No upgrade log present (probably fresh install)

Robin Hicks (hicksrobin42) wrote :
Jeremy Bicha (jbicha) on 2018-02-28
Changed in epiphany-browser (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in webkit2gtk (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in epiphany-browser (Ubuntu Artful):
importance: Undecided → High
status: New → Confirmed
Changed in webkit2gtk (Ubuntu Artful):
importance: Undecided → High
status: New → Confirmed
Changed in webkit-open-source:
importance: Unknown → Medium
status: Unknown → Won't Fix
Jeremy Bicha (jbicha) wrote :

I'm closing the epiphany task since this is easy to reproduce in the GNOME help app (yelp) too.

I reported this bug upstream.
Feel free to visit https://bugs.webkit.org/show_bug.cgi?id=183362 if you want to follow its progress there.

no longer affects: epiphany-browser (Ubuntu Artful)
Changed in webkit-open-source:
importance: Medium → Unknown
status: Won't Fix → Unknown
Changed in epiphany-browser (Ubuntu):
status: Confirmed → Invalid
Jeremy Bicha (jbicha) on 2018-03-06
summary: - Gnome Web has trouble playing YouTube videos
+ Videos won't resume after being paused
Changed in webkit-open-source:
importance: Unknown → Medium
status: Unknown → Confirmed
Jeremy Bicha (jbicha) wrote :

This issue can be fixed by switching webkit2gtk to use gstreamergl but that is blocked on LP: #1753581 .

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webkit2gtk - 2.20.0-2ubuntu1

---------------
webkit2gtk (2.20.0-2ubuntu1) bionic; urgency=medium

  * Enable gstreamer-gl on Ubuntu
    - Resuming paused videos will work correctly now (LP: #1752197)

 -- Jeremy Bicha <email address hidden> Wed, 04 Apr 2018 08:08:55 -0400

Changed in webkit2gtk (Ubuntu):
status: Confirmed → Fix Released
Leianna Heremaia (jahmaia) wrote :

I play a movie on youtube from the start without trouble, but it still in slowness and not normal

Changed in webkit2gtk (Ubuntu):
assignee: nobody → Leianna Heremaia (jahmaia)
Jeremy Bicha (jbicha) on 2018-04-06
Changed in webkit2gtk (Ubuntu):
assignee: Leianna Heremaia (jahmaia) → nobody
Changed in webkit-open-source:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.