[regression] Combobox menus have gray text on gray background

Bug #1725921 reported by Eldar Khayrullin on 2017-10-22
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu theme
High
Daniel van Vugt
ubuntu-themes (Ubuntu)
High
Daniel van Vugt
Xenial
High
Daniel van Vugt
Artful
High
Unassigned
Bionic
High
Daniel van Vugt

Bug Description

[Impact]

Regression: After a recent update, combobox menus have gray text on gray background making them almost unreadable.

[Test Case]

1. Open GIMP and start a new file.
2. At the bottom of the window click on the 'px' combo box.
3. Verify the menu that appears has readable text (light grey text on a dark grey background).

[Regression Potential]

Very low. The fix changes the theme for "gtk-combobox-popup-menu" only. So theoretically it should not be possible for the fix to affect anything other than combobox menus.

[Other Info]

The regression happened in updates to 18.04, 17.10 and 16.04 around late 2017 - January 2018.

Related branches

Eldar Khayrullin (eldar) wrote :
Eldar Khayrullin (eldar) wrote :
Eldar Khayrullin (eldar) wrote :

But text in menus is good

The same issue in wayland and Xorg

summary: - Combo boxes have gray text on gray background on ubuntu 17.10 (wayland)
+ Combo boxes have gray text on gray background on ubuntu 17.10 (gnome)
tags: removed: wayland
Eldar Khayrullin (eldar) wrote :

The same issue in dialog combo boxes

Eldar Khayrullin (eldar) wrote :

I see the same issue in another program kicadbom2spec (use wxwidgets).
Maybe it is wxwidgets bug

Eldar Khayrullin (eldar) on 2018-02-11
affects: kicad → ubuntu
Eldar Khayrullin (eldar) on 2018-02-11
no longer affects: kicad

Fix:
It is need to comment (with '#') in file /usr/share/themes/Ambiance/gtk-2.0/gtkrc the next line:
widget "*.gtk-combobox-popup-menu.*" style "menuitem_text_is_fg_color_workaround"
Restart buggy application.

summary: - Combo boxes have gray text on gray background on ubuntu 17.10 (gnome)
+ Combobox has gray text on gray background on ubuntu 17.10 (gnome)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → ubuntu-themes (Ubuntu)
affects: light-themes → ubuntu
Changed in ubuntu:
status: New → Confirmed
no longer affects: ubuntu
summary: - Combobox has gray text on gray background on ubuntu 17.10 (gnome)
+ Combobox has gray text on gray background
Changed in ubuntu-themes:
importance: Undecided → High
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → High
Changed in ubuntu-themes:
status: New → Triaged
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Triaged
tags: added: artful bionic
tags: added: regression-update visual-quality
tags: added: xenial
summary: - Combobox has gray text on gray background
+ [regression] Combobox has gray text on gray background

Fix #2 (use light menu in popup):
It is need to change in file /usr/share/themes/Ambiance/gtk-2.0/gtkrc the next line:
style "menu" = "dark" {
to
style "menu" = "white" {

Restart buggy application.

Daniel van Vugt (vanvugt) wrote :

This bug is a simple regression. So you can also work around it by taking one step back. Just install:

https://launchpad.net/ubuntu/+archive/primary/+files/light-themes_14.04+16.04.20160415-0ubuntu1_all.deb

summary: - [regression] Combobox has gray text on gray background
+ [regression] Combobox menus have gray text on gray background
tags: added: rls-bb-incoming
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
Changed in ubuntu-themes:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
Will Cooke (willcooke) on 2018-03-06
tags: removed: rls-bb-incoming
Daniel van Vugt (vanvugt) wrote :

Added a fix for xenial too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+18.04.20180322.3-0ubuntu1

---------------
ubuntu-themes (16.10+18.04.20180322.3-0ubuntu1) bionic; urgency=medium

  [ Daniel van Vugt ]
  * Remove an old workaround which would force combobox menu text (LP:
    #1725921)

  [ Marco Trevisan (Treviño) ]
  * list, row: set padding, use white bg and hover effect on activatable
    (LP: #1755351, #1757471)
  * Ambiance: add proper theming for horizontal and vertical linked
    items
  * Ambiance, Radiance: use proper border-width for first/last linked
    buttons in rtl
  * Ambiance, Radiance: use default backdrop colors for views and
    progress bars
  * Ambiance, Radiance: implement ambiance-rw inspired darker
    placessidebar
  * debian/control: change dependency from python3-scour to scour

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 22 Mar 2018 08:28:08 +0000

Changed in ubuntu-themes (Ubuntu Bionic):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

Please make sure to include the SRU-required info in the description [1]. Also, I see this bug has been nominated for artful - could an artful update be published to UNAPPROVED in that case?

Thank you!

[1] https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Changed in ubuntu-themes:
status: In Progress → Fix Released
description: updated
Changed in ubuntu-themes (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Daniel van Vugt (vanvugt)
description: updated

This introduced a regression, and now there are light grey items on grey menus which are barely readable. For example this screenshot of virt-manager.

Daniel van Vugt (vanvugt) wrote :

jibel,

Please log a new bug for that. Also, do you know of any other apps that show it?

Daniel van Vugt (vanvugt) wrote :

BTW, I think the bug there is that the menu background is light. They are meant to be dark now.

I filed bug 1758841, and virt-manager is the only application I found with this problem. So it might be something to fix there.

Hello Eldar, or anyone else affected,

Accepted ubuntu-themes into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/14.04+16.04.20180326-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-themes (Ubuntu Artful):
status: New → Invalid
Changed in ubuntu-themes (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

I have accepted this package to xenial-proposed but could someone check if virt-manager is also affected with bug LP: #1758841 for that series? I would also like some other GTK apps getting tested to make sure they do not regress in xenial. Thanks!

Daniel van Vugt (vanvugt) wrote :

Verification succeeded in xenial using 14.04+16.04.20180326-0ubuntu1

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Daniel van Vugt (vanvugt) wrote :

I can't comment about bug 1758841 right now but I assume the same will happen to xenial. Any comments about that bug should be made in bug 1758841.

I certainly can't find any such regressions in other apps.

rduke15 (rduke15) wrote :

Works for me. Thanks!

After I had enabled xenial-proposed, this did it:

    sudo apt install light-themes/xenial-proposed

The verification of the Stable Release Update for ubuntu-themes has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.04.20180326-0ubuntu1

---------------
ubuntu-themes (14.04+16.04.20180326-0ubuntu1) xenial; urgency=medium

  * Remove an old workaround which would force combobox menu text (LP:
    #1725921)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 26 Mar 2018 09:25:21 +0000

Changed in ubuntu-themes (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in ubuntu-themes (Ubuntu Artful):
status: Invalid → Triaged
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.