update-manager no longer gives good information if /var is too full

Bug #1729368 reported by Patola on 2017-11-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Artful
High
Unassigned

Bug Description

Upgrading from 17.04 to 17.10:

Previous installations of Ubuntu would eventually fail due to lack of space in any one of the filesystems, but at least update-manager and/or do-release-upgrade told me which filesystem was lacking the space and how much it needed, so I could do an online extend since I'm using LVM.

The newer update-manager doesn't do that, even in the terminal output, and even by do-release-upgrade. It just tells me:

==========
Building dependency tree
Reading state information... Done

Calculating the changes
Calculating the changes

Not enough free disk space

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
=== Command terminated with exit status 1 (Wed Nov 1 12:44:09 2017) ===

I understand that Ubuntu is geared towards the novice user, but hiding this kind of information is not useful to him/her too. I eventually found out that the logs had a cryptically formatted space requirement output:

[12:57] [3762] [patola@ovo log]% tail -20 /var/log/dist-upgrade/main.log
2017-11-01 12:43:59,445 DEBUG Free space on /boot: 400269312
2017-11-01 12:43:59,445 DEBUG Dir /var/cache/apt/archives mounted on /var
2017-11-01 12:43:59,445 DEBUG Free space on /tmp: 4931989504
2017-11-01 12:43:59,445 DEBUG Free space on /home: 3533549568
2017-11-01 12:43:59,445 DEBUG Dir /tmp mounted on /tmp
2017-11-01 12:43:59,446 DEBUG fs_free contains: '{'/home': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1f60>, '/var/cache/apt/archives': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e10>, '/tmp': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1cf8>, '/boot': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e80>, '/var': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e10>, '/usr': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e48>, '/': <DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1d68>}'
2017-11-01 12:44:00,388 DEBUG linux-image-4.13.0-16-lowlatency (new-install) added with 14042324 to boot space
2017-11-01 12:44:05,555 DEBUG dir '/var/cache/apt/archives' needs '5775199340' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e10>' (1316454400.000000)
2017-11-01 12:44:05,556 DEBUG dir '/usr' needs '1734142976' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e48>' (12781453312.000000)
2017-11-01 12:44:05,556 DEBUG dir '/usr' needs '52428800' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e48>' (11047310336.000000)
2017-11-01 12:44:05,556 DEBUG dir '/boot' needs '120526816' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e80>' (400269312.000000)
2017-11-01 12:44:05,556 DEBUG dir '/tmp' needs '5242880' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1cf8>' (4931989504.000000)
2017-11-01 12:44:05,556 DEBUG dir '/' needs '10485760' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1d68>' (3914502144.000000)
2017-11-01 12:44:05,556 DEBUG dir '/tmp' needs '0.0' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1cf8>' (4926746624.000000)
2017-11-01 12:44:05,556 DEBUG dir '/usr' needs '0.0' of '<DistUpgrade.DistUpgradeCache.MyCache.checkFreeSpace.<locals>.FreeSpace object at 0x7f175f3e1e48>' (10994881536.000000)
2017-11-01 12:44:05,556 ERROR Not enough free space: ['/var']
2017-11-01 12:44:05,566 DEBUG abort called
2017-11-01 12:44:05,575 DEBUG openCache()
2017-11-01 12:44:05,575 DEBUG failed to SystemUnLock() (E:Not locked)
2017-11-01 12:44:09,030 DEBUG /openCache(), new cache size 88780
[12:57] [3763] [patola@ovo log]%

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: update-manager 1:17.04.8
ProcVersionSignature: Ubuntu 4.10.0-38.42-lowlatency 4.10.17
Uname: Linux 4.10.0-38-lowlatency x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu4.5
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Wed Nov 1 12:51:16 2017
GsettingsChanges:
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'864'
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'window-width' b'1229'
 b'com.ubuntu.update-manager' b'launch-time' b'int64 1509546701'
InstallationDate: Installed on 2014-08-02 (1187 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: Upgraded to zesty on 2017-11-01 (0 days ago)

Related branches

Patola (patola) wrote :
tags: added: dist-upgrade
Brian Murray (brian-murray) wrote :

Thanks for reporting this issue, the lack of an error message is specific to /var being full. Could you tell me what version of ubuntu-release-upgrader you were using. You should be able to find a version string towards the beginning of /var/log/dist-upgrade/main.log. Thanks!

summary: - [REGRESSION] update-manager no longer informs space needed and
- filesystem
+ update-manager no longer gives good information if /var is too full
affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → High
tags: added: artful
Patola (patola) wrote :

I upgraded my system since them but according to /var/log/dpkg.log it was 1:17.04.9 (ubuntu-release-upgrader-gtk, -qt and -core)

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu Artful):
status: New → Triaged
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.2

---------------
ubuntu-release-upgrader (1:18.04.2) bionic; urgency=medium

  * DistUpgrade/DistUpgradeController.py: Provide a better error message if
    /var does not have enough free space and a generic fallback error message
    if it is a parition without a specific remedy. (LP: #1729368)

 -- Brian Murray <email address hidden> Wed, 08 Nov 2017 11:15:54 -0800

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers