apt-config-auto-update and update-notifier-common can't be co-installed

Bug #1616689 reported by chris pollock on 2016-08-25
178
This bug affects 26 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
pk-update-icon (Ubuntu)
High
Unassigned
Artful
High
Unassigned
update-notifier (Ubuntu)
High
Unassigned
Artful
High
Unassigned

Bug Description

apt-config-auto-update and update-notifier-common can't be installed together, because they both ship the file /etc/apt/apt.conf.d/10periodic, but neither package declares a Conflicts-relationship. This results in:

dpkg: error processing archive /var/cache/apt/archives/apt-config-auto-update_2.0.0-1_all.deb (--unpack):
 trying to overwrite '/etc/apt/apt.conf.d/10periodic', which is also in package update-notifier-common 3.168.1

chris pollock (cpollock) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pk-update-icon (Ubuntu):
status: New → Confirmed
Changed in pk-update-icon (Ubuntu):
importance: Undecided → Medium
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Medium
Andreas Moog (ampelbein) on 2017-05-26
Changed in pk-update-icon (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Changed in update-notifier (Ubuntu):
status: New → Confirmed
Andreas Moog (ampelbein) on 2017-05-26
Changed in update-notifier (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
tags: added: artful
description: updated
Andreas Moog (ampelbein) on 2017-05-26
summary: - package apt-config-auto-update not installed failed to
- install/upgrade: trying to overwrite /etc/apt/apt.conf.d/10periodic ,
- which is also in package update-notifier-common 3.168.1
+ apt-config-auto-update and update-notifier-common can't be co-installed
Steve Langasek (vorlon) wrote :

update-notifier-common has shipped /etc/apt/apt.conf.d/10periodic in every Ubuntu flavor image we produce, and has been since at least 12.04. pk-update-icon was introduced some time post-14.04. This needs to be fixed in that package to not ship this file.

Conflicts is a wrong solution, because these should not be two alternate implementations of /etc/apt/apt.conf.d/10periodic in Ubuntu.

Changed in update-notifier (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers