mongodump does not work – Failed: error dumping metadata: error converting index (<nil>): conversion of BSON value '2' of type 'bson.Decimal128' not supported

Bug #1743865 reported by Alexander on 2018-01-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mongodb (Ubuntu)
Undecided
Unassigned
Artful
High
Unassigned

Bug Description

Hi,
[this is my first bug report on launchpad, so if something is missing, just let me know :-)]

mongodump does not work at all. Everytime I try to dump I get the error message:
Failed: error dumping metadata: error converting index (<nil>): conversion of BSON value '2' of type 'bson.Decimal128' not supported

Googling the error leads to https://stackoverflow.com/questions/43575194/mongodump-index-conversion-error-of-bson-decimal128-not-supported
suggesting it's a version compatibility issue. See below the packaged version of mongodump says it is built without a concrete version or git commit.

--------------------------------------------------------------------------

Reproduction:

I reproduced on a fresh installation of Ubuntu 17.10 Server.
Just install mongodb and try to mongodump.
There is no need to insert data to trigger the issue.

--------------------------------------------------------------------------

Additional information:

# mongodump
2018-01-17T19:57:03.251+0100 Failed: error dumping metadata: error converting index (<nil>): conversion of BSON value '2' of type 'bson.Decimal128' not supported

# cat /etc/issue
Ubuntu 17.10 \n \l

# apt show mongodb-server | grep Version
Version: 1:3.4.7-1

# mongod --version
db version v3.4.7
git version: cf38c1b8a0a8dca4a11737581beafef4fe120bcd
OpenSSL version: OpenSSL 1.0.2g 1 Mar 2016
allocator: tcmalloc
modules: none
build environment:
    distarch: x86_64
    target_arch: x86_64

# apt show mongo-tools | grep Version
Version: 3.2.11-1

# mongodump --version
mongodump version: built-without-version-string
git version: built-without-git-spec
Go version: go1.7.3
   os: linux
   arch: amd64
   compiler: gc
OpenSSL version: OpenSSL 1.0.2g 1 Mar 2016

# lsb_release -rd
Description: Ubuntu 17.10
Release: 17.10

# apt-cache policy mongodb mongodb-server mongo-tools
mongodb:
  Installiert: 1:3.4.7-1
  Installationskandidat: 1:3.4.7-1
  Versionstabelle:
 *** 1:3.4.7-1 500
        500 http://de.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status
mongodb-server:
  Installiert: 1:3.4.7-1
  Installationskandidat: 1:3.4.7-1
  Versionstabelle:
 *** 1:3.4.7-1 500
        500 http://de.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status
mongo-tools:
  Installiert: 3.2.11-1
  Installationskandidat: 3.2.11-1
  Versionstabelle:
 *** 3.2.11-1 500
        500 http://de.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: mongodb 1:3.4.7-1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
Date: Wed Jan 17 20:18:33 2018
InstallationDate: Installed on 2018-01-17 (0 days ago)
InstallationMedia: Ubuntu-Server 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
SourcePackage: mongodb
UpgradeStatus: No upgrade log present (probably fresh install)

Alexander (thehacker) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mongodb (Ubuntu):
status: New → Confirmed
Robie Basak (racb) wrote :

Confirmed on Artful. This does not reproduce on Bionic with the new mongodb/mongo-tools 3.6. So I presume this is fixed on Bionic.

For Artful a fix may be possible but awaits a volunteer to prepare an update and drive it through the process. If you can help with this, please see https://wiki.ubuntu.com/StableReleaseUpdates#Procedure for details.

Changed in mongodb (Ubuntu Artful):
status: New → Triaged
importance: Undecided → High
Changed in mongodb (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers