ppc64el: Support firmware disable of RFI flush

Bug #1751994 reported by bugproxy on 2018-02-27
258
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Kernel Team
linux (Ubuntu)
High
Canonical Kernel Team
Trusty
High
Joseph Salisbury
Xenial
High
Joseph Salisbury
Artful
High
Joseph Salisbury
Bionic
High
Canonical Kernel Team

Bug Description

== Comment: #0 - Breno Leitao <email address hidden> - 2018-02-26 13:59:55 ==
Hi Canonical,

We still need some changes regarding spectre and meltdown. We need to backport the following commit to all supported kernel.

I undertand that the backport for kernel 4.XX should be trivial. Not sure about kernel 3.13 yet.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=582605a429e20ae68fd0b041b2e840af296edd08
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=eb0a2d2620ae431c543963c8c7f08f597366fc60

CVE References

bugproxy (bugproxy) on 2018-02-27
tags: added: architecture-ppc64le bugnameltc-165181 severity-medium targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-power-systems:
importance: Undecided → Medium
status: New → Triaged
tags: added: triage-g
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Breno Leitão (breno-leitao) wrote :

Can we increase the priority of this bug from medium to high, please?

Andrew Cloke (andrew-cloke) wrote :

Certainly. Priority bumped.

Changed in ubuntu-power-systems:
importance: Medium → High
information type: Public → Public Security
Changed in linux (Ubuntu):
status: New → Triaged
importance: Undecided → High
Manoj Iyer (manjo) on 2018-03-05
Changed in linux (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Kernel Team (canonical-kernel-team)
Seth Forshee (sforshee) on 2018-03-07
Changed in linux (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in linux (Ubuntu Trusty):
importance: Undecided → High
Changed in linux (Ubuntu Xenial):
importance: Undecided → High
Changed in linux (Ubuntu Artful):
importance: Undecided → High
Joseph Salisbury (jsalisbury) wrote :

I built Trust, Xenial and Artful test kernels with a back ports of commits 582605a and eb0a2d2. The test kernels can be downloaded from:

http://kernel.ubuntu.com/~jsalisbury/lp1751994

Can you test these kernels and see if they resolve this bug?

Note, to test this kernel, you need to install both the linux-image and linux-image-extra .deb packages.

Thanks in advance!

Changed in linux (Ubuntu Trusty):
status: New → In Progress
Changed in linux (Ubuntu Xenial):
status: New → In Progress
Changed in linux (Ubuntu Artful):
status: New → In Progress
Changed in linux (Ubuntu Trusty):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Xenial):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Artful):
assignee: nobody → Joseph Salisbury (jsalisbury)
Launchpad Janitor (janitor) wrote :
Download full text (40.0 KiB)

This bug was fixed in the package linux - 4.15.0-12.13

---------------
linux (4.15.0-12.13) bionic; urgency=medium

  * linux: 4.15.0-12.13 -proposed tracker (LP: #1754059)

  * CONFIG_EFI=y on armhf (LP: #1726362)
    - [Config] CONFIG_EFI=y on armhf, reconcile secureboot EFI settings

  * ppc64el: Support firmware disable of RFI flush (LP: #1751994)
    - powerpc/pseries: Support firmware disable of RFI flush
    - powerpc/powernv: Support firmware disable of RFI flush

  * [Feature] CFL/CNL (PCH:CNP-H): New GPIO Commit added (GPIO Driver needed)
    (LP: #1751714)
    - gpio / ACPI: Drop unnecessary ACPI GPIO to Linux GPIO translation
    - pinctrl: intel: Allow custom GPIO base for pad groups
    - pinctrl: cannonlake: Align GPIO number space with Windows

  * [Feature] Add xHCI debug device support in the driver (LP: #1730832)
    - usb: xhci: Make some static functions global
    - usb: xhci: Add DbC support in xHCI driver
    - [Config] USB_XHCI_DBGCAP=y for commit mainline dfba2174dc42.

  * [SRU] Lenovo E41 Mic mute hotkey is not responding (LP: #1753347)
    - platform/x86: ideapad-laptop: Increase timeout to wait for EC answer

  * headset mic can't be detected on two Dell machines (LP: #1748807)
    - ALSA: hda - Fix a wrong FIXUP for alc289 on Dell machines

  * hisi_sas: Add disk LED support (LP: #1752695)
    - scsi: hisi_sas: directly attached disk LED feature for v2 hw

  * [Feature] [Graphics]Whiskey Lake (Coffelake-U 4+2) new PCI Device ID adds
    (LP: #1742561)
    - drm/i915/cfl: Adding more Coffee Lake PCI IDs.

  * [Bug] [USB Function][CFL-CNL PCH]Stall Error and USB Transaction Error in
    trace, Disable of device-initiated U1/U2 failed and rebind failed: -517
    during suspend/resume with usb storage. (LP: #1730599)
    - usb: Don't print a warning if interface driver rebind is deferred at resume

  * retpoline: ignore %cs:0xNNN constant indirections (LP: #1752655)
    - [Packaging] retpoline -- elide %cs:0xNNNN constants on i386
    - [Config] retpoline -- clean up i386 retpoline files

  * hisilicon hibmc regression due to ea642c3216cb ("drm/ttm: add io_mem_pfn
    callback") (LP: #1738334)
    - drm/ttm: add ttm_bo_io_mem_pfn to check io_mem_pfn

  * [Asus UX360UA] battery status in unity-panel is not changing when battery is
    being charged (LP: #1661876) // AC adapter status not detected on Asus
    ZenBook UX410UAK (LP: #1745032)
    - ACPI / battery: Add quirk for Asus UX360UA and UX410UAK

  * ASUS UX305LA - Battery state not detected correctly (LP: #1482390)
    - ACPI / battery: Add quirk for Asus GL502VSK and UX305LA

  * [18.04 FEAT] Automatically detect layer2 setting in the qeth device driver
    (LP: #1747639)
    - s390/diag: add diag26c support for VNIC info
    - s390/qeth: support early setup for z/VM NICs

  * Bionic update to v4.15.7 stable release (LP: #1752317)
    - netfilter: drop outermost socket lock in getsockopt()
    - arm64: mm: don't write garbage into TTBR1_EL1 register
    - kconfig.h: Include compiler types to avoid missed struct attributes
    - MIPS: boot: Define __ASSEMBLY__ for its.S build
    - xtensa: fix high memory/reserved memory collision
    - scsi: ibmvfc: fix misde...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Changed in ubuntu-power-systems:
status: Triaged → In Progress
Changed in ubuntu-power-systems:
status: In Progress → Fix Committed
tags: added: triage-a
removed: triage-g
Breno Leitão (breno-leitao) wrote :

I just tested artful and it is working fine:

1604 ➜ ~ uname -a
Linux 1604 4.13.0-36-generic #40~lp1751994 SMP Thu Mar 8 15:19:19 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux
1604 ➜ ~ dmesg | grep rfi
[ 0.000000] rfi-flush: Using fallback displacement flush
[ 0.000000] rfi-flush: patched 11 locations

Breno Leitão (breno-leitao) wrote :

I also tested the xenial GA kernel:

# uname -a
Linux 1604 4.4.0-116-generic #140~lp1751994 SMP Thu Mar 8 15:31:31 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux

# dmesg | grep rfi
[ 0.000000] rfi-flush: Using fallback displacement flush
[ 0.000000] rfi-flush: patched 10 locations

Breno Leitão (breno-leitao) wrote :

I also tested the trusty GA kernel:

➜ ~ uname -a
Linux ubuntu140403 3.13.0-142-generic #191~lp1751994 SMP Thu Mar 8 15:49:48 UTC 2018 ppc64le ppc64le ppc64le GNU/Linux

➜ ~ dmesg | grep rfi
[ 0.000000] rfi-flush: Using fallback displacement flush
[ 0.000000] rfi-flush: patched 9 locations

Thanks for the custom kernels!

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers