Installed application from .deb does not appear unless Ubuntu is restarted

Bug #1629600 reported by Hadrien on 2016-10-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
gnome-software (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
High
Unassigned

Bug Description

I'm using Ubuntu 16.04 x64 and the installed version of gnome-software is 3.20.1

  * I install a desktop application from a .deb package. I tried several methods (apt install, dpkg -i, xdg-open then click on install button).
  * After the installation, I control that the application is visible from the system:
    * The application appears correctly in the application list in Unity Dash
    * The application appears in the "Open With" menu list in Nautilus (because of registered mime types)
    * The package name of the application can be used as an argument of apt commands (apt show, apt remove...) and dpkg (dpkg -l, dpkg -L...)
  * I start gnome-software.
  * I click on the "installed" tab to get the list of installed applications.

expected result: the freshly installed application is in the list
actual result: the freshly installed application is not in the list.

If I reboot my computer and start gnome-software, the installed application appears in the list.

It looks like there is some kind of cache that is not refreshed at the right moment.

Hadrien (psydk) wrote :

It seems that the process does not exit when the gnome-software window is closed.

If I kill the gnome-software process and restart it, the freshly installed .deb package is now visible in the list. It's better than rebooting but still quite confusing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-software (Ubuntu):
status: New → Confirmed
tags: added: yakkety

Problem verified with Google Chrome on Yakkety.
 * install google-chrome-stable package with g-s;
 * close and restart g-s, notice that Google Chrome is not listed under "installed" apps nor searchable inside g-s;
 * $ pkill gnome-software;
 * start again g-s, now Google Chrome is listed in g-s.

However there is one omore problem: I can launch Google Chrome from g-s, but I can't remove it. "Remove" button in g-s does nothing.

tags: added: xenial
Changed in gnome-software (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Robert Ancell (robert-ancell) wrote :

This seems to occur for packages that are not in the Ubuntu archive e.g.
https://www.google.com/chrome/
http://itch.io/app

Changed in gnome-software (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) wrote :

Robert, the last time I checked, this issue doesn't affect Ubuntu 17.10 "artful"

Hadrien (psydk) wrote :

I tried with Ubuntu 17.10 and a .deb package I propose here: http://psydk.org/pngoptimizer

The application does not appear unless gnome-software is killed.
After I restart gnome-software, it appears in the Graphics section and if I specifically search for it. However it does not appear in the "Installed" view.

Iain Lane (laney) wrote :

(valid bug, but not one the team will commit to fixing for 17.10)

tags: added: rls-aa-notfixing
Hadrien (psydk) wrote :

Ubuntu 18.04, gnome-software 3.28.1

The application now appears in the "Installed" list, but with the wrong name and the wrong icon.
If I kill gnome-software and restart it, the application is not present anymore in the "Installed" list.
If I do a search in gnome-software, I can find the application again, with the right icon and with the "Installed" check tick (as it was the case for 17.10).

dino99 (9d9) on 2018-05-09
tags: removed: yakkety
Changed in gnome-software (Ubuntu Zesty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers