App indicator is not always displayed

Bug #1714504 reported by Jean-Baptiste Lallement on 2017-09-01
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-shell-extension-appindicator (Ubuntu)
High
Marco Trevisan (Treviño)
Artful
High
Marco Trevisan (Treviño)

Bug Description

I've 2 apps that should be displayed in the indicator:
- hp systray (from the package hplip-gui)
- synology cloud client (download from synology)

Sometimes the indicators are displayed and sometimes not. The extension is loaded and show no error.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell-extension-appindicator 17.10
ProcVersionSignature: Ubuntu 4.12.0-11.12-generic 4.12.5
Uname: Linux 4.12.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 1 14:57:16 2017
Dependencies:

InstallationDate: Installed on 2013-09-03 (1458 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130902)
PackageArchitecture: all
ProcEnviron:
 TERM=screen-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-shell-extension-appindicator
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in gnome-shell-extension-appindicator (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
description: updated
Changed in gnome-shell-extension-appindicator (Ubuntu):
status: New → Confirmed
Changed in gnome-shell-extension-appindicator (Ubuntu):
importance: Undecided → High
tags: added: rls-aa-incoming
Iain Lane (laney) on 2017-09-21
tags: removed: rls-aa-incoming

This is not related to locking/unlocking, right?
Just on startup...

Jean-Baptiste Lallement (jibel) wrote :

No this is not related to locking/unlocking and it seems to happen on X rather than wayland.

Gavin Graham (gavingraham) wrote :

The same is happening for me with the Synology Cloudstation Client and additionally, Cadence, the Jackd manager app. Also only happening under X and not Wayland.
This was actually working before Ubuntu got it's hands on it so it was a recent update. The version on Gnome Extensions I assume has had the same patches applied as it is not displaying icons now either.
It stopped working two updates ago.

Happens at log-in.

But to add a twist to the plot, I have the exact same behaviour with Ubuntu 17.04 running Unity 7! I would have missing app-icons under X but they would display fine under Wayland.

Yet still, with this current version of the problem, it only started happening in the past month.

Therefore, I put it to you that the issue is not so much with this package but potentially a patch in X that was recently applied. Probably the same patch they used in the previous version of Ubuntu at some point.

Likely to be an Ubuntu customisation of X rather than the appindicator package.

Gavin Graham (gavingraham) wrote :

Since it works under Wayland and not under X, should this be tagged Xorg rather than Wayland?

rhhoek (r-h-hoek) wrote :

For my it does not work under X-Org.
Under Wayland is works.
Used apps are Dropbox, MEGA, Nextcloud, Telegram.

SB (emehntehtt) wrote :

I have a different problem with app indicator icons, those that appear like Qbittorrent and Viber, are tiny, I am running X.org. Some that should appear in the "tray" like Clementine do not appear at all. I couldnt find a bug with this kind of problem, should I post a new one?

tags: removed: wayland-session
Daniel van Vugt (vanvugt) wrote :

We may want to merge bug 1728124 with this one at some point.

QkiZ (qkiz) wrote :

Same here. I'm using ownCloud, Variety, My Weather Indicator, Classic Menu Indicator and sometimes icons doesn't appear at all or some of them. Usually it happens after computer start or reboot. I found errors in syslog (in attachment).

Gavin Graham (gavingraham) wrote :

I can confirm that removing the extraneous Indicator packages does the job.

Pablo Catalina (xkill) wrote :

Same problem. After back from suspend it does not work, solution for me: kill -HUP.

Michał Sawicz (saviq) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.