Change metadata server to upstream requested one

Bug #1761005 reported by Robert Ancell on 2018-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
fwupd (Ubuntu)
Undecided
Unassigned
Xenial
High
Unassigned
Artful
High
Unassigned

Bug Description

[Impact]
fwupd is configured to use an Amazon server for downloading firmware metadata. As requested by upstream:

"The current CDN (~$100/month) is kindly sponsored by Amazon, but that won't
last forever. In the future we can switch to a 'dumb' provider like BunnyCDN
for 1/10th of the cost.

Use a CNAME we control to make switching CDN providers easy in the future."

[Test Case]
Still able to install firmware as before

[Regression Potential]
Some risk of breaking firmware updates due to server configuration, but this matches upstreams setup and is the behaviour in fwupd 1.0.6 (in bionic onwards).

Mario Limonciello (superm1) wrote :

Already fixed in 1.0.6 release, marking bionic fix released.

Changed in fwupd (Ubuntu):
status: New → Fix Released
Changed in fwupd (Ubuntu Xenial):
status: New → Confirmed
Changed in fwupd (Ubuntu Artful):
status: New → Confirmed
Changed in fwupd (Ubuntu Xenial):
importance: Undecided → High
Changed in fwupd (Ubuntu Artful):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers