sru curtin 2018-01-18 - 17.1-11-ga4c9636b-0ubuntu1

Bug #1743618 reported by Ryan Harper on 2018-01-16
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
curtin (Ubuntu)
Xenial
Medium
Ryan Harper
Artful
Medium
Ryan Harper

Bug Description

== Begin SRU Template ==
[Impact]
This release sports both bug-fixes and new features and we would like to
make sure all of our supported customers have access to these improvements.
The notable ones are:

   * storage: add 'options' key mount type to specify mount parameters for
     filesystems (LP: #1709284)
   * Re-add curthooks.write_files method for backwards compat
     (LP: #1731709)
   * block: handle wiping bcache parts (LP: #1718699)
   * bcache: accept sysfs write failure in shutdown handler if path
     missing (LP: #1700564)
   * block_meta: use block.wipe_volume(mode=superblock) to clear MBR/GPT
     tables (LP: #1722322)
   * apt: Be more lenient when replacing mirrors in /etc/apt/sources.list
     (LP: #1744038)
   * vmtest: Drop Zesty release

See the changelog entry below for a full list of changes and bugs.

[Test Case]
The following development and SRU process was followed:
https://wiki.ubuntu.com/CurtinUpdates

Curtin now contains an extensive integration test suite that is ran using
the SRU package for each releases. These suite has documentation here:
https://curtin.readthedocs.io/en/latest/topics/integration-testing.html

In order to avoid regression to existing MAAS product, the MAAS team will
run their continuous integration test against the curtin that is in
-proposed. A successful run will be required before the proposed curtin
can be let into -updates.

The curtin team will be in charge of attaching the artifacts and console
output of the appropriate run to the bug. Curtin team members will not
mark ‘verification-done’ until this has happened.

[Verification]
integration tests for xenial:
 * log: see attached curtin-vmtest-proposed-x-console.log
 * artifacts: see attached curtin-vmtest-proposed-x-artifacts.tar.xz
 Note: one test case failed due to transient Bionic Kernel bug
 which is unrelated to curtin (LP: #1730717)

integration tests for artful:
 * log: see attached curtin-vmtest-proposed-a-console.log
 * artifacts: see attached curtin-vmtest-proposed-a-artifacts.tar.xz

maas qa tests for xenial:
 * log: see attached curtin-sru-maas-qa-xenial.log
 * artifacts: none

maas qa tests for artful:
 * log: see attached curtin-sru-maas-qa-artful.log
 * artifacts: none

[Regression Potential]
In order to mitigate the regression potential, the results of the
aforementioned integration tests are attached to this bug.

[Discussion]
The primary motiviation for this SRU is to bring 'options' mount parameters (LP# 1709284).

== End SRU Template ==

=== Changelog ===

curtin (17.1-11-ga4c9636b-0ubuntu1) UNRELEASED; urgency=medium

  * New upstream snapshot. (LP: #1743618)
    - tests: cleanup the apt custom sources test.
    - apt: Be more lenient when replacing mirrors in /etc/apt/sources.list
      (LP: #1744038)
    - vmtest: Drop Zesty release
    - vmtest: initialize logger with class names for easy parsing
    - packaging: Do not mention primary contributors in debian/changelog.

curtin (17.1-6-g8b145067-0ubuntu1) UNRELEASED; urgency=medium

  * New upstream snapshot. (LP: #1743618)
    - packaging: Update new-upstream-snapshot to work with git.
    - Bump pylint to 1.8.1.
    - vmtests: switch to MAAS v3 streams for images and kernels
    - tests: update pack tests to clear out pyc files more completely.
    - debian/control: drop conflicts that had bzr version
    - Switch uses of bzr to git, borrow from cloud-init git workflow.
    - Release 17.1
    - packaging: update debian/build-deb to remove ~bzrREV when using equal tag
    - pack: fix packing when curtin is installed inside a snap.
    - tox: move to pylint 1.7.4
    - vmtests: iscsi minor cleanup.
    - vmtests: exercise rootfs over an lvm logical volume
    - Switch network dep filter to test for ifupdown/nplan instead of
      release name
    - Allow control of curtin install unmounting
    - vmtests: Add Bionic release to tests and update classes.
    - storage: add 'options' key mount type to specify mount parameters for
      filesystems (LP: #1709284)
    - Re-add curthooks.write_files method for backwards compat (LP: #1731709)
    - vmtest: Remove ArtfulTestBridging skip_by_date check, bug fixed
    - Drop Precise from vmtest
    - clear_holders: bcache log IO/OS exceptions but do not raise
    - vmtest: Support newer qemu and multipath.
    - block: enable control over exclusive_open use when wiping volumes
    - block: handle wiping bcache parts (LP: #1718699)
    - vmtests: Defer ArtfulNetworkMtu SkipbyDate to 2018
    - bcache: accept sysfs write failure in shutdown handler if path missing
      (LP: #1700564)
    - vmtest: Rephrase a message about no disks to be less scary
    - block_meta: use block.wipe_volume(mode=superblock) to clear MBR/GPT
      tables (LP: #1722322)

Related branches

Ryan Harper (raharper) on 2018-01-16
description: updated
Scott Moser (smoser) on 2018-01-16
summary: - sru curtin 2018-01016 - 17.1-5-gfae8ffb1
+ sru curtin 20180116 - 17.1-5-gfae8ffb1
Scott Moser (smoser) on 2018-01-16
summary: - sru curtin 20180116 - 17.1-5-gfae8ffb1
+ sru curtin 2018-01-16 - 17.1-5-gfae8ffb1
summary: - sru curtin 2018-01-16 - 17.1-5-gfae8ffb1
+ sru curtin 2018-01-16 - 17.1-6-g8b145067
no longer affects: curtin (Ubuntu)
Changed in curtin (Ubuntu Xenial):
status: New → In Progress
Changed in curtin (Ubuntu Artful):
status: New → In Progress
Changed in curtin (Ubuntu Xenial):
importance: Undecided → Medium
Changed in curtin (Ubuntu Artful):
importance: Undecided → Medium
Changed in curtin (Ubuntu Xenial):
assignee: nobody → Ryan Harper (raharper)
Changed in curtin (Ubuntu Artful):
assignee: nobody → Ryan Harper (raharper)
description: updated

Hello Ryan, or anyone else affected,

Accepted curtin into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/17.1-6-g8b145067-0ubuntu1~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in curtin (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello Ryan, or anyone else affected,

Accepted curtin into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/17.1-6-g8b145067-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in curtin (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial
Scott Moser (smoser) on 2018-01-18
summary: - sru curtin 2018-01-16 - 17.1-6-g8b145067
+ sru curtin 2018-01-18 - 17.1-11-ga4c9636b-0ubuntu1
Ryan Harper (raharper) on 2018-01-18
description: updated
Brian Murray (brian-murray) wrote :

Hello Ryan, or anyone else affected,

Accepted curtin into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/17.1-11-ga4c9636b-0ubuntu1~17.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Brian Murray (brian-murray) wrote :

Hello Ryan, or anyone else affected,

Accepted curtin into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/curtin/17.1-11-ga4c9636b-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Scott Moser (smoser) on 2018-01-19
description: updated
Ryan Harper (raharper) wrote :

Xenial-proposed integration test console-log

Ryan Harper (raharper) wrote :

Xenial-proposed integration test artifacts/logs

description: updated
Ryan Harper (raharper) wrote :

Artful-proposed integration test console-log

Ryan Harper (raharper) wrote :

Artful-proposed integration test artifacts/logs

John George (jog) wrote :

Xenial-proposed VM deploy log.

John George (jog) wrote :

Xenial-proposed metal deploy log.

Scott Moser (smoser) on 2018-01-29
description: updated
Mateusz Pawlowski (teluka) wrote :

Hi,

I am wondering what is the ETA to get this package released to -updates ?

Thanks.

We're awaiting results from a MAAS QA run; once that's complete we'll mark
verification done and it should
show up in -updates shortly after that.

On Thu, Feb 1, 2018 at 10:11 AM, Mateusz Pawlowski <
<email address hidden>> wrote:

> Hi,
>
> I am wondering what is the ETA to get this package released to -updates
> ?
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1743618
>
> Title:
> sru curtin 2018-01-18 - 17.1-11-ga4c9636b-0ubuntu1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/xenial/+source/curtin/+
> bug/1743618/+subscriptions
>

Mateusz Pawlowski (teluka) wrote :

Thanks.

Andres Rodriguez (andreserl) wrote :

Xenial CI run with curtin from -proposed has been verified. Marking verification-done-xenial

tags: added: verification-done-xenial
removed: verification-needed-xenial
Andres Rodriguez (andreserl) wrote :

Ok, I've tested in artful as well, and confirm it works as expected. I've marked verification-done-artful. I'll leave it to the curtin team mark it verification-done for final if they are ready to push this forward.

tags: added: verification-done-artful
removed: verification-needed-artful
Mateusz Pawlowski (teluka) wrote :

Hi guys,

Could you please mark it as verification-done as per previous update ?

Sorry for pushing you but I have customer that waiting for SRU to be completed.

Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 17.1-11-ga4c9636b-0ubuntu1~17.10.1

---------------
curtin (17.1-11-ga4c9636b-0ubuntu1~17.10.1) artful; urgency=medium

  * New upstream snapshot. (LP: #1743618)
    - tests: cleanup the apt custom sources test.
    - apt: Be more lenient when replacing mirrors in /etc/apt/sources.list
    - vmtest: Drop Zesty release
    - vmtest: initialize logger with class names for easy parsing
    - packaging: Do not mention primary contributors in debian/changelog.

curtin (17.1-6-g8b145067-0ubuntu1~17.10.1) artful; urgency=medium

  * New upstream snapshot. (LP: #1743618)
    - packaging: Update new-upstream-snapshot to work with git.
    - Bump pylint to 1.8.1.
    - vmtests: switch to MAAS v3 streams for images and kernels [Ryan Harper]
    - tests: update pack tests to clear out pyc files more completely.
    - debian/control: drop conflicts that had bzr version
    - Switch uses of bzr to git, borrow from cloud-init git workflow.
    - Release 17.1
    - packaging: update debian/build-deb to remove ~bzrREV when using equal tag
    - pack: fix packing when curtin is installed inside a snap.
    - tox: move to pylint 1.7.4
    - vmtests: iscsi minor cleanup.
    - vmtests: exercise rootfs over an lvm logical volume [Ryan Harper]
    - Switch network dep filter to test for ifupdown/nplan instead of release
      name [Ryan Harper]
    - Allow control of curtin install unmounting [Ryan Harper]
    - vmtests: Add Bionic release to tests and update classes.
    - storage: add 'options' key mount type to specify mount parameters for
      filesystems [Ryan Harper]
    - Re-add curthooks.write_files method for backwards compat
      [Ryan Harper]
    - vmtest: Remove ArtfulTestBridging skip_by_date check, bug fixed
    - Drop Precise from vmtest [Ryan Harper]
    - clear_holders: bcache log IO/OS exceptions but do not raise [Ryan Harper]
    - vmtest: Support newer qemu and multipath.
    - block: enable control over exclusive_open use when wiping volumes
      [Ryan Harper]
    - block: handle wiping bcache parts [Ryan Harper]
    - vmtests: Defer ArtfulNetworkMtu SkipbyDate to 2018 [Ryan Harper]
    - bcache: accept sysfs write failure in shutdown handler if path missing
      [Ryan Harper]
    - vmtest: Rephrase a message about no disks to be less scary
    - block_meta: use block.wipe_volume(mode=superblock) to clear MBR/GPT
      tables [Ryan Harper]

 -- Ryan Harper <email address hidden> Thu, 18 Jan 2018 15:47:59 -0600

Changed in curtin (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for curtin has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package curtin - 17.1-11-ga4c9636b-0ubuntu1~16.04.1

---------------
curtin (17.1-11-ga4c9636b-0ubuntu1~16.04.1) xenial; urgency=medium

  * New upstream snapshot. (LP: #1743618)
    - tests: cleanup the apt custom sources test.
    - apt: Be more lenient when replacing mirrors in /etc/apt/sources.list
    - vmtest: Drop Zesty release
    - vmtest: initialize logger with class names for easy parsing
    - packaging: Do not mention primary contributors in debian/changelog.

curtin (17.1-6-g8b145067-0ubuntu1~16.04.1) xenial; urgency=medium

  * New upstream snapshot. (LP: #1743618)
    - packaging: Update new-upstream-snapshot to work with git.
    - Bump pylint to 1.8.1.
    - vmtests: switch to MAAS v3 streams for images and kernels [Ryan Harper]
    - tests: update pack tests to clear out pyc files more completely.
    - debian/control: drop conflicts that had bzr version
    - Switch uses of bzr to git, borrow from cloud-init git workflow.
    - Release 17.1
    - packaging: update debian/build-deb to remove ~bzrREV when using equal tag
    - pack: fix packing when curtin is installed inside a snap.
    - tox: move to pylint 1.7.4
    - vmtests: iscsi minor cleanup.
    - vmtests: exercise rootfs over an lvm logical volume [Ryan Harper]
    - Switch network dep filter to test for ifupdown/nplan instead of release
      name [Ryan Harper]
    - Allow control of curtin install unmounting [Ryan Harper]
    - vmtests: Add Bionic release to tests and update classes.
    - storage: add 'options' key mount type to specify mount parameters for
      filesystems [Ryan Harper]
    - Re-add curthooks.write_files method for backwards compat
      [Ryan Harper]
    - vmtest: Remove ArtfulTestBridging skip_by_date check, bug fixed
    - Drop Precise from vmtest [Ryan Harper]
    - clear_holders: bcache log IO/OS exceptions but do not raise [Ryan Harper]
    - vmtest: Support newer qemu and multipath.
    - block: enable control over exclusive_open use when wiping volumes
      [Ryan Harper]
    - block: handle wiping bcache parts [Ryan Harper]
    - vmtests: Defer ArtfulNetworkMtu SkipbyDate to 2018 [Ryan Harper]
    - bcache: accept sysfs write failure in shutdown handler if path missing
      [Ryan Harper]
    - vmtest: Rephrase a message about no disks to be less scary
    - block_meta: use block.wipe_volume(mode=superblock) to clear MBR/GPT
      tables [Ryan Harper]

 -- Ryan Harper <email address hidden> Thu, 18 Jan 2018 15:30:09 -0600

Changed in curtin (Ubuntu Xenial):
status: Fix Committed → Fix Released
Ryan Harper (raharper) wrote :

MAAS QA results (Xenial)

Ryan Harper (raharper) wrote :

MAAS QA results for Artful

description: updated
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers