Zsys changes the canmount property of persistent bpool/grub dataset

Bug #1897563 reported by Didier Roche on 2020-09-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zsys (Ubuntu)
High
Didier Roche
Focal
Undecided
Didier Roche

Bug Description

[Impact]
 * People having personal layout, like a persistent dedicated dataset under /boot like /boot/grub will get it unmouted after a state revert.
 * Side effects:
  - those datasets are never marked as being part of the current machine, or any state.
  - bpool and bpool/BOOT are not listed in the unmanaged dataset list.

[Test Case]
 * Install ZFS manually with a persistent bpool/bpool/grub dataset
 * Take a snapshot
 * Revert to this snapshot when rebooting
 * Check that the persistent grub dataset is still mounted
 * You can check as well with zsysctl show --full that you have this persistent dataset attached to the machine.

[Regression Potential]
 * New datasets under /boot could appear to be attached by the machine (even if unlikely due to the huge testsuite which has been updated and checked)

Didier Roche (didrocks) on 2020-09-28
description: updated
Didier Roche (didrocks) on 2020-09-28
Changed in zsys (Ubuntu Bionic):
importance: Undecided → High
Changed in zsys (Ubuntu):
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
Changed in zsys (Ubuntu Bionic):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsys - 0.5.2

---------------
zsys (0.5.2) groovy; urgency=medium

  * Fix /boot/subdataset now being considered as persistent datasets
    (LP: #1897563)
  * Fix persistent dataset printing (LP: #1897565)

 -- Didier Roche <email address hidden> Mon, 28 Sep 2020 14:39:07 +0200

Changed in zsys (Ubuntu):
status: New → Fix Released

Hello Didier, or anyone else affected,

Accepted zsys into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zsys/0.4.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in zsys (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zsys (Ubuntu Bionic):
status: New → Confirmed
Domizio Demichelis (domizio) wrote :

0.4.8 works here on 20.04.1!

Didier Roche (didrocks) on 2020-10-13
Changed in zsys (Ubuntu Focal):
assignee: nobody → Didier Roche (didrocks)
no longer affects: zsys (Ubuntu Bionic)
tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal

The verification of the Stable Release Update for zsys has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsys - 0.4.8

---------------
zsys (0.4.8) focal; urgency=medium

  * Fix /boot/subdataset now being considered as persistent datasets
    (LP: #1897563)
  * Fix persistent dataset printing (LP: #1897565)

 -- Didier Roche <email address hidden> Mon, 28 Sep 2020 14:39:07 +0200

Changed in zsys (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers