Freezes in midgame

Bug #1214241 reported by Edgar on 2013-08-20
132
This bug affects 28 people
Affects Status Importance Assigned to Milestone
zsnes (Ubuntu)
Medium
Unassigned

Bug Description

After a while playing a game (~ 1 hour) the emuator freezes, all I can do is to kill the process.
This does not happen with a specific game, or a specific part of a game; it looks more like random.

3,7 GiB RAM.
Intel® Core™ i3 CPU M 380 @ 2.53GHz × 4
Intel® Ironlake Mobile x86/MMX/SSE2 (graph)
OS 32 bits. Ubuntu 13.04
>100Gb free space

Zsnes ver: 1.510+bz2-5ubuntu2.1

WORKAROUND: Use the Windows version of zsnes 1.51 via WINE.

apt-cache policy wine1.7
wine1.7:
  Installed: 1:1.7.31-0ubuntu1~ppa1
  Candidate: 1:1.7.31-0ubuntu1~ppa1
  Version table:
 *** 1:1.7.31-0ubuntu1~ppa1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zsnes (Ubuntu):
status: New → Confirmed
Jonas Oscarsson (joscarsson) wrote :

I am seeing this as well. After upgrading from Ubuntu 12.10 to 13.04 a bug was introduced which caused the emulator to crash as soon as a game was selected to be played. When that bug was fixed, this bug was introduced instead. It is now playable, but without exception it hangs in the middle of the game after ~1 hour. Only thing that helps is to kill the process and restart.

Let me know what information I can give to help you troubleshoot this. coredump?

james pinckney (james-pinckney) wrote :

I am also seeing this on 13.10. I saw it on 13.04 before the upgrade as well. Did not have this issue when using 12.04 at a previous time on the same hardware with the same ROMs.

Alexander Klauer (graf-zahl) wrote :

Me too. Unfortunately, there does not appear to be a debug package for zsnes. This is what I found during a freeze:

<code>
(gdb) thread 1
[Switching to thread 1 (Thread 0xf6a29700 (LWP 10036))]
#0 0xf73737e0 in ?? () from /lib/i386-linux-gnu/libc.so.6
(gdb) bt
#0 0xf73737e0 in ?? () from /lib/i386-linux-gnu/libc.so.6
#1 0xf76bf272 in SDL_strlcpy () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#2 0xf76b668a in SDL_SetError () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#3 0xf77069ba in SDL_SemPost () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#4 0x082ff4c2 in ?? ()
#5 0x082fc741 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb) thread 2
[Switching to thread 2 (Thread 0xef0ffb40 (LWP 10040))]
#0 0xf779f430 in __kernel_vsyscall ()
(gdb) bt
#0 0xf779f430 in __kernel_vsyscall ()
#1 0xf7770126 in nanosleep () from /lib/i386-linux-gnu/libpthread.so.0
#2 0xf7708cd7 in SDL_Delay () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#3 0xf7708d24 in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#4 0xf76bf901 in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#5 0xf770646b in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#6 0xf7768d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#7 0xf73dffee in clone () from /lib/i386-linux-gnu/libc.so.6
(gdb) thread 3
[Switching to thread 3 (Thread 0xefa26b40 (LWP 10039))]
#0 0xf779f430 in __kernel_vsyscall ()
(gdb) bt
#0 0xf779f430 in __kernel_vsyscall ()
#1 0xf73d0ae0 in ppoll () from /lib/i386-linux-gnu/libc.so.6
#2 0xf71c610b in pa_mainloop_poll ()
   from /usr/lib/i386-linux-gnu/libpulse.so.0
#3 0xf71c68c9 in pa_mainloop_iterate ()
   from /usr/lib/i386-linux-gnu/libpulse.so.0
#4 0xf76e7f06 in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#5 0xf76b6eb8 in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#6 0xf76bf901 in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#7 0xf770646b in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#8 0xf7768d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#9 0xf73dffee in clone () from /lib/i386-linux-gnu/libc.so.6
(gdb) thread 4
[Switching to thread 4 (Thread 0xf5c78b40 (LWP 10037))]
#0 0xf779f430 in __kernel_vsyscall ()
(gdb) bt
#0 0xf779f430 in __kernel_vsyscall ()
#1 0xf73a8776 in nanosleep () from /lib/i386-linux-gnu/libc.so.6
#2 0xf73d896d in usleep () from /lib/i386-linux-gnu/libc.so.6
#3 0x082fd05b in ?? ()
#4 0xf76bf901 in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#5 0xf770646b in ?? () from /usr/lib/i386-linux-gnu/libSDL-1.2.so.0
#6 0xf7768d78 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#7 0xf73dffee in clone () from /lib/i386-linux-gnu/libc.so.6
</code>

Paul Kilgo (paulkilgo) wrote :

I ran into a very similar behavior as well. There is an ongoing discussion at ubuntuforums where I posted some info but I think it is better suited here. Here is the thread:

http://ubuntuforums.org/showthread.php?t=2159402

So this is on Ubuntu 13.10 with znes package version 1.510+bz2-5ubuntu3. Very similar behavior -- the application stops responding to input after 30 minutes or so and can only be SIGKILL'd. I ran strace on the hung process and it appeared to be stuck in a futex-based deadlock:

futex(0x9851848, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x9851848, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x9851848, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x9851848, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x9851848, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x9851848, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
...

Etienne Millon (etienne-millon) wrote :

This is presumably the same bug as https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=740860 which was fixed in version -7.

tags: added: cherry-pick i386 trusty
Changed in zsnes (Ubuntu):
importance: Undecided → Medium

Still happening to me on 14.04, happens every 40 minutes or so. Also deletes any save progress that occurs while in-game, I've had to rely on save states instead.

Jan (thesheeep2) wrote :

I can confirm that this is still an issue.
I'm using the latest version of Linux Mint, 17, (running the Ubuntu based version, of course).

Changed in zsnes (Ubuntu):
status: Confirmed → Triaged
description: updated
Ben M. (bmhm) wrote :

Fixed in debian since 10 May 2014, still not fixed in 14.04 LTS since Aug. 2013. What can we do to help get this fixed into ubuntus repositories?

Regine (cap-is-) wrote :

Hey all,

I can confirm this as well:
zsnes Version: 1.510+bz2-6
Ubuntu 14.04.2 LTS

Brian Morton (rokclimb15) wrote :

Bug is fixed in Wily due to a resync with upstream.

http://changelogs.ubuntu.com/changelogs/pool/universe/z/zsnes/zsnes_1.510+bz2-8/changelog

Also, they added a debug package, which is great news.

shankao (shankao) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - Xenial Xerus

This is a significant bug in Ubuntu. If you need a fix for the bug in previous versions of Ubuntu, please perform as much as possible of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in zsnes (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.