zsh version 4.3.11-4ubuntu2.is.3ubuntu1 failed to build on armel

Bug #841489 reported by Ricardo Salveti
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zsh (Debian)
Fix Released
Unknown
zsh (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

zsh version 4.3.11-4ubuntu2.is.3ubuntu1 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110819/+build/2731599

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110819/+build/2731599/+files/buildlog_ubuntu-oneiric-armel.zsh_4.3.11-4ubuntu2.is.3ubuntu1_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 3501 lines into the build log:

checking for streams headers including struct winsize... no
checking for printf in -lc... yes
checking for pow in -lm... yes
checking for library containing tigetstr... no
checking if _XOPEN_SOURCE_EXTENDED should not be defined... no
checking for library containing tigetflag... no
checking for library containing tgetent... no
configure: error: in `/build/buildd/zsh-4.3.11/obj-static':
configure: error: "No terminal handling library was found on your system.
This is probably a library called 'curses' or 'ncurses'. You may
need to install a package called 'curses-devel' or 'ncurses-devel' on your
system."
See `config.log' for more details.
make: *** [stamp-configure-static] Error 255
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2
******************************************************************************
Build finished at 20110829-0559
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/zsh-4.3.11

Related branches

Changed in zsh (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

Fixed this problem and requested to merge.
Could you review it?

Merge proposal is following:
ncurses splitted out tinfo library from ncurses at 5.9-1ubuntu1.
However debian/rules script link with -lncurses(w) only.

In dynamic linkage its no problem because libncurses(s) depends
libtinfo.so. But static linkage in configure script occurs failure,
because needs to list up all objects.

Therefore this branch adds -ltinfo list link libraries at
debian/rules to use --with-term-lib option.

This is Ubuntu specific problem. In Debian sid, doesn't split
tinfo library, doesn't needs link libtinfo.a.

Changed in zsh (Ubuntu Oneiric):
status: Confirmed → In Progress
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

FYI, this problem presents in all architectures, not only armel.

Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :
tags: added: patch
Revision history for this message
Michael Vogt (mvo) wrote :

Thanks a bunch! I uploaded this now to oneiric.

Changed in zsh (Ubuntu Oneiric):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsh - 4.3.11-4ubuntu2.is.3ubuntu2

---------------
zsh (4.3.11-4ubuntu2.is.3ubuntu2) oneiric; urgency=low

  * Add "tinfo" to --with-term-lib flag. (LP: #841489)
    Ubuntu striped out libtinfo* package from ncurses.
 -- Mitsuya Shibata <email address hidden> Sat, 24 Sep 2011 14:53:40 +0900

Changed in zsh (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in zsh (Debian):
status: Unknown → New
Changed in zsh (Debian):
status: New → Fix Committed
Changed in zsh (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.