FFe: Please merge zsh 4.3.17-1 from Debian

Bug #762286 reported by Daniel Hahler
32
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zsh (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: zsh

While running into bug #762238 I've been told that it is fixed in 4.3.11-4, which I have verified.

Given that 4.3.11-4 is a bugfix release, Frank Terbeck ("ft" on #zsh) has recommended to get it into Ubuntu.

I am attaching a debdiff against the current version in Ubuntu, and a debdiff for sponsorship, hoping that this will be enough to get it into Natty still.

Related branches

Revision history for this message
Daniel Hahler (blueyed) wrote :

% diffstat debdiff-4.3.11-3ubuntu1-to-4.3.11-4ubuntu1.diff
 README.Debian | 31
 at2quilt | 162
 changelog | 31
 control | 2
 patches/0000-compsys-fuser-fix.diff | 16
 patches/0001-colors-with-ksharrays.diff | 16
 patches/0002-vcs_info-svn-detection.diff | 14
 patches/0003-regex-match-crash-fix.diff | 43
 patches/0004-support-yodl3.diff | 40
 patches/0005-lexer-fix.diff | 16
 patches/deb_0000_at_configure.diff |14044 +++++++++++++++++++++++++++++++
 patches/deb_0001_at_config_h_in.diff | 1160 ++
 patches/debian-changes-4.3.11-3 | 288
 patches/debian-changes-4.3.11-4 | 192
 patches/series | 8
 rules | 5
 16 files changed, 15773 insertions(+), 295 deletions(-)

Changed in zsh (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Daniel Hahler (blueyed) wrote :
Revision history for this message
Daniel Hahler (blueyed) wrote :

Subscribing ubuntu-sponsors and -release to hopefully get this into Natty still.

I have uploaded it to my PPA for test-building and verification; it should show up at https://launchpad.net/~blueyed/+archive/ppa soonish.

Revision history for this message
Martin Pitt (pitti) wrote :

Most of it is bug fixing indeed, but there are also some nontrivial build system changes. It built fine, but how much testing did you give this?

Revision history for this message
Daniel Hahler (blueyed) wrote :

I have done moderate testing, just been using it.

I understand if you think that only the bugfix patch(es) should get used/picked, but I could not provide these (for Natty) - I'll be away for the week.

Revision history for this message
Martin Pitt (pitti) wrote :

Also migrated to testing in Debian. Approved.

Changed in zsh (Ubuntu):
status: New → Confirmed
Revision history for this message
Michael Vogt (mvo) wrote :

I uploaded this now based on the changelog and the comment from pitti.

Changed in zsh (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsh - 4.3.11-4ubuntu1

---------------
zsh (4.3.11-4ubuntu1) natty; urgency=low

  * Merge from debian unstable. (LP: #762286) Remaining changes:
    - debian/zshrc: Enable completions by default, unless
      skip_global_compinit is set

zsh (4.3.11-4) unstable; urgency=low

  [ Frank Terbeck ]
  * [78ab02ff] Initial `debian/' import
  * [bfb94ad4] Adding _fuser fix from upstream
  * [344bea55] Adding at2quilt script
  * [4e83fa72] Adding autotools related patches
  * [0bfbee7f] Make sure a configure script is executable and stamp.h.in exists
  * [56cc95c7] Installation of Etc/FAQ currently fails for the debian package
  * [545b40ea] Fix colors function to work with ksh_arrays (Closes: #613162)
  * [6219ec1f] Fix detection of svn repositories in vcs_info (Closes: #611175)
  * [983b6365] Adding patch to fix segfault with regular expression matching
  * [6ced6e2c] Adding patch to support yodl3
  * [6267bebc] Refreshing autotools patches for yodl3 fixes
  * [40086130] Fix endless loop due to lexer bug (Closes: #353863)

  [ Michael Prokop ]
  * [e8d69775] README.Debian: Add instructions how to use the zsh-dbg package.
  * [ed6737b2] Add yodl to Build-Depends and sort Build-Depends while at it.
 -- Daniel Hahler <email address hidden> Sat, 16 Apr 2011 00:47:30 +0200

Changed in zsh (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Reopening, WONTFIX for natty. The new version introduces new build dependencies from universe:

 o icmake: icmake icmake-doc
   [Reverse-Depends: Rescued from icmake]
   [Reverse-Build-Depends: yodl]

 o yodl: yodl yodl-doc
   [Reverse-Depends: Rescued from yodl]
   [Reverse-Build-Depends: zsh]

Changed in zsh (Ubuntu):
status: Fix Released → Confirmed
tags: added: patch
Jeremy Bicha (jbicha)
Changed in zsh (Ubuntu):
status: Confirmed → Fix Released
status: Fix Released → Confirmed
Revision history for this message
Felix Geyer (debfx) wrote :

Updated merge to zsh 4.3.15.

I have opened a MIR for yodl and icmake: bug #920436

summary: - Please merge zsh 4.3.11-4 from Debian
+ Please merge zsh 4.3.15-1 from Debian
Revision history for this message
Jonathan Davies (jpds) wrote : Re: Please merge zsh 4.3.15-1 from Debian

This merge will also fix wishlist bug #924830.

Felix Geyer (debfx)
summary: - Please merge zsh 4.3.15-1 from Debian
+ FFe: Please merge zsh 4.3.17-1 from Debian
Revision history for this message
Felix Geyer (debfx) wrote :

The MIR hasn't been approved so we have to use the upstream tarball with pre-generated docs.

I have uploaded the package to:
http://people.ubuntu.com/~debfx/zsh_4.3.17-1ubuntu1.dsc

Revision history for this message
Felix Geyer (debfx) wrote :

zsh 4.3.11 -> 4.3.17 are mostly bufixes but there seem to be some new features and the diff is quite large so I'm requesting a FFe.

I have been using zsh 4.3.15 and 4.3.17 for some time on two different machines without problems.

Revision history for this message
Felix Geyer (debfx) wrote :
Changed in zsh (Ubuntu):
status: Confirmed → New
Revision history for this message
Martin Pitt (pitti) wrote :

Seems fine to me. Please double-check with "check-mir" that it's buildable in main. Thanks!

Changed in zsh (Ubuntu):
status: New → Triaged
tags: added: css-sponsored-p
Revision history for this message
Felix Geyer (debfx) wrote :

Yes, I have checked that no MIRs are required.

However the build log I linked above is wrong as the package in the PPA still uses yodl. I'm attaching a correct one.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Thanks for your work on this. Closing bug manually.

Changed in zsh (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers