Please merge zsh 4.3.10-14(main) from debian unstable(main)

Bug #612938 reported by Bhavani Shankar
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zsh (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: zsh

Debian changes:

zsh (4.3.10-14) unstable; urgency=low

   * ZW#27804: don't hang on encountering invalid character in
     incremental search. closes: #574502.
   * xmlsoft --nodtdattr completion thanks to Vincent Lefevre.
     closes: #585812.
   * Add example .zshrc from Carsten Hey. closes: #587278.
   * Add recommended .zshrc for users to choose on initial run.
 -- Clint Adams <email address hidden> Wed, 30 Jun 2010 09:40:28 -0400

zsh (4.3.10-13) unstable; urgency=low

   * Patch from Bernd Zeimetz to complete 'bts affects'.
     closes: #579529.
   * ZW#28006: make zgetcwd() fall back to pwd, only use "." if
     setting pwd. closes: #585660.
 -- Clint Adams <email address hidden> Sun, 13 Jun 2010 10:35:03 -0400

zsh (4.3.10-12) unstable; urgency=low

   * Do not do host completion for entries in ~/.ssh/known_hosts with
     port numbers.
   * Fix lsusb completino to work with uncompressed usb.ids.
     closes: #579117.
   * Add completion for axi-cache.
   * Add completion for pbuilder. ref: #570878.
 -- Clint Adams <email address hidden> Sun, 25 Apr 2010 19:05:36 -0400

zsh (4.3.10-11) unstable; urgency=low

   * Switch build-dep back to libcap-dev since libcap2-dev is a virtual
     package now.
   * Bump to Standards-Version 3.8.4.
   * Patch from Michael Prokop for apt --no-install-recommends
     completion. closes: #570520
 -- Clint Adams <email address hidden> Sun, 21 Feb 2010 13:15:17 -0500

zsh (4.3.10-10) unstable; urgency=low

   * ZW#27565: sanity check numeric arguments to ulimit
   * ZW#27566: add ulimit -c hard and immediate return on argument error
     closes: #568678.
 -- Clint Adams <email address hidden> Sat, 06 Feb 2010 18:47:41 -0500

2009

zsh (4.3.10-9) unstable; urgency=low

   * Patch from Chris Lamb to improve django completion.
     closes: #562753.
 -- Clint Adams <email address hidden> Sun, 27 Dec 2009 21:52:39 -0500

zsh (4.3.10-8) unstable; urgency=low

   * Patch from Michael Prokop to fix dput --delayed completion.
     closes: #560881.
 -- Clint Adams <email address hidden> Sat, 12 Dec 2009 19:16:31 -0500

zsh (4.3.10-7) unstable; urgency=low

   * Update prompt_clint_setup to use a slightly different color scheme
     when run over ssh.
   * Switch to 3.0 (quilt) source format.
   * Fix gpg --verify-files completion. closes: #557286.
 -- Clint Adams <email address hidden> Mon, 23 Nov 2009 04:49:17 -0500

zsh (4.3.10-6) unstable; urgency=low

   * Update mpc completion for version 0.17.
   * Have zsh-doc depend on dpkg (>= 1.15.4) | install-info.
   * Drop ancient Conflicts.
   * Drop duplicate Priority fields.
   * Drop alternative build dependency on tetex-bin.
 -- Clint Adams <email address hidden> Sat, 24 Oct 2009 01:20:39 -0400

Related branches

Revision history for this message
Bhavani Shankar (bhavi) wrote :
Changed in zsh (Ubuntu):
status: New → Confirmed
Revision history for this message
Benjamin Drung (bdrung) wrote :

It's 'Debian', not 'debian' and there should be a space before the round bracket.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zsh - 4.3.10-14ubuntu1

---------------
zsh (4.3.10-14ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #612938). Remaining changes:
    - debian/zshrc: Enable completions by default, unless
      skip_global_compinit is set

zsh (4.3.10-14) unstable; urgency=low

  * ZW#27804: don't hang on encountering invalid character in
    incremental search. closes: #574502.
  * xmlsoft --nodtdattr completion thanks to Vincent Lefevre.
    closes: #585812.
  * Add example .zshrc from Carsten Hey. closes: #587278.
  * Add recommended .zshrc for users to choose on initial run.

zsh (4.3.10-13) unstable; urgency=low

  * Patch from Bernd Zeimetz to complete 'bts affects'.
    closes: #579529.
  * ZW#28006: make zgetcwd() fall back to pwd, only use "." if
    setting pwd. closes: #585660.

zsh (4.3.10-12) unstable; urgency=low

  * Do not do host completion for entries in ~/.ssh/known_hosts with
    port numbers.
  * Fix lsusb completino to work with uncompressed usb.ids.
    closes: #579117.
  * Add completion for axi-cache.
  * Add completion for pbuilder. ref: #570878.

zsh (4.3.10-11) unstable; urgency=low

  * Switch build-dep back to libcap-dev since libcap2-dev is a virtual
    package now.
  * Bump to Standards-Version 3.8.4.
  * Patch from Michael Prokop for apt --no-install-recommends
    completion. closes: #570520

zsh (4.3.10-10) unstable; urgency=low

  * ZW#27565: sanity check numeric arguments to ulimit
  * ZW#27566: add ulimit -c hard and immediate return on argument error
    closes: #568678.

zsh (4.3.10-9) unstable; urgency=low

  * Patch from Chris Lamb to improve django completion.
    closes: #562753.

zsh (4.3.10-8) unstable; urgency=low

  * Patch from Michael Prokop to fix dput --delayed completion.
    closes: #560881.

zsh (4.3.10-7) unstable; urgency=low

  * Update prompt_clint_setup to use a slightly different color scheme
    when run over ssh.
  * Switch to 3.0 (quilt) source format.
  * Fix gpg --verify-files completion. closes: #557286.

zsh (4.3.10-6) unstable; urgency=low

  * Update mpc completion for version 0.17.
  * Have zsh-doc depend on dpkg (>= 1.15.4) | install-info.
  * Drop ancient Conflicts.
  * Drop duplicate Priority fields.
  * Drop alternative build dependency on tetex-bin.
 -- Bhavani Shankar <email address hidden> Tue, 03 Aug 2010 15:51:55 +0530

Changed in zsh (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers