all zsh manpages and inline help files are missing

Bug #1242108 reported by Alexander Gabriel on 2013-10-19
360
This bug affects 75 people
Affects Status Importance Assigned to Milestone
zsh (Ubuntu)
Medium
Dimitri John Ledkov
Trusty
Low
Unassigned

Bug Description

In Ubuntu 13.10 and 14.04 all of zsh's manpages are missing.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zsh (Ubuntu):
status: New → Confirmed
Dave Gilbert (ubuntu-treblig) wrote :

Low: Just docs
Triaged: Trivially repeatable, can tell they aren't there just by dpkg -L on all the zsg packages as well.

Changed in zsh (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: packaging
Gerry (gsker) wrote :

This happened in revision 39:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/zsh/trusty/revision/39

{{{
   - Keep using the upstream tarball that contains pre-generated docs as
    yodl is required to build them but the MIR hasn't been approved.
  - Drop yodl from Build-Depends.
  - Support cross-compiling:
    - Adjust upstream autoconf cross-compile default fallbacks.
    - Skip zcompile when cross-compiling.
    - Add libelf-dev dependency.
  + Add doc tarball component
  + Drop patches that modify docs, add patch to skip building docs.
}}}

We still need the man pages.

Gerry (gsker) wrote :

I think I read that wrong. It IS intended to include a doc tarball, but somehow the man pages are not being included. The "orig" file in the published package doesn't include the prebuilt man files, but the tarball from www.zsh.org does. Anyway, I hope this gets fixed. I've installed the manpages from source --

   get the file from www.zsh.org.
   extract Docs from it: tar xvf zsh-5.0.2.tar.bz2 zsh-5.0.2/Doc/
   copy man pages: sudo cp -v zsh-5.0.2/Doc/*.1 /usr/share/man/man1/

Changed in zsh (Ubuntu):
importance: Low → Medium
assignee: nobody → Dmitrijs Ledkovs (xnox)
Philipp Kern (pkern) wrote :

Dimitri, any update on this? The package has also not been rebased on the version in sid/testing for trusty (5.0.5).

Another ping from here. This is quite annoying, and breaks capabilities on the package (for example, meta-h on a commands fails because it doesn't find man zshbuitin). Please....

Just as an addenda: the zsh help files, found in zsh-<version>/Doc/help, are missing too (they should go to /usr/share/zsh/help)

Pierre Equoy (pieq) wrote :

I'm having the same issue with Ubuntu 14.04. Should I file a separate bug report?

$ sudo apt install zsh zsh-doc
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  zsh-common
The following NEW packages will be installed:
  zsh zsh-common zsh-doc
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/5,000 kB of archives.
After this operation, 17.3 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Selecting previously unselected package zsh-common.
(Reading database ... 166304 files and directories currently installed.)
Preparing to unpack .../zsh-common_5.0.2-3ubuntu6_all.deb ...
Unpacking zsh-common (5.0.2-3ubuntu6) ...
Selecting previously unselected package zsh.
Preparing to unpack .../zsh_5.0.2-3ubuntu6_amd64.deb ...
Unpacking zsh (5.0.2-3ubuntu6) ...
Selecting previously unselected package zsh-doc.
Preparing to unpack .../zsh-doc_5.0.2-3ubuntu6_all.deb ...
Unpacking zsh-doc (5.0.2-3ubuntu6) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for doc-base (0.10.5) ...
Processing 1 added doc-base file...
Processing triggers for install-info (5.2.0.dfsg.1-2) ...
Setting up zsh-common (5.0.2-3ubuntu6) ...
Setting up zsh (5.0.2-3ubuntu6) ...
update-alternatives: using /bin/zsh5 to provide /bin/zsh (zsh) in auto mode
update-alternatives: using /bin/zsh5 to provide /bin/rzsh (rzsh) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man1/rzsh.1.gz because associated file /usr/share/man/man1/zsh.1.gz (of link group rzsh) doesn't exist
Setting up zsh-doc (5.0.2-3ubuntu6) ...

Dave Gilbert (ubuntu-treblig) wrote :

Pierre: No, it's OK just to note it still affects 14.04 on here.

tags: added: saucy trusty utopic
Mikel Ward (mikelward) wrote :

The rationale was

 - Keep using the upstream tarball that contains pre-generated docs as
    yodl is required to build them but the MIR hasn't been approved.

Does "MIR" mean merge into release?

"yodl" appears to be in main, having hit saucy on 2013-05-24 and trusty on 2013-10-25.

https://launchpad.net/ubuntu/+source/yodl

and it's also in Debian stable https://packages.debian.org/wheezy/yodl

Does that mean that the current workaround can just be removed?

(Or perhaps the rebase pkern mentions in #5 is sufficient?)

skierpage (skierpage) on 2014-05-30
description: updated
Anonymous bin Ich (ichbinanon) wrote :

This is weird. How can I tell people to RTFM when it is not their?

Mike Chelen (mchelen) wrote :

Confirm workaround from #4

Axel Beckert (xtaran) wrote :

In addition to the man-pages, also the inline helpfiles under /usr/share/zsh/help/ are completely missing, hence Esc-h for shell builtin commands does not work.

summary: - all zsh manpages are missing
+ all zsh manpages and inline help files are missing
Changed in zsh (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (7.1 KiB)

This bug was fixed in the package zsh - 5.0.5-4ubuntu1

---------------
zsh (5.0.5-4ubuntu1) utopic; urgency=medium

  * Merge from Debian unstable, remaining changes:
    - debian/zshrc: Enable completions by default, unless
      skip_global_compinit is set
    - Drop yodl from Build-Depends.
    - Support cross-compiling:
      - Adjust upstream autoconf cross-compile default fallbacks.
      - Skip zcompile when cross-compiling.
      - Add libelf-dev dependency.
    - Add libncurses5-dev build-dep to avoid tgoto implicit function
    declaration and thus, implicit integer to pointer conversion. zsh
    should build with just ncursesw though.
    - Use dh_autotools-dev_update|restoreconfig in addition to
    dh_autoreconf to actually update config.sub|guess.

  * Adjust prebuild target to prebuild missing docs locally with yodl
    installed, and dpkg-source --commit the results into
    prebuild-docs.patch. Adjust source/options to not ignore doc changes &
    manpages. Adjust debian/clean to not purge prebuild manpages. Revert
    debian/rules to Debian, thus installing & build remaining pdf/texinfo
    documentation at build time. This should resolve partially missing
    documentation bug LP: #1242108.

zsh (5.0.5-4) unstable; urgency=medium

  * [5cebe890] Fix output file descriptor of bug script. reportbug
    only captures output to fd 3 and ignores STDOUT.
  * [11486424] Simplify helpfiles generation in debian/rules.
    + nroff is no more called twice (Closes: #737582)
    + There's no more need to replace any ISO Latin-1 character.
    + debian/rules is now pure 7-bit ASCII again
  * [d1d4dabe] Add lintian overrides for spelling error false positives.

zsh (5.0.5-3) unstable; urgency=medium

  [ Axel Beckert ]
  * [befdc25a] Don't even try to run test suite on hurd, it hangs.
  * [53e4180a] Add bug scripts to list packages that could interfere with
    zsh's behaviour.
  * [1af939ec] Cherry-pick apt and apt-mark completion updates from
    upstream. (Closes: #691526)
  * [ce0c912b] Cherry-pick upstream fix for INC_APPEND_HISTORY
    regression. (Closes: #749969)
  * [655a374b] Add build-dependency on cm-super-minimal. It FTBFS with TeX
    Live >= 2014 otherwise.

  [ Frank Terbeck ]
  * [5ac620f4] Add note about $fpath entries to README.Debian.

zsh (5.0.5-2) unstable; urgency=medium

  * [9cfeffbc] Add build-dependency on texlive-fonts-recommended
    (c.f. #738402, closes: #738452)
  * [c14fd3a8] Add a debian/upstream/metadata file according to DEP-12

zsh (5.0.5-1) unstable; urgency=medium

  * [8f137a4a] New upstream release
    + No more freeze when piping a function's output (Closes: #732726)
    + Command tab-completion works again after semicolon (Closes: #733075)

zsh (5.0.4-1) unstable; urgency=low

  * [59152a34] New upstream release

zsh (5.0.3-1) unstable; urgency=low

  * [929ba17da] New upstream release
    + [97ed366a] Drop fix-A05execution-ztst-setopt-MONITOR patch (applied
      upstream)
  * [7cdfd51c] Ignore test suite results on hurd-i386 for now
  * [54e2f2ee] Remove use-dev-null-instead-of-dev-tty-for-dash-c-test
    patch again. It was introduced in the hope it would fix test suite
    failures on hurd, ...

Read more...

Changed in zsh (Ubuntu):
status: In Progress → Fix Released
Juha Vainikka (vainikkaj) wrote :

Is 5.0.5 going be available also for trusty?

On 15 July 2014 15:55, Juha Vainikka <email address hidden> wrote:
> Is 5.0.5 going be available also for trusty?
>

No, as that would be out of scope for Stable Release Updates policy. I
may apply similar packaging changes to bring back manpages there as
well.

--
Regards,

Dimitri.

rob (rob-3732872) wrote :

Look, we don't care about release policy. We just want our man pages back!

Is this the best Ubuntu can do??? Trusty is a LTS release! What do you want us to do, check back in a few YEARS?!? This is pathetic!

Changed in zsh (Ubuntu Trusty):
status: New → Confirmed
importance: Undecided → Low
John Y (unikitty37) wrote :

Please do bring this back for Trusty. Surely the release policy should be "if we break something in a release, we fix it in that release"?

Ed Hynan (ehynan-suffolk) wrote :

Marking 'importance' as low is *wrong*. 1) a shell is a fundamental piece of software, of high importance, and 2) the Z shell is an advanced shell with many features and documentation is very important.

Do not suggest the documentation in GNU info or html format. The use of man pages is part of the way people work.

No policy should prevent the repair of this bug, quickly. If it does, that casts Ubuntu in a very poor light.

Dimitri John Ledkov (xnox) wrote :

On 6 August 2014 11:30, Ed Hynan <email address hidden> wrote:
> Marking 'importance' as low is *wrong*. 1) a shell is a fundamental
> piece of software, of high importance, and 2) the Z shell is an advanced
> shell with many features and documentation is very important.
>

Importance is low, because it doesn't cause data loss, crash the OS or
render ones machine unusable.
zsh is still fully operational, albeit without documentation available.

> Do not suggest the documentation in GNU info or html format. The use of
> man pages is part of the way people work.
>
> No policy should prevent the repair of this bug, quickly. If it does,
> that casts Ubuntu in a very poor light.
>

No policy is preventing to repair this bug, on the contrary backport
of the bug fix from utopic as appropriate for trusty is eagerly
awaited by many users here. When someone steps up to create such path
& it gets sponsored into trusty-proposed this bug will be fixed.
However, no such work has been done yet and nobody is working on it at
the moment.

Regards,

Dimitri.

Mike Chelen (mchelen) wrote :

Here is a little one line bash script to download & extract the needed files to the man directory:

wget -qO- "http://downloads.sourceforge.net/project/zsh/zsh/5.0.2/zsh-5.0.2.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fzsh%2Ffiles%2Fzsh%2F5.0.2%2F&ts=1407408881&use_mirror=superb-dca3" | sudo tar xvz -C /usr/share/man/man1/ --wildcards "zsh-5.0.2/Doc/*.1" --strip-components=2 && sudo chown root:root /usr/share/man/man1/zsh*.1

https://gist.github.com/mchelen/60b2853bf84117088662#file-gistfile1-sh-L6

It's not very pretty, but it works.

Rami Lehti (ramilehti) wrote :

I've created a "No change" backport of the utopic package for trusty. They can be obtained from my PPA at
https://launchpad.net/~ramilehti/+archive/ubuntu/ppa

I've also created a formal request for backport (https://bugs.launchpad.net/trusty-backports/+bug/1355811)

Lars Noodén (larsnooden) wrote :

Any word on the backport for Trusty? The man page still ends up missing.

Sebastian Geiger (lanoxx) wrote :

Come on guys, how difficult can it be to make a stable release update for trusty and include the man pages? Is this an LTS after all?

Orhan Cakan (ocakan) wrote :

#all in one manual fix for Ubuntu 14.04 with zsh-5.0.2 (based on mchelen's one-liner):

# get zsh tar file and uncompress its Doc folder to /usr/share/man/man1
wget -qO- "http://downloads.sourceforge.net/project/zsh/zsh/5.0.2/zsh-5.0.2.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fzsh%2Ffiles%2Fzsh%2F5.0.2%2F&ts=1407408881&use_mirror=superb-dca3" | sudo tar xvz -C /usr/share/man/man1/ --wildcards "zsh-5.0.2/Doc/*.1" --strip-components=2

# fix permissions
sudo chown root:root /usr/share/man/man1/zsh*.1
sudo chmod 0644 /usr/share/man/man1/zsh*.1

# gzip the new zsh man pages (all others are gzipped as well)
sudo gzip /usr/share/man/man1/zsh*.1

# renew the man database (so that man -k or apropos finds the newly installed man pages)
sudo mandb

# show installed zsh man pages
man -k zsh

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers