command not found: -antigen-env-setup

Bug #1770915 reported by Andrei Shevchuk on 2018-05-13
This bug affects 22 people
Affects Status Importance Assigned to Milestone
zsh-antigen (Debian)
zsh-antigen (Ubuntu)

Bug Description

When trying to `source /usr/share/zsh-antigen/antigen.zsh` (either in .zshrc or manually), I get `/usr/share/zsh-antigen/antigen.zsh:748: command not found: -antigen-env-setup` error. `/usr/share/zsh-antigen/antigen.zsh` indeed does not contain `-antigen-env-setup` function, in contrast to artful package and upstream `bin/antigen.zsh` (see

See also upstream bug report:

Ubuntu 18.04 amd64, zsh 5.4.2-3ubuntu3, zsh-antigen 2.2.3-1

description: updated
tags: added: bionic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zsh-antigen (Ubuntu):
status: New → Confirmed
Julien Herr (juherr) wrote :

The Debian package maintainer answered on Github:

Please, fix it!

seagle (seagle0128) wrote :

Please fix this issue. Thanks!

WhiteG (whiteg) wrote :

Still not working


Still affecting Disco.

tags: added: disco
RazgrizHsu (razgrizhsu) wrote :

same issue, please fix, Thanks!

Alexander Bragin (alefbragin) wrote :

The bug affects `eoan` too. Please, do not pass it to `focal`

Andrei Shevchuk (shevchuk) wrote :

This bug affects Focal

tags: added: focal
Hans Joachim Desserud (hjd) wrote :

I tried to rebuild the package, but that didn't seem to work. It looks like each time the package is built, certain parts of the code is consistently missing. (See also the corresponding Debian bug report for more detail)

Changed in zsh-antigen (Debian):
status: Unknown → New
tags: added: groovy
removed: disco
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.