package zram-config 0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #996535 reported by DiQ on 2012-05-08
478
This bug affects 89 people
Affects Status Importance Assigned to Milestone
zram-config (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu 12.04 LTS
Release: 12.04

Tried to install zram with synaptic

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: zram-config 0.1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
ApportVersion: 2.0.1-0ubuntu7
AptOrdering:
 zram-config: Install
 zram-config: Configure
Architecture: i386
Date: Tue May 8 14:19:23 2012
Dependencies:

DuplicateSignature:
 Setting up zram-config (0.1) ...
 start: Job failed to start
 invoke-rc.d: initscript zram-config, action "start" failed.
 dpkg: error processing zram-config (--configure):
  subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
PackageArchitecture: all
SourcePackage: zram-config
Title: package zram-config 0.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-05-08 (0 days ago)

DiQ (dik23) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zram-config (Ubuntu):
status: New → Confirmed
tags: added: quantal
Mark Bennett (mark-bennett17) wrote :

+1. At 10 Jan 2013 I have also experienced the issue stated in this Bug Description.

Taqi Raza (mmtrt) wrote :

same here on lubuntu 12.10.

I know what this bug is about (I think) !

This package use a set of scripts to check how much CPU cores you have to set the number of virtual swaps accordingly.
The problem is, the scripts are checking for a text string ("Processor") and this string is usually here one time only.

But if you are using a Pentium M CPU like me, this string is here twice and this confuses the scripts at upstart is trying to init zram.

To repair this package for us, the only thing needed is to make the upstart job script a little wiser.

I myself don't think I have the knowledge to do that, but I will try !

Kevin (scooby-2) wrote :

Same problem on Xubuntu 12.04.2 LTS. CPU is AMD Sempron, if that helps....

Kevin (scooby-2) wrote :

I just found these instructions which purport to be for 12.04 and 12.10:

sudo su
apt-get remove --purge zram-config
apt-add-repository ppa:shnatsel/zram
apt-get update
apt-get install zram-config
exit

This worked for me... Hope it helps someone else.

Kevin (scooby-2) wrote :

UPDATE:

The last 2 line of my dmesg file were:
# dmesg|tail -2
[ 6202.834745] zram: Creating 1 devices ...
[ 6203.394159] Adding 447752k swap on /dev/zram0. Priority:5 extents:1 across:447752k SS

Running the following gave me this:
cat /proc/swaps
Filename Type Size Used Priority
/dev/dm-0 partition 2048252 2820 -1
/dev/zram0 partition 447752 20 5
so it looked like zram was running.

However, after a reboot the zram entry was missing from /proc/swaps file. It looks like the service is running:
# sudo service zramswap status
zramswap start/running
but not providing any swap. I did try running:
# update-rc.d zramswap defaults
which gave an error about missing LSB information and so doesn't work.

I found that if I stop and restart the zram service:
# service zram stop
# service zram start
then everything appears to work OK UNTIL THE NEXT REBOOT ONLY.

Note that I ran all the above commands as root.

Apologies. This is now beyond me!

Richard Sellam (richard-sellam) wrote :

Same issue in Ubuntu 13.04 on Intel Atom N570...

And after upgrade to 13.10, package installed without any error.

Gabriel Mazetto (brodock) wrote :

I still have problems with zram-config on 13.10 while using it on DigitalOcean (Xen Provisor)

Joseph Bylund (joseph-bylund) wrote :

Problems on Amazon EC2.

Same problem on elementary OS Luna, but the tip #7 work for me.
I use a eOS x86 Kernel 3.11

Andrew Ziem (ahziem1) wrote :

I have the same error on Ubuntu 13.10 on Amazon EC2. It seems the problem is the module is not installed:

$ modinfo zram
ERROR: Module zram not found.

Alex Henrie (alexhenrie24) wrote :

I can't reproduce this bug in Ubuntu 14.04 Server, but I can reproduce it on Ubuntu 14.04 cloud: https://cloud-images.ubuntu.com/trusty/current/trusty-server-cloudimg-amd64-disk1.img

`sudo apt-get install linux-image-generic zram-config` fixes the problem.

Since installing linux-image-generic is the only nice way to make sure the correct linux-image-extra package is always installed and available, and zram is particularly useful for RAM-limited Amazon micro instances, I suggest including linux-image-generic in the cloud images by default.

Alex Henrie (alexhenrie24) wrote :

Oh, and if installing linux-image-generic results in a kernel update, you'll have to reboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers