python-zopeinterface removed from Karmic repos still has lots of dependants

Bug #444579 reported by abujafar on 2009-10-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Zope 3
Invalid
Undecided
Unassigned
zope.interface (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by abujafar

Bug Description

Binary package hint: zope3

The package python-zopeinterface has been removed form Karmic repos but it still has lots of dependant packeges. See attached screenshot.

abujafar (abujafar) wrote :
Xavier Bassery (xaba) wrote :

It looks like a transition issue to me.
In aptitude, the package is indeed in the "Obsolete" section.
Having a look at the package description in aptitude, the "Versions" section reads:

      --\ Versions of python-zopeinterface (2)
       i 3.4.0-0ubuntu3
       p python-zope.interface 3.5.2-1

So the new version is listed, but its name is different from the old one.
The obsolete package name is "python-zopeinterface" while the new one is "python-zope.interface".
I should add that the manual selection of the new package does not raise any issue like breaking dependencies and allows a manually forced transition.

Would a meta-package be of any help to make the transition automatic?
Apropos meta-package, the changelog of 3.5.1-2 mentions the "removal of python-zopeinterface metapackage as it is not needed". Is this the culprit?

abujafar (abujafar) wrote :

Manual forcing of "python-zope.interface" worked for me too. Moved as a bug of the new package.

affects: zope3 (Ubuntu) → zope.interface (Ubuntu)
Tres Seaver (tseaver) wrote :

This is a packaging issue inside Ubuntu, and not within the purview of the upstream Zope3 project.

Changed in zope3:
status: New → Invalid
Gediminas Paulauskas (menesis) wrote :

python-zope.interface 3.5.1-2 (in fact, 3.5.2-1) was in karmic and it provides/replaces/conflicts the obsolete python-zopeinterface package, and that is correct.

Some packages still depend on older name, they should be updated, but this is their problem, not a bug in zope.interface package.

Changed in zope.interface (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments