[MIR] Main Inclusion for zope.interface

Bug #425740 reported by James Westby on 2009-09-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
van.pydeb (Ubuntu)
Undecided
Martin Pitt
zope.interface (Ubuntu)
Undecided
Unassigned

Bug Description

Result of the zope3 split, and needed in main for various things.

Just a package split, so not a full MIR.

I am going to optimistically promote this assuming approval as I need
it to get python-apport installable.

Thanks,

James

Loïc Minier (lool) wrote :

Could you please strip XS-Vcs-Svn: since there are some Ubuntu changes?

FYI there's a new upstream minor version.

Someone needs to subscribe to bug mail.

I wondered about this warning:
dpkg-gencontrol: warning: unknown substitution variable ${python:Versions}
since python:Versions is properly subst-ed in the output .deb. I think the issue is that /usr/share/python-van.pydeb/rules_templates/rules.1.mk relies on DH_OPTIONS=-i but nothing exports DH_OPTIONS, so all dh_ commands act on all packages. But that's just a guess. It looks like a real issue though.

Loïc Minier (lool) wrote :

Since it's a split I have no issue with promoting this to main, except the comments I made on sub-ing to bugmail.

Changed in zope.interface (Ubuntu):
status: New → Fix Committed
Matthias Klose (doko) wrote :

van.pydeb needs a MIR and promotion as well

Martin Pitt (pitti) wrote :

I looked at van.pydeb a while ago as part of my spec work. It's pretty imprecise, but as Douglas Adams would say, "mostly harmless". I see no issue with having it in main, we won't need to spend maintenance effort on it.

Approved and promoted.

Changed in van.pydeb (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: New → Fix Released
Matthias Klose (doko) wrote :

zope.interface appears to be in main now.

Changed in zope.interface (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers