Wrong path to ckeditor files

Bug #1306986 reported by Gediminas Paulauskas on 2014-04-12
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
zope.html (Ubuntu)
Critical
Gediminas Paulauskas

Bug Description

SchoolTool 2.6.3, that switched to CKEditor, exposed a packaging bug in zope.html

2014-04-12 19:46:24,719 http://localhost:7080/schoolyears/1/groups/teachers/calendar/add.html
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/zope/publisher/publish.py", line 135, in publish
    response.setResult(result)
  File "/usr/lib/python2.7/dist-packages/zope/publisher/http.py", line 776, in setResult
    r, headers = self._implicitResult(r)
  File "/usr/lib/python2.7/dist-packages/zc/resourcelibrary/publication.py", line 114, in _implicitResult
    html = self._generateIncludes(resource_libraries)
  File "/usr/lib/python2.7/dist-packages/zc/resourcelibrary/publication.py", line 158, in _generateIncludes
    url = library_resources[file_name]()
  File "/usr/lib/python2.7/dist-packages/zope/browserresource/directory.py", line 70, in __getitem__
    raise KeyError(name)
KeyError: u'3.6.1/ckeditor/ckeditor.js'

but it is installed to
/usr/share/pyshared/zope/html/ckeditor/3.3.1/ckeditor

Changed in zope.html (Ubuntu):
assignee: nobody → Gediminas Paulauskas (menesis)
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zope.html (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zope.html - 2.2.0-0ubuntu11

---------------
zope.html (2.2.0-0ubuntu11) trusty; urgency=medium

  * debian/rules: Fix version of ckeditor (LP: #1306986)
  * debian/control:
    - Moved fckeditor to Recommends
    - Increase Standards Version to 3.9.25
  * debian/source/lintian-overrides: add to suppress source-is-missing
    warning.
  *
 -- Gediminas Paulauskas <email address hidden> Sat, 12 Apr 2014 19:52:11 +0300

Changed in zope.html (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers