zookeeper 3.3.4+dfsg1-2ubuntu2 FTBFS on armel and armhf

Bug #920871 reported by James Page on 2012-01-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zookeeper (Ubuntu)
High
Unassigned

Bug Description

The C test suite causes a FTBFS on armel and armhf precise:

# Execute multi-threaded test suite
/usr/bin/make -C src/c zktest-mt
make[2]: Entering directory `/build/buildd/zookeeper-3.3.4+dfsg1/src/c'
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-TestDriver.o -MD -MP -MF .deps/zktest_mt-TestDriver.Tpo -c -o zktest_mt-TestDriver.o `test -f 'tests/TestDriver.cc' || echo './'`tests/TestDriver.cc
mv -f .deps/zktest_mt-TestDriver.Tpo .deps/zktest_mt-TestDriver.Po
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-LibCMocks.o -MD -MP -MF .deps/zktest_mt-LibCMocks.Tpo -c -o zktest_mt-LibCMocks.o `test -f 'tests/LibCMocks.cc' || echo './'`tests/LibCMocks.cc
mv -f .deps/zktest_mt-LibCMocks.Tpo .deps/zktest_mt-LibCMocks.Po
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-LibCSymTable.o -MD -MP -MF .deps/zktest_mt-LibCSymTable.Tpo -c -o zktest_mt-LibCSymTable.o `test -f 'tests/LibCSymTable.cc' || echo './'`tests/LibCSymTable.cc
mv -f .deps/zktest_mt-LibCSymTable.Tpo .deps/zktest_mt-LibCSymTable.Po
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-MocksBase.o -MD -MP -MF .deps/zktest_mt-MocksBase.Tpo -c -o zktest_mt-MocksBase.o `test -f 'tests/MocksBase.cc' || echo './'`tests/MocksBase.cc
mv -f .deps/zktest_mt-MocksBase.Tpo .deps/zktest_mt-MocksBase.Po
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-ZKMocks.o -MD -MP -MF .deps/zktest_mt-ZKMocks.Tpo -c -o zktest_mt-ZKMocks.o `test -f 'tests/ZKMocks.cc' || echo './'`tests/ZKMocks.cc
mv -f .deps/zktest_mt-ZKMocks.Tpo .deps/zktest_mt-ZKMocks.Po
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-Util.o -MD -MP -MF .deps/zktest_mt-Util.Tpo -c -o zktest_mt-Util.o `test -f 'tests/Util.cc' || echo './'`tests/Util.cc
mv -f .deps/zktest_mt-Util.Tpo .deps/zktest_mt-Util.Po
g++ -DHAVE_CONFIG_H -I. -I./include -I./tests -I./generated -D_FORTIFY_SOURCE=2 -DUSE_STATIC_LIB -DTHREADED -DZKSERVER_CMD="\"./tests/zkServer.sh\"" -Wall -g -MT zktest_mt-ThreadingUtil.o -MD -MP -MF .deps/zktest_mt-ThreadingUtil.Tpo -c -o zktest_mt-ThreadingUtil.o `test -f 'tests/ThreadingUtil.cc' || echo './'`tests/ThreadingUtil.cc
/tmp/ccqJWQRC.s: Assembler messages:
/tmp/ccqJWQRC.s:373: Error: bad instruction `lock xaddl r4,[r3,#0]'
/tmp/ccqJWQRC.s:425: Error: bad instruction `lock xchgl r4,[r3,#0]'
make[2]: *** [zktest_mt-ThreadingUtil.o] Error 1
make[2]: Leaving directory `/build/buildd/zookeeper-3.3.4+dfsg1/src/c'
make[1]: *** [override_dh_auto_test-arch] Error 2
make[1]: Leaving directory `/build/buildd/zookeeper-3.3.4+dfsg1'
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

See https://launchpad.net/ubuntu/precise/+source/zookeeper/3.3.4+dfsg1-2ubuntu2 for links to both build logs.

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zookeeper - 3.3.4+dfsg1-2ubuntu3

---------------
zookeeper (3.3.4+dfsg1-2ubuntu3) precise; urgency=low

  * Fix FTBFS of test suite on armel/armhf (LP: #920871):
    - d/patches/fixes/ZOOKEEPER-1374: Use __sync_* primitives
      instead of ASM code to improve portability across supported
      platforms.
    - d/rules: Don't run full core Java test suite on arm architectures
      as it breaks due to JVM incompatibilities.
 -- James Page <email address hidden> Tue, 24 Jan 2012 15:14:43 +0000

Changed in zookeeper (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers