export failed

Bug #740809 reported by Fitch on 2011-03-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
zoneminder (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: zoneminder

This bug may or may not be officially "known", cannot see it in a bugzilla search, so I'll put it in anyway.
Export of video and multiple stills continually fail due to an error in line 255 from the file zm/skins/classic/includes/export_functions.php

$exportFileList = array_merge( $exportFileList, exportFileList( $eid ), $exportDetail, $exportFrames, $exportImages, $exportVideo, $exportMisc );

should read:

$exportFileList = array_merge( $exportFileList, exportFileList( $eid , $exportDetail, $exportFrames, $exportImages, $exportVideo, $exportMisc ));

See:
http://www.zoneminder.com/forums/viewtopic.php?f=21&t=16110&start=15 for the story.

Fitch (brafferton) wrote :

In case you don't want to plough through the story.. (the end bit of the link takes you to post 15, and not the first post.)
Ubuntu Karmic and Lucid show the same fault.
Debian install through Synaptic package manager of ZM 1.24.2
What else do you need?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zoneminder (Ubuntu):
status: New → Confirmed
Walt Howd (walthowd) wrote :

Bug still exists for zoneminder 1.24.2-2build3 on Ubuntu 10.04.2 LTS. Above fix will allow for exporting of events from the event listing window but not from the event details window. This also breaks video generation from the event details window.

ZoneMinder Console - Running - v1.26.5 on debian testing is still affected.
Im trying to troubleshoot this too.

well, I solved my case.

I tried to manually run the video export perl script:

sudo -u www-data zmvideo.pl -e 2 -r 1 -s 1 -F 30 -o

and found that script was complaining about permission error when writing ffmpeg.log
revieweing the perl script code I found that ffmpeg.log was being written to the ZM events folder, so:

sudo chown -R www-data:www-data /var/cache/zoneminder
sudo chown -R www-data:www-data /usr/share/zoneminder/events

solved the problem

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers