[Ubuntu 20.04] zlib on s390x may produce incomplete raw (but not gzip/zlib) streams

Bug #1889059 reported by bugproxy on 2020-07-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Skipper Bug Screeners
zlib (Ubuntu)
Undecided
Canonical Foundations Team
Focal
Undecided
Canonical Foundations Team
Groovy
Undecided
Canonical Foundations Team

Bug Description

zlib on s390x may produce incomplete raw (but not gzip/zlib) streams

---uname output---
Linux t35lp56.lnxne.boe 5.8.0-20200703.rc3.git0.52a479d42203.300.fc31.s390x #1 SMP Fri Jul 3 00:46:20 CEST 2020 s390x s390x s390x GNU/Linux

Machine Type = z15

---Debugger---
A debugger is not configured

---Steps to Reproduce---
 Create a raw (negative windowBits value) stream with zlib. EOBS might be missing or truncated.

This affects all distro levels that contain hardware acceleration (DFLTCC) patch. I've attached the preliminary fix.

Default Comment by Bridge

tags: added: architecture-s3903164 bugnameltc-186995 severity-high targetmilestone-inin2004
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → zlib (Ubuntu)
Frank Heimes (fheimes) on 2020-07-27
Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Changed in zlib (Ubuntu Groovy):
assignee: Skipper Bug Screeners (skipper-screen-team) → Canonical Foundations Team (canonical-foundations)
Changed in zlib (Ubuntu Focal):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in ubuntu-z-systems:
importance: Undecided → High
bugproxy (bugproxy) wrote : debs
  • debs Edit (836.3 KiB, application/gzip)

------- Comment (attachment only) From <email address hidden> 2020-07-27 11:27 EDT-------

tags: added: id-5f1ef5fbb4e583090040ab60

------- Comment From <email address hidden> 2020-07-30 10:45 EDT-------
Compiled and ran DeInflate.java test program.
# javac DeInflate.java
Without fix encountered the following behaviour:
# java DeInflate.java
Exception in thread "main" java.lang.RuntimeException: De/inflater failed:java.util.zip.Deflater@3c73951
at DeInflate.check(DeInflate.java:91)
at DeInflate.main(DeInflate.java:139)

# dpkg -i zlib1g_1.2.11.dfsg-2ubuntu2_s390x.deb
(Reading database ... 58606 files and directories currently installed.)
Preparing to unpack zlib1g_1.2.11.dfsg-2ubuntu2_s390x.deb ...
Unpacking zlib1g:s390x (1:1.2.11.dfsg-2ubuntu2) over (1:1.2.11.dfsg-2ubuntu1) ...
Setting up zlib1g:s390x (1:1.2.11.dfsg-2ubuntu2) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...

Problem not longer seen.

Frank Heimes (fheimes) wrote :

@Christian, thx for the preliminary fix and the test.
May I ask if the path is already upstream accepted or if you are working on that?

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-07-30 17:13 EDT-------
Unfortunately zlib does not accept patches at the moment, so it is unlikely that this fix will be accepted in the strict sense of the word anytime soon. However, I will include
https://github.com/iii-i/zlib/commit/aff708461f9903055edf07c8e908f860788d069d, which contains this fix, into my "official" hardware acceleration pull request (https://github.com/madler/zlib/pull/410) in the next few days.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-08-05 12:34 EDT-------
I've updated https://github.com/madler/zlib/pull/410 to https://github.com/iii-i/zlib/releases/tag/dfltcc-20200805 level.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-08-11 03:25 EDT-------
@fheimes, gentle ping. How are things looking on your side?

Frank Heimes (fheimes) wrote :

Due to the work on the point releases (20.04.1 and 18.04.5 within 2 weeks) there is some delay on this. But the maintaining team is aware of this...

Michael Hudson-Doyle (mwhudson) wrote :

Hi, is it correct to say that fixing this bug and bug 1882494 just requires updating the patch we have to the current state of the https://github.com/madler/zlib/pull/410 pull request? If so, the package that is currently building at https://launchpad.net/~mwhudson/+archive/ubuntu/devirt/+packages?field.name_filter=zlib should have the fix and would be worth testing.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-08-19 20:27 EDT-------
Hi, yes, this is correct. The latest version of the pull request has the fix.

Great thanks for confirming. Are you able to test the packages mentioned above? We don't have z15 hardware to test on (also bug 1884514 while you're here :-p)

Frank Heimes (fheimes) on 2020-08-24
Changed in ubuntu-z-systems:
status: New → Triaged
Frank Heimes (fheimes) on 2020-08-26
Changed in ubuntu-z-systems:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zlib - 1:1.2.11.dfsg-2ubuntu2

---------------
zlib (1:1.2.11.dfsg-2ubuntu2) groovy; urgency=medium

  * Update d/patches/410.patch to current state. LP: #1882494, #1889059, #1893170

 -- Michael Hudson-Doyle <email address hidden> Thu, 20 Aug 2020 11:52:59 +1200

Changed in zlib (Ubuntu Groovy):
status: New → Fix Released
Frank Heimes (fheimes) wrote :

aligned state to LP 1893170

Changed in zlib (Ubuntu Focal):
status: New → Fix Committed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Frank Heimes (fheimes) wrote :

Updating the status of this ticket to Fix Released because it is now fixed based on LP 1893170.

Changed in zlib (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
tags: added: fr-176
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-10-20 08:53 EDT-------
IBM Buzgilla -> closed, Fix Released with all requested distros

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers