lib64z1: call dh_makeshlibs for the lib64z1 package

Bug #1766566 reported by Matthias Klose on 2018-04-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zlib (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

SRU:

dh_makeshlibs is not called for the lib64z1 package, letting packages which have dependencies on this library fail to build:

DIRNAME=64 dh_shlibdeps -plib64gphobos71 -l/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnu:/lib64:/usr/lib64:/<<PKGBUI
LDDIR>>/debian/tmp/usr/lib64:/<<PKGBUILDDIR>>/debian/tmp/usr/x86_64-linux-gnu/lib -- -Ldebian/shlibs.common64
dpkg-shlibdeps: error: no dependency information found for /usr/lib64/libz.so.1 (used by debian/lib64gphobos71/usr/lib6
4/libgphobos.so.71.0.2)
dh_shlibdeps: dpkg-shlibdeps -Tdebian/lib64gphobos71.substvars -l/lib/x86_64-linux-gnu -l/usr/lib/x86_64-linux-gnu -l/l
ib64 -l/usr/lib64 -l/<<PKGBUILDDIR>>/debian/tmp/usr/lib64 -l/<<PKGBUILDDIR>>/debian/tmp/usr/x86_64-linux-gnu/lib -Ldebi
an/shlibs.common64 debian/lib64gphobos71/usr/lib64/libgphobos.so.71.0.2 debian/lib64gphobos71/usr/lib64/libgdruntime.so
.71.0.2 returned exit code 2
make[1]: *** [stamps/08-binary-stamp-lib64phobos] Error 2

The fix is simple, and in wily and newer Ubuntu versions.

SRU validation: the package builds, and dh_shlibdeps doesn't fail anymore for depending packages (e.g. the gcc-7 build in the ubuntu-toolchain-r/test directory.

Matthias Klose (doko) on 2018-04-24
Changed in zlib (Ubuntu):
status: New → Fix Released
Robie Basak (racb) wrote :

Thank you for the upload. Please fill out the Regression Potential information. See https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Robie Basak (racb) wrote :

(or if it doesn't apply, please explain that here)

Matthias Klose (doko) wrote :

It's a change to a library package which is normally unused, so I don't see any regression potential there.

However zlib was not built in trusty, but in saucy only. So there could be unexpected results, however I don't see build failures in the trusty test rebuilds either.

Hello Matthias, or anyone else affected,

Accepted zlib into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zlib/1:1.2.8.dfsg-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zlib (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed verification-needed-trusty
Matthias Klose (doko) wrote :

the package built, and dh_makeshlibs is called for the lib64z1 package.

tags: added: verification-done verification-done-trusty
removed: verification-needed verification-needed-trusty
Łukasz Zemczak (sil2100) wrote :

Confirmed that the autopkgtest failures are not regressions caused by this upload. Releasing.

The verification of the Stable Release Update for zlib has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zlib - 1:1.2.8.dfsg-1ubuntu1.1

---------------
zlib (1:1.2.8.dfsg-1ubuntu1.1) trusty-proposed; urgency=medium

  * SRU: LP: #1766566.
  * Call dh_makeshlibs for the 64bit multilib package.

 -- Matthias Klose <email address hidden> Tue, 24 Apr 2018 13:42:30 +0200

Changed in zlib (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers