Activity log for bug #1692870

Date Who What changed Old value New value Message
2017-05-23 11:47:51 Jean-Louis Dupond bug added bug
2017-05-23 11:49:34 Jean-Louis Dupond attachment added New version with patch included. https://bugs.launchpad.net/ubuntu/+source/zlib/+bug/1692870/+attachment/4881920/+files/fix_deflateParams.debdiff
2017-05-23 11:57:03 Jean-Louis Dupond description Hi, Since I upgraded from Ubuntu 16.10 to 17.04, my Guest portal for my UniFi system was broken (https://www.ubnt.com/download/unifi/). Curl gave me the following response: # curl -vvvv --compress localhost:8880/guest/s/default/ * Trying ::1... * TCP_NODELAY set * Connected to localhost (::1) port 8880 (#0) > GET /guest/s/default/ HTTP/1.1 > Host: localhost:8880 > User-Agent: curl/7.52.1 > Accept: */* > Accept-Encoding: deflate, gzip > < HTTP/1.1 200 OK < Server: Apache-Coyote/1.1 < Content-Type: text/html;charset=utf-8 < Transfer-Encoding: chunked < Content-Encoding: gzip < Vary: Accept-Encoding < Date: Tue, 23 May 2017 11:19:22 GMT < * Error while processing content unencoding: invalid code lengths set * Failed writing data * Curl_http_done: called premature == 1 * Closing connection 0 curl: (23) Error while processing content unencoding: invalid code lengths set After some debugging, I found out that downgrading to zlib 1:1.2.8.dfsg-2ubuntu5.1 was a workaround. Now after digging into the issue some more, I found the following upstream patch (unreleased version), fixes the issue: https://github.com/madler/zlib/commit/f9694097dd69354b03cb8af959094c7f260db0a1 I've created a new package, and its working fine again. Now as the UniFi controller is just some Tomcat, which relies on Java (OpenJDK), which uses zlib for its built-in Compression/Decompression. I guess even more java related tools can be broken. But I didn't have time to test this. At least some other people using UniFi have the same issue, see: https://community.ubnt.com/t5/UniFi-Wireless/ERR-CONTENT-DECODING-FAILED-on-guest-portal-customisation/td-p/1903419 [Impact] Since I upgraded from Ubuntu 16.10 to 17.04, my Guest portal for my UniFi system was broken (https://www.ubnt.com/download/unifi/). Curl gave me the following response: # curl -vvvv --compress localhost:8880/guest/s/default/ * Trying ::1... * TCP_NODELAY set * Connected to localhost (::1) port 8880 (#0) > GET /guest/s/default/ HTTP/1.1 > Host: localhost:8880 > User-Agent: curl/7.52.1 > Accept: */* > Accept-Encoding: deflate, gzip > < HTTP/1.1 200 OK < Server: Apache-Coyote/1.1 < Content-Type: text/html;charset=utf-8 < Transfer-Encoding: chunked < Content-Encoding: gzip < Vary: Accept-Encoding < Date: Tue, 23 May 2017 11:19:22 GMT < * Error while processing content unencoding: invalid code lengths set * Failed writing data * Curl_http_done: called premature == 1 * Closing connection 0 curl: (23) Error while processing content unencoding: invalid code lengths set [Test Case] Just install a fresh Ubuntu 17.04 with UniFi controller. And the Guest Portal is broken. See above. When disabling compression in curl, it works fine. After some debugging, I found out that downgrading to zlib 1:1.2.8.dfsg-2ubuntu5.1 was a workaround. Now after digging into the issue some more, I found the following upstream patch (unreleased version), fixes the issue: https://github.com/madler/zlib/commit/f9694097dd69354b03cb8af959094c7f260db0a1 [Regression Potential] Everybody upgrading from 16.10 (or previous) to 17.04 will be affected by this. The patch is taken from upstream, so this isn't a change we will need to keep different from upstream. I've already created a new package (see debdiff) that fixes the issue. [Other Info] Now as the UniFi controller is just some Tomcat, which relies on Java (OpenJDK), which uses zlib for its built-in Compression/Decompression. I guess even more java related tools can be broken. But I didn't have time to test this. At least some other people using UniFi have the same issue, see: https://community.ubnt.com/t5/UniFi-Wireless/ERR-CONTENT-DECODING-FAILED-on-guest-portal-customisation/td-p/1903419
2017-05-23 12:28:48 Ubuntu Foundations Team Bug Bot tags patch
2017-05-23 12:28:54 Ubuntu Foundations Team Bug Bot bug added subscriber Ubuntu Sponsors Team
2017-05-23 13:31:04 Launchpad Janitor zlib (Ubuntu): status New Confirmed
2017-05-23 16:17:28 Brian Murray nominated for series Ubuntu Zesty
2017-05-23 16:17:28 Brian Murray bug task added zlib (Ubuntu Zesty)
2017-05-23 16:19:19 Brian Murray tags patch patch regression-release
2017-05-23 16:19:36 Brian Murray tags patch regression-release patch regression-release rls-aa-incoming
2017-05-26 00:13:09 Darwin Mach bug added subscriber Darwin Mach
2017-06-16 22:45:18 Chris Buechler bug added subscriber Chris Buechler
2017-06-17 12:49:24 Jean-Louis Dupond description [Impact] Since I upgraded from Ubuntu 16.10 to 17.04, my Guest portal for my UniFi system was broken (https://www.ubnt.com/download/unifi/). Curl gave me the following response: # curl -vvvv --compress localhost:8880/guest/s/default/ * Trying ::1... * TCP_NODELAY set * Connected to localhost (::1) port 8880 (#0) > GET /guest/s/default/ HTTP/1.1 > Host: localhost:8880 > User-Agent: curl/7.52.1 > Accept: */* > Accept-Encoding: deflate, gzip > < HTTP/1.1 200 OK < Server: Apache-Coyote/1.1 < Content-Type: text/html;charset=utf-8 < Transfer-Encoding: chunked < Content-Encoding: gzip < Vary: Accept-Encoding < Date: Tue, 23 May 2017 11:19:22 GMT < * Error while processing content unencoding: invalid code lengths set * Failed writing data * Curl_http_done: called premature == 1 * Closing connection 0 curl: (23) Error while processing content unencoding: invalid code lengths set [Test Case] Just install a fresh Ubuntu 17.04 with UniFi controller. And the Guest Portal is broken. See above. When disabling compression in curl, it works fine. After some debugging, I found out that downgrading to zlib 1:1.2.8.dfsg-2ubuntu5.1 was a workaround. Now after digging into the issue some more, I found the following upstream patch (unreleased version), fixes the issue: https://github.com/madler/zlib/commit/f9694097dd69354b03cb8af959094c7f260db0a1 [Regression Potential] Everybody upgrading from 16.10 (or previous) to 17.04 will be affected by this. The patch is taken from upstream, so this isn't a change we will need to keep different from upstream. I've already created a new package (see debdiff) that fixes the issue. [Other Info] Now as the UniFi controller is just some Tomcat, which relies on Java (OpenJDK), which uses zlib for its built-in Compression/Decompression. I guess even more java related tools can be broken. But I didn't have time to test this. At least some other people using UniFi have the same issue, see: https://community.ubnt.com/t5/UniFi-Wireless/ERR-CONTENT-DECODING-FAILED-on-guest-portal-customisation/td-p/1903419 [Impact] Since I upgraded from Ubuntu 16.10 to 17.04, my Guest portal for my UniFi system was broken (https://www.ubnt.com/download/unifi/). Curl gave me the following response: # curl -vvvv --compress localhost:8880/guest/s/default/ * Trying ::1... * TCP_NODELAY set * Connected to localhost (::1) port 8880 (#0) > GET /guest/s/default/ HTTP/1.1 > Host: localhost:8880 > User-Agent: curl/7.52.1 > Accept: */* > Accept-Encoding: deflate, gzip > < HTTP/1.1 200 OK < Server: Apache-Coyote/1.1 < Content-Type: text/html;charset=utf-8 < Transfer-Encoding: chunked < Content-Encoding: gzip < Vary: Accept-Encoding < Date: Tue, 23 May 2017 11:19:22 GMT < * Error while processing content unencoding: invalid code lengths set * Failed writing data * Curl_http_done: called premature == 1 * Closing connection 0 curl: (23) Error while processing content unencoding: invalid code lengths set [Test Case] - Install UniFi controller on Ubuntu 17.04 (http://dl.ubnt.com/unifi/5.4.16/unifi_sysvinit_all.deb) - Go to https://<ip>:8443/manage/site/default/settings/guestcontrol - Or do: curl -vvvv --compress <ip>:8880/guest/s/default/ When compression is enabled, its broken. When disabling compression in curl, it works fine. After some debugging, I found out that downgrading to zlib 1:1.2.8.dfsg-2ubuntu5.1 was a workaround. Now after digging into the issue some more, I found the following upstream patch (unreleased version), fixes the issue: https://github.com/madler/zlib/commit/f9694097dd69354b03cb8af959094c7f260db0a1 [Regression Potential] Everybody upgrading from 16.10 (or previous) to 17.04 will be affected by this. The patch is taken from upstream, so this isn't a change we will need to keep different from upstream. I've already created a new package (see debdiff) that fixes the issue. [Other Info] Now as the UniFi controller is just some Tomcat, which relies on Java (OpenJDK), which uses zlib for its built-in Compression/Decompression. I guess even more java related tools can be broken. But I didn't have time to test this. At least some other people using UniFi have the same issue, see: https://community.ubnt.com/t5/UniFi-Wireless/ERR-CONTENT-DECODING-FAILED-on-guest-portal-customisation/td-p/1903419
2017-06-21 20:32:54 Martin Tibke bug added subscriber Martin Tibke
2017-06-21 20:40:30 Launchpad Janitor zlib (Ubuntu Zesty): status New Confirmed
2017-08-13 18:56:35 Christian Krützfeldt bug added subscriber Christian Krützfeldt
2017-08-16 02:14:09 Allyn Bottorff bug added subscriber Allyn Bottorff
2017-08-17 15:23:48 Steve Langasek zlib (Ubuntu): importance Undecided High
2017-08-17 15:23:49 Steve Langasek zlib (Ubuntu Zesty): importance Undecided High
2017-08-17 15:24:18 Brian Murray nominated for series Ubuntu Artful
2017-08-17 15:24:18 Brian Murray bug task added zlib (Ubuntu Artful)
2017-08-17 15:24:40 Brian Murray tags patch regression-release rls-aa-incoming patch regression-release
2017-08-17 15:41:28 Steve Langasek zlib (Ubuntu Zesty): assignee Steve Langasek (vorlon)
2017-08-17 15:41:33 Steve Langasek zlib (Ubuntu Zesty): assignee Steve Langasek (vorlon)
2017-08-17 15:41:34 Steve Langasek zlib (Ubuntu): assignee Steve Langasek (vorlon)
2017-08-17 15:41:37 Steve Langasek zlib (Ubuntu): status Confirmed Fix Committed
2017-08-22 22:47:13 Launchpad Janitor zlib (Ubuntu Artful): status Fix Committed Fix Released