package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4

Bug #1512992 reported by robert key on 2015-11-04
406
This bug affects 74 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
zlib (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

Test Case
---------
1) Install zlib1g-dev:i386
2) Install lib32z1-dev.
3) Observe a package installation failure

After enabling -proposed you should be able to install both packages without an issue.

Original Description
--------------------

The package did not install when I did a fresh install of 15.10.

ProblemType: PackageDistroRelease: Ubuntu 15.10
Package: zlib1g-dev 1:1.2.8.dfsg-2ubuntu4
ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
Uname: Linux 4.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
Date: Wed Nov 4 10:36:43 2015
DuplicateSignature: package:zlib1g-dev:1:1.2.8.dfsg-2ubuntu4:trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
ErrorMessage: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
InstallationDate: Installed on 2015-11-04 (0 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
RelatedPackageVersions:
 dpkg 1.18.2ubuntu5
 apt 1.0.10.2ubuntu1SourcePackage: zlib
Title: package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
UpgradeStatus: No upgrade log present (probably fresh install)

robert key (rob54321) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in zlib (Ubuntu):
status: New → Confirmed
Changed in zlib (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
tags: removed: need-duplicate-check

I'm encountering the same bug on xubuntu-15.10:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libpng12-dev:i386 : Depends: zlib1g-dev:i386 but it is not installed
E: Unmet dependencies. Try using -f.

$ sudo apt-get -f upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  appmenu-qt appmenu-qt5 apturl apturl-common bamfdaemon brasero brasero-cdrkit empathy-common folks-common gedit-common gir1.2-accounts-1.0
  gir1.2-gdata-0.0 gir1.2-goa-1.0 gir1.2-gtksource-3.0 gir1.2-signon-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 indicator-appmenu
  indicator-printers jayatana libavahi-gobject0 libbamf3-2 libchamplain-0.12-0 libedataserverui-1.2-1 libfolks-eds25 libfolks25 libframe6
  libgail-3-0 libgeis1 libglewmx1.10 libgrail6 libmission-control-plugins0 libnux-4.0-0 libnux-4.0-common libtelepathy-farstream3
  libtelepathy-logger3 libunity-core-6.0-9 libunity-gtk2-parser0 libunity-gtk3-parser0 libunity-misc4 libwhoopsie-preferences0 nux-tools
  python3-feedparser signon-plugin-password telepathy-gabble telepathy-haze telepathy-indicator telepathy-logger telepathy-mission-control-5
  telepathy-salut unity-gtk2-module unity-gtk3-module unity-lens-music unity-lens-photos unity-schemas unity-scope-audacious
  unity-scope-calculator unity-scope-chromiumbookmarks unity-scope-clementine unity-scope-colourlovers unity-scope-devhelp
  unity-scope-firefoxbookmarks unity-scope-gdrive unity-scope-gmusicbrowser unity-scope-gourmet unity-scope-guayadeque unity-scope-home
  unity-scope-manpages unity-scope-musicstores unity-scope-musique unity-scope-openclipart unity-scope-texdoc unity-scope-tomboy
  unity-scope-virtualbox unity-scope-yelp unity-scope-zotero unity-scopes-master-default unity-scopes-runner unity-services
  whoopsie-preferences
Use 'apt-get autoremove' to remove them.
Done
The following NEW packages will be installed:
  zlib1g-dev:i386
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/167 kB of archives.
After this operation, 403 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 261971 files and directories currently installed.)
Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb ...
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-2ubuntu4) ...
dpkg: error processing archive /var/cache/apt/archives/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb (--unpack):
 trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
Processing triggers for man-db (2.7.4-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

-> is there a way to repair my packages?

In case it helps someone else having the same issue, I repaired my apt-get packages using:

$ sudo apt-get -o Dpkg::Options::="--force-overwrite" install zlib1g-dev:i386

I came up with this after reading this... https://raphaelhertzog.com/2011/08/01/understanding-dpkgs-file-overwrite-error/

tags: added: xenial

THanks.

On Mon, Aug 15, 2016 at 2:47 PM, Hans Joachim Desserud <
<email address hidden>> wrote:

> ** Tags added: xenial
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1523105).
> https://bugs.launchpad.net/bugs/1512992
>
> Title:
> package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade:
> trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is
> also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
>
> Status in One Hundred Papercuts:
> Confirmed
> Status in zlib package in Ubuntu:
> Confirmed
>
> Bug description:
> The package did not install when I did a fresh install of 15.10.
>
> ProblemType: Package
> DistroRelease: Ubuntu 15.10
> Package: zlib1g-dev 1:1.2.8.dfsg-2ubuntu4
> ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
> Uname: Linux 4.2.0-17-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.19.1-0ubuntu4
> Architecture: amd64
> Date: Wed Nov 4 10:36:43 2015
> DuplicateSignature: package:zlib1g-dev:1:1.2.8.dfsg-2ubuntu4:trying to
> overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package
> lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
> ErrorMessage: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h',
> which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
> InstallationDate: Installed on 2015-11-04 (0 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> RelatedPackageVersions:
> dpkg 1.18.2ubuntu5
> apt 1.0.10.2ubuntu1
> SourcePackage: zlib
> Title: package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to
> install/upgrade: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h',
> which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1512992/+subscriptions
>

nimbosa (darth-serious) wrote :

i have a duplicate bug, but runs in reverse:

package lib32z1-dev (not installed) failed to install/upgrade: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package zlib1g-dev:i386 1:1.2.8.dfsg-2ubuntu4
___
Errors were encountered while processing:
 /var/cache/apt/archives/lib32z1-dev_1%3a1.2.8.dfsg-2ubuntu4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
___

and this is a FRESH install!

should i force this as:
$ sudo apt-get -o Dpkg::Options::="--force-overwrite" install lib32z1-dev
???

Thanks!

Yes force it

On 29-Aug-2016 06:15, "nimbosa" <email address hidden> wrote:

> i have a duplicate bug, but runs in reverse:
>
> package lib32z1-dev (not installed) failed to install/upgrade: trying to
> overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package
> zlib1g-dev:i386 1:1.2.8.dfsg-2ubuntu4
> ___
> Errors were encountered while processing:
> /var/cache/apt/archives/lib32z1-dev_1%3a1.2.8.dfsg-2ubuntu4_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> ___
>
> and this is a FRESH install!
>
> should i force this as:
> $ sudo apt-get -o Dpkg::Options::="--force-overwrite" install lib32z1-dev
> ???
>
> Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1512992
>
> Title:
> package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to install/upgrade:
> trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is
> also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
>
> Status in One Hundred Papercuts:
> Confirmed
> Status in zlib package in Ubuntu:
> Confirmed
>
> Bug description:
> The package did not install when I did a fresh install of 15.10.
>
> ProblemType: Package
> DistroRelease: Ubuntu 15.10
> Package: zlib1g-dev 1:1.2.8.dfsg-2ubuntu4
> ProcVersionSignature: Ubuntu 4.2.0-17.21-generic 4.2.3
> Uname: Linux 4.2.0-17-generic x86_64
> NonfreeKernelModules: nvidia
> ApportVersion: 2.19.1-0ubuntu4
> Architecture: amd64
> Date: Wed Nov 4 10:36:43 2015
> DuplicateSignature: package:zlib1g-dev:1:1.2.8.dfsg-2ubuntu4:trying to
> overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package
> lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
> ErrorMessage: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h',
> which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
> InstallationDate: Installed on 2015-11-04 (0 days ago)
> InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64
> (20151021)
> RelatedPackageVersions:
> dpkg 1.18.2ubuntu5
> apt 1.0.10.2ubuntu1
> SourcePackage: zlib
> Title: package zlib1g-dev 1:1.2.8.dfsg-2ubuntu4 failed to
> install/upgrade: trying to overwrite '/usr/include/i386-linux-gnu/zconf.h',
> which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hundredpapercuts/+bug/1512992/+subscriptions
>

Someone Else (n00by0815) wrote :

Problem still present in 16.04 LTS
LOG:
(Reading database ... 216786 files and directories currently installed.)
Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb ...
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-2ubuntu4) ...
dpkg: error processing archive /var/cache/apt/archives/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb (--unpack):
 trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I encountered this while trying to setup an Android build environment/kernel building environment.

Forcing as mentioned above works.

Hans Joachim Desserud (hjd) wrote :

Based on some of the duplicate bugs, this also affects Ubuntu 16.10.

tags: added: yakkety
removed: wily

Sure it affects Ubuntu 16.04. I was trying to install the wine 2.0 libs when it happened.

Brian Murray (brian-murray) wrote :

I managed to recreate this is a clean yakkety virtual machine by installing zlib1g-dev:i386 and then installing lib32z1-dev.

Brian Murray (brian-murray) wrote :

This is *not* reproducible on zesty so the packaging changes in zesty bear investigating.

Hello robert, or anyone else affected,

Accepted zlib into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zlib/1:1.2.8.dfsg-2ubuntu5.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in zlib (Ubuntu Yakkety):
status: New → Fix Committed
tags: added: verification-needed
Changed in zlib (Ubuntu Xenial):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

Hello robert, or anyone else affected,

Accepted zlib into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zlib/1:1.2.8.dfsg-2ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zlib (Ubuntu):
status: Confirmed → Fix Released
Andreas Hasenack (ahasenack) wrote :

xenial verification

Reproduced the bug without proposed:
root@zlib-xenial-1512992:~# apt install zlib1g-dev:i386 lib32z1-dev
(...)
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-2ubuntu4) ...
dpkg: error processing archive /var/cache/apt/archives/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb (--unpack):
 trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu4
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

With proposed enabled, installation works just fine: http://pastebin.ubuntu.com/24498586/
root@zlib-xenial-1512992:~# apt-cache policy zlib1g-dev:i386 lib32z1-dev
zlib1g-dev:i386:
  Installed: 1:1.2.8.dfsg-2ubuntu4.1
  Candidate: 1:1.2.8.dfsg-2ubuntu4.1
  Version table:
 *** 1:1.2.8.dfsg-2ubuntu4.1 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:1.2.8.dfsg-2ubuntu4 500
        500 http://br.archive.ubuntu.com/ubuntu xenial/main i386 Packages
lib32z1-dev:
  Installed: 1:1.2.8.dfsg-2ubuntu4.1
  Candidate: 1:1.2.8.dfsg-2ubuntu4.1
  Version table:
 *** 1:1.2.8.dfsg-2ubuntu4.1 500
        500 http://br.archive.ubuntu.com/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:1.2.8.dfsg-2ubuntu4 500
        500 http://br.archive.ubuntu.com/ubuntu xenial/main amd64 Packages

tags: added: verification-done-xenial
Andreas Hasenack (ahasenack) wrote :

yakkety verification:

without proposed:
root@zlib-yakkety-1512992:~# apt install zlib1g-dev:i386 lib32z1-dev
(...)
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-2ubuntu5) ...
dpkg: error processing archive /tmp/apt-dpkg-install-ZGcn5m/59-zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu5_i386.deb (--unpack):
 trying to overwrite '/usr/include/i386-linux-gnu/zconf.h', which is also in package lib32z1-dev 1:1.2.8.dfsg-2ubuntu5
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /tmp/apt-dpkg-install-ZGcn5m/59-zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu5_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

With proposed enabled it installs just fine: http://pastebin.ubuntu.com/24498634/
root@zlib-yakkety-1512992:~# apt-cache policy zlib1g-dev:i386 lib32z1-dev
zlib1g-dev:i386:
  Installed: 1:1.2.8.dfsg-2ubuntu5.1
  Candidate: 1:1.2.8.dfsg-2ubuntu5.1
  Version table:
 *** 1:1.2.8.dfsg-2ubuntu5.1 500
        500 http://br.archive.ubuntu.com/ubuntu yakkety-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:1.2.8.dfsg-2ubuntu5 500
        500 http://br.archive.ubuntu.com/ubuntu yakkety/main i386 Packages
lib32z1-dev:
  Installed: 1:1.2.8.dfsg-2ubuntu5.1
  Candidate: 1:1.2.8.dfsg-2ubuntu5.1
  Version table:
 *** 1:1.2.8.dfsg-2ubuntu5.1 500
        500 http://br.archive.ubuntu.com/ubuntu yakkety-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:1.2.8.dfsg-2ubuntu5 500
        500 http://br.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages

tags: added: verification-done-yakkety
Ragusa (constantin.laurent) wrote :

Thanks for the fix. It is great to have a feedback (and a fast one). You are doing a great job.

Fathi Boudra (fboudra) wrote :

For how long is it going to stay in -proposed?
The fix for Xenial (current LTS) has been published on 2017-03-03, 2 months ago.

Robie Basak (racb) wrote :

@Fathi

Sorry for the delay. It was caused by nobody affected coming forward to verify the proposed fixes as requested in comments 13 and 14. As Andreas has kindly stepped in to verify the fixes, I can now release the fixes to the updates pockets.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zlib - 1:1.2.8.dfsg-2ubuntu4.1

---------------
zlib (1:1.2.8.dfsg-2ubuntu4.1) xenial-proposed; urgency=medium

  * SRU
  * Move zconf.h back to /usr/include (not differing across architectures)
    anymore. Closes: #787956. LP: #1512992.

 -- Matthias Klose <email address hidden> Fri, 03 Mar 2017 18:31:53 +0100

Changed in zlib (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zlib - 1:1.2.8.dfsg-2ubuntu5.1

---------------
zlib (1:1.2.8.dfsg-2ubuntu5.1) yakkety-proposed; urgency=medium

  * SRU
  * Move zconf.h back to /usr/include (not differing across architectures)
    anymore. Closes: #787956. LP: #1512992.

 -- Matthias Klose <email address hidden> Fri, 03 Mar 2017 18:36:09 +0100

Changed in zlib (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Hans Joachim Desserud (hjd) wrote :

Could someone please take a look at bug 1690178? It looks similar to this one, but occured when attempting to install the update.

Changed in hundredpapercuts:
status: Confirmed → Fix Released
Download full text (11.6 KiB)

I don't see any issue.

luca@luca-ThinkPad-X220:~$ sudo apt install lib32z1-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.8.0-36 linux-headers-4.8.0-36-generic linux-image-4.8.0-36-generic
  linux-image-extra-4.8.0-36-generic python3-pip
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gcc-5-multilib gcc-multilib lib32asan2 lib32atomic1 lib32cilkrts5 lib32gcc-5-dev lib32gcc1
  lib32gomp1 lib32itm1 lib32mpx0 lib32quadmath0 lib32stdc++6 lib32ubsan0 lib32z1 libc6-dev-i386
  libc6-dev-x32 libc6-i386 libc6-x32 libx32asan2 libx32atomic1 libx32cilkrts5 libx32gcc-5-dev
  libx32gcc1 libx32gomp1 libx32itm1 libx32quadmath0 libx32stdc++6 libx32ubsan0
The following NEW packages will be installed:
  gcc-5-multilib gcc-multilib lib32asan2 lib32atomic1 lib32cilkrts5 lib32gcc-5-dev lib32gcc1
  lib32gomp1 lib32itm1 lib32mpx0 lib32quadmath0 lib32stdc++6 lib32ubsan0 lib32z1 lib32z1-dev
  libc6-dev-i386 libc6-dev-x32 libc6-i386 libc6-x32 libx32asan2 libx32atomic1 libx32cilkrts5
  libx32gcc-5-dev libx32gcc1 libx32gomp1 libx32itm1 libx32quadmath0 libx32stdc++6 libx32ubsan0
0 upgraded, 29 newly installed, 0 to remove and 6 not upgraded.
Need to get 14,0 MB of archives.
After this operation, 59,0 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libc6-i386 amd64 2.23-0ubuntu7 [2.337 kB]
Get:2 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libc6-dev-i386 amd64 2.23-0ubuntu7 [1.262 kB]
Get:3 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libc6-x32 amd64 2.23-0ubuntu7 [2.561 kB]
Get:4 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libc6-dev-x32 amd64 2.23-0ubuntu7 [1.558 kB]
Get:5 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 lib32gcc1 amd64 1:6.0.1-0ubuntu1 [46,6 kB]
Get:6 http://it.archive.ubuntu.com/ubuntu xenial/main amd64 libx32gcc1 amd64 1:6.0.1-0ubuntu1 [38,7 kB]
Get:7 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 lib32gomp1 amd64 5.4.0-6ubuntu1~16.04.4 [59,7 kB]
Get:8 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libx32gomp1 amd64 5.4.0-6ubuntu1~16.04.4 [55,4 kB]
Get:9 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 lib32itm1 amd64 5.4.0-6ubuntu1~16.04.4 [29,5 kB]
Get:10 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libx32itm1 amd64 5.4.0-6ubuntu1~16.04.4 [27,7 kB]
Get:11 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 lib32atomic1 amd64 5.4.0-6ubuntu1~16.04.4 [8.634 B]
Get:12 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libx32atomic1 amd64 5.4.0-6ubuntu1~16.04.4 [8.888 B]
Get:13 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 lib32asan2 amd64 5.4.0-6ubuntu1~16.04.4 [259 kB]
Get:14 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libx32asan2 amd64 5.4.0-6ubuntu1~16.04.4 [253 kB]
Get:15 http://it.archive.ubuntu.com/ubuntu xenial-updates/main amd64 lib32stdc++6 amd64 5.4.0-6ubuntu1~16.04.4 [404 kB]
Get:16 ...

Download full text (15.1 KiB)

luca@luca-ThinkPad-X220:~$ sudo apt install zlib1g-dev:i386
[sudo] password for luca:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-4.8.0-36 linux-headers-4.8.0-36-generic linux-image-4.8.0-36-generic
  linux-image-extra-4.8.0-36-generic python3-pip
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  gcc-6-base:i386 libc6:i386 libc6-dev:i386 libgcc1:i386 linux-libc-dev:i386 zlib1g:i386
Suggested packages:
  glibc-doc:i386 locales:i386 manpages-dev:i386
The following NEW packages will be installed:
  gcc-6-base:i386 libc6:i386 libc6-dev:i386 libgcc1:i386 linux-libc-dev:i386 zlib1g:i386
  zlib1g-dev:i386
0 upgraded, 7 newly installed, 0 to remove and 6 not upgraded.
Need to get 5.065 kB of archives.
After this operation, 24,6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://it.archive.ubuntu.com/ubuntu xenial/main i386 gcc-6-base i386 6.0.1-0ubuntu1 [14,3 kB]
Get:2 http://it.archive.ubuntu.com/ubuntu xenial/main i386 libgcc1 i386 1:6.0.1-0ubuntu1 [46,8 kB]
Get:3 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 libc6 i386 2.23-0ubuntu7 [2.275 kB]
Get:4 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 zlib1g i386 1:1.2.8.dfsg-2ubuntu4.1 [52,1 kB]
Get:5 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 linux-libc-dev i386 4.4.0-78.99 [838 kB]
Get:6 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 libc6-dev i386 2.23-0ubuntu7 [1.673 kB]
Get:7 http://it.archive.ubuntu.com/ubuntu xenial-updates/main i386 zlib1g-dev i386 1:1.2.8.dfsg-2ubuntu4.1 [167 kB]
Fetched 5.065 kB in 6s (774 kB/s)
Preconfiguring packages ...
Selecting previously unselected package gcc-6-base:i386.
(Reading database ... 271591 files and directories currently installed.)
Preparing to unpack .../gcc-6-base_6.0.1-0ubuntu1_i386.deb ...
Unpacking gcc-6-base:i386 (6.0.1-0ubuntu1) ...
Selecting previously unselected package libgcc1:i386.
Preparing to unpack .../libgcc1_1%3a6.0.1-0ubuntu1_i386.deb ...
Unpacking libgcc1:i386 (1:6.0.1-0ubuntu1) ...
Selecting previously unselected package libc6:i386.
Preparing to unpack .../libc6_2.23-0ubuntu7_i386.deb ...
Unpacking libc6:i386 (2.23-0ubuntu7) ...
Selecting previously unselected package zlib1g:i386.
Preparing to unpack .../zlib1g_1%3a1.2.8.dfsg-2ubuntu4.1_i386.deb ...
Unpacking zlib1g:i386 (1:1.2.8.dfsg-2ubuntu4.1) ...
Selecting previously unselected package linux-libc-dev:i386.
Preparing to unpack .../linux-libc-dev_4.4.0-78.99_i386.deb ...
Unpacking linux-libc-dev:i386 (4.4.0-78.99) ...
Selecting previously unselected package libc6-dev:i386.
Preparing to unpack .../libc6-dev_2.23-0ubuntu7_i386.deb ...
Unpacking libc6-dev:i386 (2.23-0ubuntu7) ...
Selecting previously unselected package zlib1g-dev:i386.
Preparing to unpack .../zlib1g-dev_1%3a1.2.8.dfsg-2ubuntu4.1_i386.deb ...
Unpacking zlib1g-dev:i386 (1:1.2.8.dfsg-2ubuntu4.1) ...
Processing triggers for libc-bin (2.23-0ubuntu7) ...
Processing triggers...

To post a comment you must log in.