upgrade from 19.04 to 19.10 fails to upgrade zfsutils-linux package

Bug #1851314 reported by Jay R. Wren
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
Won't Fix
Colin Ian King

Bug Description

# apt get upgrade tells me:

The following packages have been kept back:
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

But I'm pretty sure I need the newer 0.8.1-1ubuntu14 package because the previous version 0.7.12-1ubuntu5 zfs command fails:

zfs: symbol lookup error: zfs: undefined symbol: libzfs_dataset_cmp

When I try to ask for the kept back page to be upgraded:

# apt dist-upgrade -y zfsutils-linux

The following packages have unmet dependencies:
 zfsutils-linux : Conflicts: insserv (< 1.18) but 1.14.0-5ubuntu3 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I really don't understand the <1.18 when 1.14.0 looks less than 1.18.

Is there a workaround?

whoa... on a whim, I tried apt-get instead of apt. It seems to have worked.

$ sudo apt-get install zfsutils-linux

I'm filing this bug so that others may find this work around.

Revision history for this message
Colin Ian King (colin-king) wrote :

I believe this because apt-get update resolved this and it's not a bug per-se with zfs. Thank you for reporting this issue.

Changed in zfs-linux (Ubuntu):
importance: Undecided → Low
status: New → Won't Fix
assignee: nobody → Colin Ian King (colin-king)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.