Prevent bpool (or pools with /BOOT/) to be upgraded

Bug #1847389 reported by BertN45 on 2019-10-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
Undecided
Unassigned

Bug Description

The bpool status is confusing. Should I upgrade the pool or is it on purpose that the bpool is like this. I do no like to see this warning after installing the system on ZFS from scratch.

See screenshot

Richard Laager (rlaager) wrote :

Do NOT upgrade your bpool.

The dangerous warning is a known issue. There has been talk of an upstream feature that would allow a nice fix for this, but nobody has taken up implementing it yet. I wonder how hard it would be to temporarily patch zpool status / zpool upgrade to not warn about / upgrade a pool named bpool.

Didier Roche (didrocks) wrote :

We wrote on another bug report BertN45 to not upgrade your bpool. Only power users will use zpool status command to list and we expect them to know the implication.

I think I'll retarget this bug for preventing bpool upgrade.

summary: - Confusing zpool status in Ubuntu 19.10 installed onZFS
+ Prevent bpool (or pools with /BOOT/) to be upgraded
Max Jowi (maxjowi) wrote :

How exactly does it break booting?

I did a zpool upgrade bpool on two machines (one VM and one laptop) before reading this warning.
Both seems to boot just fine after the upgrade.

BertN45 (lammert-nijhof) wrote :

Well the people involved in the design and maintenance Richard Laager and Didier Roche warned me NOT to upgrade, so I did not upgrade the pool. My bug was about the confusions caused by that message.

Richard Laager (rlaager) wrote :

If the pool has an _active_ (and not "read-only compatible") feature that GRUB does not understand, then GRUB will (correctly) refuse to load the pool. Accordingly, you will be unable to boot.

Some features go active immediately, and others need you to enable some filesystem-level feature or take some other action to go from enabled to active. The features that are left disabled in the upstream Root-on-ZFS HOWTO (that I manage) are disabled because GRUB does not support them. At best, you never use them and it's fine. At worst, you make one active and then you can't boot. Since you can't use them without breaking booting, there is no point in having them enabled.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.8.3-1ubuntu12

---------------
zfs-linux (0.8.3-1ubuntu12) focal; urgency=medium

  [ Jean-Baptiste Lallement ]
  [ Didier Roche ]
  * debian/patches/4100-disable-bpool-upgrade.patch:
    - On ubuntu, upgrade of bpool is disabled to prevent users to break their
      system by upgrading to features not supported by GRUB. (LP: #1847389)

 -- Jean-Baptiste Lallement <email address hidden> Tue, 14 Apr 2020 11:14:33 +0200

Changed in zfs-linux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers