zfs-linux 0.6.5.6-0ubuntu26 ADT test failure with linux-snapdragon 4.4.0-1107.112

Bug #1813749 reported by Kleber Sacilotto de Souza on 2019-01-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
ADT Testing failed with xenial/linux-snapdragon on:
    arm64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/arm64/z/zfs-linux/20190125_170958_97a22@/log.gz

The debian test script (debian/tests/kernel-smoke-test) doesn't load the zfs module causing the tests to fail.

[Test Case]
Run autopkgtest of zfs-linux package with xenial/linux-snapdragon kernel.

Alternatively one can install the zfs-dkms package, download the zfs-linux source from version 0.6.5.6-0ubuntu26 and run:
$ sudo ./debian/tests/kernel-smoke-test

Making sure the modules are not loaded before running the test manually.

[Fix]
The solution is to load the zfs module before starting the tests, as done by the test script shipped by the packages for Bionic and later series.

[Regression Potential]
Low. The fix changes only the debian test script, so no impact on regular users.

[Other Info]
The tests were not failing before. I suspect that's being caused by a change in the order that the packages are installed before the tests start. With previous ADT runs, the zfsutils-linux package was installed after zfs-dkms, so that caused systemd to start the zfs-import-scan service, which loaded the modules. On these later ADT failed runs, zfs-dkms is installed last, so the service is not reloaded and the modules stay unloaded.

tags: added: kernel-adt-failure
description: updated

Attaching patch based on ubuntu/xenial-devel branch.

Hello Kleber, or anyone else affected,

Accepted zfs-linux into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zfs-linux/0.6.5.6-0ubuntu27 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in zfs-linux (Ubuntu Xenial):
status: New → Fix Committed
description: updated
tags: added: verification-done-xenial

The verification of the Stable Release Update for zfs-linux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.6-0ubuntu27

---------------
zfs-linux (0.6.5.6-0ubuntu27) xenial; urgency=medium

  * Fix modules not loaded on debian tests (LP: #1813749)
    - ADT tests are failing with some Xenial packages because the zfs
      module is not loaded before the tests start. This can be fixed
      by loading the module on the main test script (kernel-smoke-test)
      as done by the package built for later series.

 -- Kleber Sacilotto de Souza <email address hidden> Tue, 29 Jan 2019 11:40:10 +0100

Changed in zfs-linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
tags: added: patch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers