Conflict between zfs-linux and s390-tools

Bug #1788314 reported by Stéphane Graber on 2018-08-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
s390-tools (Ubuntu)
Critical
Dimitri John Ledkov
zfs-linux (Ubuntu)
High
Unassigned

Bug Description

Not sure which of the two needs fixing, but there's a path conflict between zfs-linux and s390-tools which effectively prevents installing ZFS on s390x in cosmic.

(Reading database ... 83042 files and directories currently installed.)
Preparing to unpack .../zfsutils-linux_0.7.9-3ubuntu5_s390x.deb ...
Unpacking zfsutils-linux (0.7.9-3ubuntu5) ...
dpkg: error processing archive /var/cache/apt/archives/zfsutils-linux_0.7.9-3ubuntu5_s390x.deb (--unpack):
 trying to overwrite '/usr/share/initramfs-tools/hooks/zdev', which is also in package s390-tools 2.6.0-0ubuntu2
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/zfsutils-linux_0.7.9-3ubuntu5_s390x.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Exit request sent.

Changed in s390-tools (Ubuntu):
status: New → Triaged
Changed in zfs-linux (Ubuntu):
status: New → Triaged
Changed in s390-tools (Ubuntu):
importance: Undecided → High
Changed in zfs-linux (Ubuntu):
importance: Undecided → High
Changed in s390-tools (Ubuntu):
status: Triaged → Confirmed
importance: High → Critical
assignee: nobody → Dimitri John Ledkov (xnox)
Stéphane Graber (stgraber) wrote :

Closing the zfs task as this will be fixed in s390-tools.

Changed in zfs-linux (Ubuntu):
status: Triaged → Invalid
Colin Ian King (colin-king) wrote :

Thanks for the update on the zfs task.

Changed in s390-tools (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-tools - 2.6.0-0ubuntu3

---------------
s390-tools (2.6.0-0ubuntu3) cosmic; urgency=medium

  * Make initramfs-tools zdev hooks not conflict with zfs. LP: #1788314

 -- Dimitri John Ledkov <email address hidden> Wed, 22 Aug 2018 18:05:29 +0100

Changed in s390-tools (Ubuntu):
status: Fix Committed → Fix Released

Hello Stéphane, or anyone else affected,

Accepted lxd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lxd/3.0.2-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Dimitri John Ledkov (xnox) wrote :

  * Temporarily disable ZFS tests on s390x due to conflict between
    zfsutils-linux and s390-tools (LP: #1788314)

however bionic was never affected, and cosmic has been long fixed....

tags: added: verification-failed verification-failed-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers