libnvpair1linux doc contents have busted symlinks

Bug #1768777 reported by Ryan Harper on 2018-05-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
Low
Colin Ian King
Bionic
Undecided
Unassigned

Bug Description

== SRU Justification [BIONIC] ==

Upgrading from Xenial to Bionic causes broken symlinked changelog, COPYRIGHT and OPENSOLARIS.LICENSE.gz files because the zfs-doc file is missing.

== Fix ==

Add back the missing zfs-doc package, with this package the upgrade works correctly.

== Regression Potential ==

Minimal, this adds just a bunch of missing files that are missing from the default Bionic zfsutils-linux installation.

-------------------------------

% apt-cache policy libnvpair1linux
libnvpair1linux:
  Installed: 0.7.5-1ubuntu15
  Candidate: 0.7.5-1ubuntu15
  Version table:
 *** 0.7.5-1ubuntu15 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status

% lsb_release -rd
Description: Ubuntu 18.04 LTS
Release: 18.04

The symlinks are busted:

% ls -al
total 108
drwxr-xr-x 3 root root 4096 Apr 23 08:33 ./
drwxr-xr-x 1120 root root 36864 May 2 07:36 ../
lrwxrwxrwx 1 root root 38 Apr 17 04:18 changelog.Debian.gz -> ../libnvpair1linux/changelog.Debian.gz
-rw-r--r-- 1 root root 53854 Oct 6 2017 copyright
lrwxrwxrwx 1 root root 28 Apr 17 04:18 COPYRIGHT -> ../libnvpair1linux/COPYRIGHT
drwxr-xr-x 2 root root 4096 Apr 23 08:33 examples/
lrwxrwxrwx 1 root root 41 Apr 17 04:18 OPENSOLARIS.LICENSE.gz -> ../libnvpair1linux/OPENSOLARIS.LICENSE.gz
-rw-r--r-- 1 root root 684 Oct 6 2017 README.Debian

% zcat changelog.Debian.gz
gzip: changelog.Debian.gz: Too many levels of symbolic links

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: libnvpair1linux 0.7.5-1ubuntu15
ProcVersionSignature: Ubuntu 4.15.0-10.11-generic 4.15.3
Uname: Linux 4.15.0-10-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Thu May 3 03:47:57 2018
Dependencies:
 gcc-8-base 8-20180414-1ubuntu2
 libc6 2.27-3ubuntu1
 libgcc1 1:8-20180414-1ubuntu2
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: zfs-linux
UpgradeStatus: No upgrade log present (probably fresh install)

Ryan Harper (raharper) wrote :
Changed in zfs-linux (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
Changed in zfs-linux (Ubuntu):
assignee: nobody → Colin Ian King (colin-king)
Colin Ian King (colin-king) wrote :

Couple of notes:

1. This is not an issue with clean install of zfsutils-linux
2. Removing zfsutils-linux and an autoremove with a re-install fixes this
3. This occurs on an upgrade from a previous release if I understand the issue correctly.

Changed in zfs-linux (Ubuntu):
importance: Medium → Low
Colin Ian King (colin-king) wrote :

This seems to only occur with a Xenial -> Artful or Xenial -> Bionic upgrades and not Artful -> Bionic.

Yes; this was a an upgraded system.

On Thu, May 3, 2018 at 5:28 PM, Colin Ian King
<email address hidden> wrote:
> This seems to only occur with a Xenial -> Artful or Xenial -> Bionic
> upgrades and not Artful -> Bionic.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1768777
>
> Title:
> libnvpair1linux doc contents have busted symlinks
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/zfs-linux/+bug/1768777/+subscriptions

description: updated
description: updated

Hello Ryan, or anyone else affected,

Accepted zfs-linux into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zfs-linux/0.7.5-1ubuntu16 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zfs-linux (Ubuntu Bionic):
status: New → Fix Committed
Colin Ian King (colin-king) wrote :

Installed a Xenial server and then zfsutils-linux. Upgraded to Bionic with -proposed enabled and the symlinks are not broken with zfsutils-linux 0.7.5-1ubuntu16 - marking as verified

tags: added: verification-done-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.7.5-1ubuntu16

---------------
zfs-linux (0.7.5-1ubuntu16) bionic; urgency=medium

  * Add back missing zfs-doc package (LP: #1768777)
    - this was accidentally removed from Bionic, restore it
      to keep the doc symlinks sane.

 -- Colin Ian King <email address hidden> Thu, 3 May 2018 16:51:11 +0100

Changed in zfs-linux (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for zfs-linux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in zfs-linux (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers