zfs-share.service: Failed at step EXEC spawning /usr/bin/rm: No such file or directory

Bug #1684731 reported by Sung Jeho on 2017-04-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
High
Colin Ian King
Xenial
High
Colin Ian King
Yakkety
High
Colin Ian King
Zesty
High
Colin Ian King
Artful
High
Colin Ian King

Bug Description

== SRU Xenial, Yakkety, Zesty ==

[Justification]
The path to rm is incorrect and hence it won't remove the /etc/dfs/sharetab

[Fix]
Set correct path, use /bin/rm and not /usr/bin/rm

[Test Case]
Without the fix, /etc/dfs/sharetab is not removed. With the fix, it is removed. To test, touch /etc/dfs/sharetab and it should be removed on startup of the zfs share service.

With the fix:
$ systemctl status zfs-share.service

● zfs-share.service - ZFS file system shares
   Loaded: loaded (/lib/systemd/system/zfs-share.service; enabled; vendor preset
   Active: active (exited) since Wed 2017-05-31 14:22:31 BST; 11s ago
  Process: 2483 ExecStart=/sbin/zfs share -a (code=exited, status=0/SUCCESS)
  Process: 2476 ExecStartPre=/bin/rm -f /etc/dfs/sharetab (code=exited, status=0
 Main PID: 2483 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   Memory: 0B
      CPU: 0
   CGroup: /system.slice/zfs-share.service

[Regression Potenial]
Minimal, this affects the removal of a file that should be fixed. The only regression risk is if somebody is depending on this file, which they should not be doing so.

wrong `rm` path on /lib/systemd/system/zfs-share.service

    ExecStartPre=-/usr/bin/rm -f /etc/dfs/sharetab

there is no file such /usr/bin/rm

Colin Ian King (colin-king) wrote :

Which release of Ubuntu and version of zfs are you using?

Changed in zfs-linux (Ubuntu):
assignee: nobody → Colin Ian King (colin-king)
importance: Undecided → Medium
status: New → In Progress
status: In Progress → Incomplete
Colin Ian King (colin-king) wrote :

/usr/bin/rm should be /bin/rm

Sung Jeho (jehos) wrote :

in Ubuntu 17.04,

Also tracked in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=842237 , where it was prematurely closed.

James Bowery (jabowery) wrote :

Affecting my 17.04 system.

`May 10 12:22:08 ... systemd[2146]: zfs-share.service: Failed at step EXEC spawning /usr/bin/rm: No such file or directory`

Changed in zfs-linux (Ubuntu):
status: Incomplete → In Progress
Colin Ian King (colin-king) wrote :

I've uploaded a fixed version of zfsutils into a PPA for testing before I upload it for a Stable Release Update.

If you don't mind testing these, please do the following:

sudo add-apt-repository ppa:colin-king/zfs-sru
sudo apt-get update
sudo apt-get dist-upgrade

and let me know if this fixes the issue.

Changed in zfs-linux (Ubuntu):
status: In Progress → Incomplete
importance: Medium → High
Sung Jeho (jehos) wrote :

Sure, Thanks. I'll try it.

Changed in zfs-linux (Ubuntu Zesty):
importance: Undecided → High
Changed in zfs-linux (Ubuntu Xenial):
importance: Undecided → High
Changed in zfs-linux (Ubuntu Yakkety):
importance: Undecided → High
Changed in zfs-linux (Ubuntu Xenial):
assignee: nobody → Colin Ian King (colin-king)
Changed in zfs-linux (Ubuntu Yakkety):
assignee: nobody → Colin Ian King (colin-king)
Changed in zfs-linux (Ubuntu Zesty):
assignee: nobody → Colin Ian King (colin-king)

Hello Sung, or anyone else affected,

Accepted zfs-linux into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zfs-linux/0.6.5.9-5ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zfs-linux (Ubuntu Zesty):
status: New → Fix Committed
Changed in zfs-linux (Ubuntu Yakkety):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Sung, or anyone else affected,

Accepted zfs-linux into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zfs-linux/0.6.5.8-0ubuntu4.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zfs-linux (Ubuntu Xenial):
status: New → Fix Committed
Andy Whitcroft (apw) wrote :

Hello Sung, or anyone else affected,

Accepted zfs-linux into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zfs-linux/0.6.5.6-0ubuntu17 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.9-5ubuntu6

---------------
zfs-linux (0.6.5.9-5ubuntu6) artful; urgency=medium

  * Fix incorrect path to rm in zfs-share.service.in (LP: #1684731)

 -- Colin Ian King <email address hidden> Mon, 22 May 2017 17:13:44 +0100

Changed in zfs-linux (Ubuntu Artful):
status: Incomplete → Fix Released
Colin Ian King (colin-king) wrote :

Verified with ubuntu Zesty 17.04 with zfsutils-linux 0.6.5.9-5ubuntu4.1 with ZFS shared over NFS, rm now works:

systemctl status zfs-share.service
● zfs-share.service - ZFS file system shares
   Loaded: loaded (/lib/systemd/system/zfs-share.service; enabled; vendor preset
   Active: active (exited) since Wed 2017-05-31 14:22:31 BST; 6min ago
  Process: 2483 ExecStart=/sbin/zfs share -a (code=exited, status=0/SUCCESS)
  Process: 2476 ExecStartPre=/bin/rm -f /etc/dfs/sharetab (code=exited, status=0
 Main PID: 2483 (code=exited, status=0/SUCCESS)
    Tasks: 0 (limit: 4915)
   Memory: 0B
      CPU: 0
   CGroup: /system.slice/zfs-share.service

description: updated
tags: added: verification-done-zesty
Colin Ian King (colin-king) wrote :

With 16.10 and 16.04 with nfs shared I can't reproduce this with the -proposed fixes either.

tags: added: verification-done verification-done-xenial verification-done-yakkety
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.9-5ubuntu4.1

---------------
zfs-linux (0.6.5.9-5ubuntu4.1) zesty; urgency=medium

  * Fix incorrect path to rm in zfs-share.service.in (LP: #1684731)

 -- Colin Ian King <email address hidden> Mon, 22 May 2017 17:13:44 +0100

Changed in zfs-linux (Ubuntu Zesty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for zfs-linux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.8-0ubuntu4.3

---------------
zfs-linux (0.6.5.8-0ubuntu4.3) yakkety; urgency=low

  * Fix incorrect path to rm in zfs-share.service.in (LP: #1684731)

 -- Colin Ian King <email address hidden> Mon, 22 May 2017 17:13:44 +0100

Changed in zfs-linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.6-0ubuntu17

---------------
zfs-linux (0.6.5.6-0ubuntu17) xenial; urgency=medium

  * Fix incorrect path to rm in zfs-share.service.in (LP: #1684731)
  * Set zfs-share.service to Wants in zfs.target (LP: #1614789)
    - Change from Requires to Wants to stop systemctl mask
      zfs-share.service from breaking zfs mounts

 -- Colin Ian King <email address hidden> Mon, 22 May 2017 17:13:44 +0100

Changed in zfs-linux (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.