Upgrading zfs-initramfs breaks booting from a zfs root

Bug #1673197 reported by Michał Sawicz on 2017-03-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
zfs-linux (Debian)
Fix Released
Unknown
zfs-linux (Ubuntu)
Critical
Aron Xu

Bug Description

Upgrading to zfs-initramfs 0.6.5.9-4ubuntu1 breaks my boot.

I've EFI and a small ext2 boot partition, and the rest of my SDD is a zfs pool. After upgrade I'm dropped in the initramfs shell and no zpools are available.

Downgrading to 0.6.5.8-0ubuntu9 makes it boot again.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: zfs-initramfs 0.6.5.9-4ubuntu1
ProcVersionSignature: Ubuntu 4.10.0-11.13-generic 4.10.1
Uname: Linux 4.10.0-11-generic x86_64
NonfreeKernelModules: zfs zunicode zavl zcommon znvpair
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity:Unity7
Date: Wed Mar 15 18:29:04 2017
InstallationDate: Installed on 2016-05-06 (312 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: zfs-linux
UpgradeStatus: Upgraded to zesty on 2016-11-22 (113 days ago)

Michał Sawicz (saviq) wrote :
description: updated
tags: added: kernel-key
Aron Xu (happyaron) wrote :

I'm setting up a test environment to debug this.

Changed in zfs-linux (Ubuntu):
assignee: nobody → Aron Xu (happyaron)
status: New → In Progress
Randall Leeds (randall-leeds) wrote :

I don't know what changed, but adding `boot=zfs` to my grub kernel parameters fixes this. I never needed it in the past and `update-grub` doesn't create it.

Randall Leeds (randall-leeds) wrote :

I just happened to find that parameter mentioned in some ZFS root setup guides and tried it as a wild guess.

Randall Leeds (randall-leeds) wrote :

Maybe this is some regression in zfs-initramfs?

I see some mention of this in https://bugs.launchpad.net/ubuntu/+source/zfs-initramfs/+bug/1530953
I don

Randall Leeds (randall-leeds) wrote :

My last comment got cut off. I was going to say I don't see /usr/share/initramfs-tools/conf.d/zfs on my filesystem.

Richard Laager (rlaager) wrote :

/usr/share/initramfs-tools/conf.d/zfs has disappeared from the package in zesty. That is the cause of this regression.

Changed in zfs-linux (Debian):
status: Unknown → Fix Released
Aron Xu (happyaron) on 2017-03-20
Changed in zfs-linux (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.9-5ubuntu1

---------------
zfs-linux (0.6.5.9-5ubuntu1) zesty; urgency=medium

  * Resynchronize with Debian, remianing changes:
    - Load zfs module unconditionally for zesty

 -- Aron Xu <email address hidden> Mon, 20 Mar 2017 11:24:41 +0800

Changed in zfs-linux (Ubuntu):
status: Fix Committed → Fix Released
Randall Leeds (randall-leeds) wrote :

Confirmed fixed over here. Thanks for the fast turnaround!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.