[SRU] zfs-linux should be using python3 for python userspace tools

Bug #1627909 reported by Colin Ian King on 2016-09-27
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
Critical
Colin Ian King
Xenial
Critical
Colin Ian King
Yakkety
Critical
Colin Ian King

Bug Description

SRU REQUEST, Xenial

[IMPACT]
dbufstat.py arc_summary.py arcstat.py should be using python3 rather than the older python2

[Test case]
running these ZFS helper tools should run with w/o python2 installed (and instead work with python3)

[Regression potential]
These helper scripts for checking ZFS state won't work if we regress. However it will not affect overall ZFS per se as these scripts are useful utilities and not part of the core ZFS functionality. Risk to ZFS core functionality on this SRU is therefore zero.

Changed in zfs-linux (Ubuntu):
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Colin Ian King (colin-king)
Richard Laager (rlaager) wrote :

As we discussed, this should just be a matter of changing the package dependency. The actual scripts support Python 3.

This assumes that the python3 package is using the alternatives system such that /usr/bin/python will still exist on a python3-only system.

description: updated
Dustin Kirkland  (kirkland) wrote :

Elevating priority to "critical", as this is blocking zfs from landing in the default Ubuntu Server seed. Adding a task for Xenial, and marking this bug for SRU, as we want to bring this back to 16.04 as well. Thanks!

Changed in zfs-linux (Ubuntu Yakkety):
importance: Medium → Critical
Changed in zfs-linux (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Colin Ian King (colin-king)
summary: - zfs-linux should be using python3 for python userspace tools
+ [SRU] zfs-linux should be using python3 for python userspace tools
Tim Gardner (timg-tpi) on 2016-09-27
Changed in zfs-linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in zfs-linux (Ubuntu Yakkety):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.8-0ubuntu2

---------------
zfs-linux (0.6.5.8-0ubuntu2) yakkety; urgency=medium

  * Use python3 for arcstat.py, arc_summary.py & dbufstat.py (LP: #1627909)
    - update dependency to python3 and set paths to use python3

 -- Colin Ian King <email address hidden> Mon, 26 Sep 2016 18:49:12 -0500

Changed in zfs-linux (Ubuntu Yakkety):
status: Fix Committed → Fix Released

Hello Colin, or anyone else affected,

Accepted zfs-linux into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zfs-linux/0.6.5.6-0ubuntu13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Richard Laager (rlaager) on 2016-09-29
tags: added: verification-done
Richard Laager (rlaager) wrote :

I tested 0.6.5.6-0ubuntu13 on a Xenial system with no python2 installed; only python3. I did this by first upgrading the ZFS packages and then purging the python2 packages. All three scripts work as expected. I did a basic run of each with no arguments.

For the record, in case anyone has this same concern... I'm not in love with patching the scripts to use /usr/bin/python3, but that does seem to be necessary. When I removed python2, there is no /usr/bin/python. I had expected that the python3 package would use the alternatives mechanism to register /usr/bin/python, but that does not seem to be the case.

Accordingly, I have marked this verification-done.

Colin Ian King (colin-king) wrote :

Tested here, works for me too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.6-0ubuntu13

---------------
zfs-linux (0.6.5.6-0ubuntu13) xenial; urgency=medium

  * Use python3 for arcstat.py, arc_summary.py & dbufstat.py (LP: #1627909)
    - update dependency to python3 and set paths to use python3

 -- Colin Ian King <email address hidden> Tue, 26 Sep 2016 07:35:44 -0500

Changed in zfs-linux (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for zfs-linux has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers