ZFS: Set elevator=noop on disks in the root pool

Bug #1550301 reported by Richard Laager on 2016-02-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfs-linux (Ubuntu)
Medium
Colin Ian King
Xenial
Medium
Colin Ian King
Zesty
Undecided
Unassigned

Bug Description

ZFS-on-Linux has its own I/O scheduler, so it sets the "noop" elevator on whole disks used in a pool. https://github.com/zfsonlinux/zfs/issues/90

It does not set the scheduler for a disk if a partition is used in a pool out of respect for the possibility that there are non-ZFS partitions on the same disk. https://github.com/zfsonlinux/zfs/issues/152

For regular pools, the recommendation is to use whole disks. For a root pools, it's just the opposite. The typical case is that partitions are used. And, for root pools, it is unlikely that the same disks have non-ZFS filesystems.

The debdiff in comment #5 applies cleanly to the latest package and functions correctly. This is an important change for root-on-ZFS users. It has no effect on non-root-on-ZFS installs, because the code is only in the zfs-initramfs package.

Richard Laager (rlaager) wrote :
description: updated
description: updated

The attachment "zfs-scheduler.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in zfs-linux (Ubuntu):
importance: Undecided → Low
Richard Laager (rlaager) wrote :

This requires the -L flag to zpool status. It sounds like ZoL 0.6.5.6 will land in Xenial, so then this is good to go at that time too.

Richard Laager (rlaager) wrote :

ZoL 0.6.5.6 has landed, so this should be good to go. Note that it only affects zfs-initramfs. It doesn't affect any other use of ZFS.

Richard Laager (rlaager) wrote :
description: updated
summary: - ZFS: Set elevator=noop on disks in the root pool
+ [FFe] ZFS: Set elevator=noop on disks in the root pool
Martin Pitt (pitti) wrote :

I'd call this a bug fix. Adjusting title and unsubscribing release team. Please go ahead.

summary: - [FFe] ZFS: Set elevator=noop on disks in the root pool
+ ZFS: Set elevator=noop on disks in the root pool
Colin Ian King (colin-king) wrote :

I'll get this applied and uploaded today

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfs-linux - 0.6.5.6-0ubuntu8

---------------
zfs-linux (0.6.5.6-0ubuntu8) xenial; urgency=medium

  [ Richard Laager ]
  * zfs-initramfs: Set elevator=noop on disks used by the root pool.
    (LP: #1550301)

 -- Colin Ian King <email address hidden> Wed, 13 Apr 2016 11:44:39 +0100

Changed in zfs-linux (Ubuntu):
status: New → Fix Released
Richard Laager (rlaager) wrote :

This has regressed in Zesty, because someone replaced the zfs-initramfs script.

Changed in zfs-linux (Ubuntu):
status: Fix Released → Confirmed
Richard Laager (rlaager) on 2017-04-23
tags: added: regression-release zesty
removed: patch
Changed in zfs-linux (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Colin Ian King (colin-king)
importance: Low → Medium
Eric Desrochers (slashd) on 2017-08-04
Changed in zfs-linux (Ubuntu Xenial):
status: New → Fix Released
importance: Undecided → Medium
assignee: nobody → Colin Ian King (colin-king)
Changed in zfs-linux (Ubuntu Zesty):
status: New → Confirmed
Simon Quigley (tsimonq2) wrote :

Unsubscribing ~ubuntu-sponsors as there's nothing left to do. If that is incorrect, please feel free to resubscribe.

Colin Ian King (colin-king) wrote :

Since this affects root on ZFS and the original patch no longer applies (and ZFS on root) is not currently supported, I am reluctantly going to close is issue. If a clean fix for ZFS on root for newer Zesty+ initramfs scripts is available I am happy to re-apply them for newer releases. However, I am not going to forward port the original changes since the delta is too large and I am not able to test these (as we don't have ZFS on root by default).

Changed in zfs-linux (Ubuntu Zesty):
status: Confirmed → Won't Fix
Changed in zfs-linux (Ubuntu):
status: In Progress → Won't Fix
Richard Laager (rlaager) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers