zfcpdump-kernel update to v5.15

Bug #1965766 reported by Dimitri John Ledkov
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zfcpdump-kernel (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

zfcpdump-kernel update to v5.15

but first zfdump_config build needs to be fixed.

tags: added: block-proposed-jammy
description: updated
Changed in zfcpdump-kernel (Ubuntu):
status: New → In Progress
Revision history for this message
Frank Heimes (fheimes) wrote :

I can confirm that the zfcpdump-kernel package in version 5.15-0ubuntu1 located in jammy-proposed works fine on s390x.
I've dumped using an LPAR loading the previously prepared LUN that incl. the dumper.
A proper dump was written, that can be read, opened and analyzed.

$ apt-cache policy zfcpdump-kernel
zfcpdump-kernel:
  Installed: 5.15-0ubuntu1
  Candidate: 5.15-0ubuntu1
  Version table:
 *** 5.15-0ubuntu1 500
        500 http://us.ports.ubuntu.com/ubuntu-ports jammy-proposed/universe s390x Packages
        100 /var/lib/dpkg/status
     5.4-0ubuntu2 500
        500 http://ports.ubuntu.com/ubuntu-ports jammy/universe s390x Packages

$ sudo zgetdump -i /dev/mapper/mpatha-part1
General dump info:
  Dump format........: elf
  Version............: 1
  UTS node name......: zbox
  UTS kernel release.: 5.15.0-23-generic
  UTS kernel version.: #23-Ubuntu SMP Fri Mar 11 14:53:58 UTC 2022
  System arch........: s390x (64 bit)
  CPU count (online).: 8
  Dump memory range..: 32768 MB

Memory map:
  0000000000000000 - 00000007ffffffff (32768 MB)

(more details see attachment)

tags: removed: block-proposed-jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfcpdump-kernel - 5.15-0ubuntu1

---------------
zfcpdump-kernel (5.15-0ubuntu1) jammy; urgency=medium

  * Switch to 5.15 base from jammy (5.15.0_5.15.0-23.23) LP: #1965766
  * Switch to debhelper 13
  * Bump standards version
  * Fix typpos in debian/copyright
  * Correct Canonical license, packaging follows upstream source code
    license
  * Improve update script to generate correct packaging data, irrespective
    of the input .deb filename
  * Generate correct Built-Using header using source package name, not
    binary
  * Apply a patch to unbreak the build
  * Use parallel build

 -- Dimitri John Ledkov <email address hidden> Mon, 21 Mar 2022 14:16:34 +0000

Changed in zfcpdump-kernel (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-hwe-5.15/5.15.0-25.25~20.04.1 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-oem-5.17/5.17.0-1004.4 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-jammy' to 'verification-done-jammy'. If the problem still exists, change the tag 'verification-needed-jammy' to 'verification-failed-jammy'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-jammy
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers