[19.04 FEAT] scsi: zfcp: add port speed capabilities (lib-zfcp-hbaapi)

Bug #1784643 reported by bugproxy on 2018-07-31
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Medium
Unassigned
zfcp-hbaapi (Ubuntu)
Undecided
Skipper Bug Screeners

Bug Description

Display support of FCP card with 32GB line speed

Will be made available with zfcp-hbaapi (aka libzfcphbaapi0).
https://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi.html
Currently not available,

Ticket will be updated once available

bugproxy (bugproxy) on 2018-07-31
tags: added: architecture-s39064 bugnameltc-170064 severity-high targetmilestone-inin1810
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → libhbaapi (Ubuntu)
Frank Heimes (frank-heimes) wrote :

Which version of the libhbaapi2 universe package is needed for that ?
There is currently 2.2.9-1 in cosmic.

tags: added: universe
Changed in ubuntu-z-systems:
importance: Undecided → Medium
status: New → Incomplete
Changed in libhbaapi (Ubuntu):
status: New → Incomplete

------- Comment From <email address hidden> 2018-08-27 08:48 EDT-------
This package upgrade will not make it into 18.10, therefore moved to 19.04 as target

tags: added: targetmilestone-inin1904
removed: targetmilestone-inin1810
summary: - [18.10 FEAT] scsi: zfcp: add port speed capabilities (lib-zfcp-hbaapi)
+ [19.04 FEAT] scsi: zfcp: add port speed capabilities (lib-zfcp-hbaapi)
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-08-27 09:54 EDT-------
To solve some confusions.
The request is related the libzfcpbaapi package.Which is available on developer works only as version 2.1.1 and inlcuded within Canonical releases.

NOT libhbaapi!

Dimitri John Ledkov (xnox) wrote :

Package name updated on launchpad.

affects: libhbaapi (Ubuntu) → zfcp-hbaapi (Ubuntu)
Frank Heimes (frank-heimes) wrote :

So it's about the zfcp-hbaapi (aka libzfcphbaapi0).

 zfcp-hbaapi | 2.1.1-0ubuntu1 | xenial/universe | source
 zfcp-hbaapi | 2.1.1-0ubuntu2 | bionic/universe | source
 zfcp-hbaapi | 2.1.1-0ubuntu2 | cosmic/universe | source

 libzfcphbaapi0 | 2.1.1-0ubuntu1 | xenial/universe | s390x
 libzfcphbaapi0 | 2.1.1-0ubuntu2 | bionic/universe | s390x
 libzfcphbaapi0 | 2.1.1-0ubuntu2 | cosmic/universe | s390x

Adjusting bug description accordingly.

description: updated
description: updated
Frank Heimes (frank-heimes) wrote :

As of Oct 25th zfcp HBA API library version 2.1.1 is still the latest at:
https://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi.html

Please let us know once a new version that includes "scsi: zfcp: add port speed capabilities" is available.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-11-27 08:21 EDT-------
*** Bug 173587 has been marked as a duplicate of this bug. ***

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-12-05 08:49 EDT-------
New version 2.2.0 will be made available here:
https://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi.html
Target Date : 2018-12-15.
Update will be provided here once available,
?

------- Comment on attachment From <email address hidden> 2018-12-11 03:48 EDT-------

lib-zfcp-hbaapi package. Finalized version, but currently not available via the download link from developerworks. This will happen beginning 2019.
But this package can be used.

Changed in ubuntu-z-systems:
status: Incomplete → Triaged
Changed in zfcp-hbaapi (Ubuntu):
status: Incomplete → New
information type: Private → Public

------- Comment From <email address hidden> 2019-02-08 07:13 EDT-------
Now library available externally..
https://www.ibm.com/developerworks/linux/linux390/zfcp-hbaapi.html
You can proceed now.... Thx

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zfcp-hbaapi - 2.2.0-0ubuntu1

---------------
zfcp-hbaapi (2.2.0-0ubuntu1) disco; urgency=medium

  * New upstream release LP: #1784643

 -- Dimitri John Ledkov <email address hidden> Fri, 08 Feb 2019 16:24:28 +0000

Changed in zfcp-hbaapi (Ubuntu):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: Triaged → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2019-02-11 03:44 EDT-------
IBM bugzilla status -> closed, Fix Released with disco

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments