zeromq3 FTBFS with zesty test rebuild

Bug #1679822 reported by Brian Murray on 2017-04-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zeromq3 (Ubuntu)
Undecided
Łukasz Zemczak

Bug Description

zeromq3 version 4.2.1-2ubuntu1 failed to build from source on armhf during a recent test rebuild for zesty. The build log can be found here:

https://launchpadlibrarian.net/312257088/buildlog_ubuntu-zesty-armhf.zeromq3_4.2.1-2ubuntu1_BUILDING.txt.gz

There seems to have been 1 test failure:

FAIL: tests/test_use_fd_tcp
===========================

lt-test_use_fd_tcp: tests/test_use_fd_tcp.cpp:59: void pre_allocate_sock(void*, const char*, const char*): Assertion `rc == 0' failed.
FAIL tests/test_use_fd_tcp (exit status: 134)

Changed in zeromq3 (Ubuntu):
assignee: nobody → Jeremy Bicha (jbicha)
Łukasz Zemczak (sil2100) wrote :

Do we know it's a real failure, or maybe just a transient test failure? I vaguely remember the test suite not being entirely stable.

Jeremy Bicha (jbicha) on 2017-04-05
Changed in zeromq3 (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
Changed in zeromq3 (Ubuntu):
assignee: nobody → Łukasz Zemczak (sil2100)
Łukasz Zemczak (sil2100) wrote :

As I remembered - I asked doko to re-run the failed build and now it passed. The test suite would need some love to be made more reliable, but that's a different issue. Marking as Invalid.

Changed in zeromq3 (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers