[SRU] Backport zeromq3 4.2.0 to yakkety

Bug #1645308 reported by Łukasz Zemczak on 2016-11-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
zeromq3 (Ubuntu)
Medium
Unassigned
Yakkety
Medium
Łukasz Zemczak

Bug Description

[Impact]

As per product requirement, we have released a git-snapshot based pre-release version of zeromq3 4.2.0 to yakkety (4.1.5+git20160811+2fc86bc) as the upstream version was not yet available. The agreement was that we will release the snapshot-based version only if, once the official update is available we will update and switch.

The rationale for this would be that the snapshot-based version is anyway more-or-less feature compatible with the official version. It's also not wise to keep shipping a snapshot for long as some bugfixes might be missing from the cherry-pick. The generated binaries are binary-compatible, with only a few new symbols exported in the main 4.2.0 version.

[Test Case]

No particular test-case - installing the new version and making sure that existing reverse-dependencies still work as intended.

[Regression Potential]

There is, of course, some regression potential, but as already mentioned: there weren't too many commits since the git snapshot that our previous version was based off.

Changed in zeromq3 (Ubuntu Yakkety):
importance: Undecided → Medium
status: New → In Progress
Changed in zeromq3 (Ubuntu):
status: New → Fix Released
Changed in zeromq3 (Ubuntu Yakkety):
assignee: nobody → Łukasz Zemczak (sil2100)
Brian Murray (brian-murray) wrote :

This is blocked by the fact that 4.2.0 is stuck in zesty-proposed.

Changed in zeromq3 (Ubuntu Yakkety):
status: In Progress → Incomplete

Hello Łukasz, or anyone else affected,

Accepted zeromq3 into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/zeromq3/4.2.0-2ubuntu0.16.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in zeromq3 (Ubuntu Yakkety):
status: Incomplete → Fix Committed
tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers