Cryptic error message when trying to install "Tasklist" from the ROX desktop

Bug #366333 reported by melkart on 2009-04-24
Affects Status Importance Assigned to Milestone
zeroinstall-injector (Ubuntu)

Bug Description

Binary package hint: zeroinstall-injector

On Ubuntu 9.04, I install zeroinstall-injector, download ROX-All from, unpack
it, run "./rox", add ROX to login. (after having set up my root account, so
I can enter a root password)

Then I log in into ROX desktop. When I drag and drop apps/Utility/Tasklist
on the panel, I get an error as shown in the following screenshot:

Zeroinstall is version 0.39-1ubuntu1

melkart (jfh) wrote :
Thomas Leonard (talex5) wrote :

Looks like downloads from FTP sites don't work when used with Python 2.6. Does the version below fix it?

Thomas Leonard (talex5) wrote :

0.40 is now in Debian/unstable. Since this was mostly a bug-fix release anyway, it may be best to sync from there. The release notes are here:

Alternatively, the patch is here:;h=c085406f4f73564869fad6b7c859b10e79c8ec7f

(the comment is misleading; the problem was originally seen on FreeBSD, but now affects Ubuntu too)

Let me know if a debdiff would be better than syncing from Debian.

Changed in zeroinstall-injector (Ubuntu):
status: New → Confirmed
Thomas Leonard (talex5) wrote :

Another bug report about this:

What's the process to get the fixed version into the archive?

Thomas Leonard (talex5) wrote :

Fixed in 9.10 I guess.

Changed in zeroinstall-injector (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers