Ubuntu

[FFe][jaunty] Please sync zeroinstall-injector 0.39 (universe) from Debian unstable (main)

Reported by Thomas Leonard on 2009-03-01
6
Affects Status Importance Assigned to Milestone
zeroinstall-injector (Ubuntu)
Low
Unassigned
Nominated for Jaunty by Thomas Leonard

Bug Description

Binary package hint: zeroinstall-injector

Jaunty has dropped support for part of the freedesktop.org notification system, and can now only display simple messages (not messages with buttons, like "Updates available. [Download]"):

 http://www.markshuttleworth.com/archives/265

The latest upstream GIT version detects this and uses the system tray instead.

Rocko (rockorequin) wrote :
Thomas Leonard (talex5) wrote :

Not quite. This bug is about moving from notifications to using the system tray. That bug is about another change: moving from using the system tray to using unfocussed windows. Probably best to see how people react to the new UI in Update Manager before doing the same thing to Zero Install.

Thomas Leonard (talex5) wrote :

A new version using the system tray is now available here:

http://mentors.debian.net/debian/pool/main/z/zeroinstall-injector/

Thomas Leonard (talex5) wrote :

Please take the fixed zeroinstall-injector_0.39-1_all.deb from Debian/unstable.

http://packages.qa.debian.org/z/zeroinstall-injector/news/20090315T220302Z.html

Thanks,

Changed in zeroinstall-injector (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Thomas Leonard (talex5) wrote :

Fix is in Debian, so status should be "Fix Committed", I think. Please sync from there.

Changed in zeroinstall-injector:
status: Triaged → Fix Committed
Thomas Leonard (talex5) wrote :

Note: the version currently in Jaunty also displays a lot of deprecation warnings due to the upgrade to Python 2.6. Using the Debian version would fix those too.

Thomas Leonard (talex5) wrote :

(changed status to Confirmed, as suggested on #ubuntu-motu)

Changed in zeroinstall-injector:
status: Fix Committed → Confirmed
Thomas Leonard (talex5) wrote :

Requesting a freeze exception, as described in https://wiki.ubuntu.com/FreezeExceptionProcess.

Proposed changes:

Update to 0.39, since the version currently in Jaunty doesn't work (throws an exception when checking for updates due to removal of the actions feature from the notification service).

The changes between 0.37 and 0.39 are mainly bug-fixes. The release notes can be found here:

http://gnomefiles.org/version.php?soft_id=921

Non-bug-fix changes affecting Ubuntu in 0.38 and 0.39 are:

- New Swedish translation.
- New --message option to display a message in the window.
- New "audit" command for verifying all packages at once.

There are no rdepends on this package.

The package has been tested using Jaunty by running the program's test-gui test suite. This fails with the current 0.37 version, and passes with Debian's 0.39.

https://zero-install.svn.sourceforge.net/svnroot/zero-install/trunk/test-gui

If you need more information, please ask.

Steve Kowalik (stevenk) wrote :

Confirmed means the FFe is approved, so I've set the status back to New.

Changed in zeroinstall-injector (Ubuntu):
status: Confirmed → New
StefanPotyra (sistpoty) wrote :

I'm ok with it, ACK #1.

Iulian Udrea (iulian) wrote :

ACK #2

Exception granted.

Changed in zeroinstall-injector:
status: New → Confirmed
Iulian Udrea (iulian) wrote :

I have just subscribed UUS for sponsorship.

Thomas Leonard (talex5) wrote :

Thanks, Iulian. Do I need to do anything else, or will the sync happen automatically now?

Iulian Udrea (iulian) wrote :

It FTBFS:

rm -r /tmp/buildd/zeroinstall-injector-0.39/debian/zeroinstall-injector/usr/man
rm: cannot remove `/tmp/buildd/zeroinstall-injector-0.39/debian/zeroinstall-injector/usr/man': No such file or directory
make: *** [install] Error 1

Please don't hardcode. You can use something like:

find $(CURDIR)/debian/zeroinstall-injector -type d -empty -delete

Changed in zeroinstall-injector (Ubuntu):
status: Confirmed → Incomplete
Thomas Leonard (talex5) wrote :

Was a work-around for a problem with Python 2.5's distutils, I think. Looks like it's not needed with Python 2.6.

The attached patch should fix it (while still supporting 2.5 if necessary). The resulting binary package's contents are the same, according to debdiff.

Note that all previous versions have had this line, so presumably the version currently in Jaunty doesn't build either now.

Thomas Leonard (talex5) wrote :

Here's a better patch. The problem was that Python 2.6 installs to /usr/local by default:

https://lists.ubuntu.com/archives/ubuntu-devel/2009-February/027439.html

Thomas Leonard (talex5) wrote :

Should I upload a new deb to REVU, or is the debdiff enough?

Thanks,

UNSUBSCRIBE

Thomas Leonard (talex5) wrote :

Tested again today after updating to latest Jaunty using these commands:

dget http://ftp.de.debian.org/debian/pool/main/z/zeroinstall-injector/zeroinstall-injector_0.39-1.dsc
wget http://launchpadlibrarian.net/24830029/python2.6.debdiff
cd zeroinstall-injector-0.39/
patch -p1 < ../python2.6.debdiff
dpkg-buildpackage

It still works, so please apply.

Thanks,

StefanPotyra (sistpoty) wrote :

test-building/preparing to upload.

Oh, side note: I've added
  * FFe: LP: #336317.
to the changelog, so that this bug report is closed on upload. Hope you don't mind.

StefanPotyra (sistpoty) wrote :

uploaded, needs to get shoved through the queue.

Changed in zeroinstall-injector (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package zeroinstall-injector - 0.39-1ubuntu1

---------------
zeroinstall-injector (0.39-1ubuntu1) jaunty; urgency=low

  * Updated build for Python 2.6.
  * FFe: LP: #336317.

zeroinstall-injector (0.39-1) unstable; urgency=low

  * New upstream release.

zeroinstall-injector (0.38-1) unstable; urgency=low

  * New upstream release.

 -- Thomas Leonard <email address hidden> Sun, 05 Apr 2009 10:40:06 +0100

Changed in zeroinstall-injector (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers